PDA

View Full Version : Ver 6.1 5/27 & 5/28 nightlies problems



Steve
2005-05-29, 13:39
With the 5/27 and 5/28 nightlies, ver 6.1 of slim.exe is gobbling up all my
cpu's resources. System resources used by slim.exe rise to 99% and the
computer comes to a virtual halt (it takes minutes for ctrl-alt-delete to
take effect). I had not had this problem previously. I reverted back to the
05-18 nightly and the problem seems to be gone (i.e., system resources stay
below 10% most of the time with occasional bump ups to around 40%). This
problem may be related to the one reported max.spicer in the thread "Web
interface broken in 6.1", since one symptom I see is that the server cannot
load information since all its resources used already used.

I am running WinXP with a library of 16,476 tracks.

-Steve

HMSeattle
2005-05-29, 22:31
Are you running MusicMagic?

Steve
2005-05-30, 07:12
HMSeattle wrote:
> Are you running MusicMagic?

Yes.

HMSeattle
2005-05-30, 09:43
Thought so...

The problem is not directly related to SlimServer, per se. If you unload MusicMagic you will most likely not see the CPU spike in SlimServer. Its got something to do with the MM implementation in SS.

See this thread

http://forums.slimdevices.com/showthread.php?t=13958&page=1&pp=10&highlight=music+magic

Steve
2005-05-30, 11:01
HMSeattle wrote:
> The problem is not directly related to SlimServer, per se. If you
> unload MusicMagic you will most likely not see the CPU spike in
> SlimServer. Its got something to do with the MM implementation in SS.
>
> See this thread
>
> http://forums.slimdevices.com/showthread.php?t=13958&page=1&pp
> =10&highlight=music+magic

Well, it is odd that this was not a problem for me with version 6.01 or the
earlier version of 6.1 (05-18). I have been using MusicMatch for a while
with no major problems. Yes, I did see occasional spikes during scanning and
other times, but they did not bring my server down. I do not let MusicMatch
analyse the library on the my server. Rather I analyze new music on another
machine and archive it the tags before loading it onto the server. That seem
to eliminate most of the problems with earlier versions. However, the latest
nightlies seem to bring my machine down in a way that earlier versions did
not.

-Steve

mirage62
2005-06-01, 05:19
I have the same problem on a WinXP SP2. With 6.1 it was ok until the version from 18/5 or so, but lately the server goes to 100% CPU after some time and it stays there until I restart it.

All my files is scanned / analysed by MusicMagic, and I have no watch-folders active.

hunta
2005-06-01, 05:40
I never fully got to the bottom of this issue, but found that running as a service rather than via the SlimServer GUI is much quicker and got around the problem. I believe something was causing SS to keep requerying MM and had thought it was fixed in one of the nightlies (I've stuck with the main release so haven't tried it myself). kdf helped with the original thread so might well be able to shed more light.

mirage62
2005-06-03, 02:25
Does anyone have the SlimServer_v2005-05-18 6.1 version ?

It's not on the website anymore, and I've lost it myself after testing the latest version (the problem is still there, and it's there in the earliest version from 05-20 as well)

Thanks,
Peter

max.spicer
2005-06-03, 07:12
Does anyone have the SlimServer_v2005-05-18 6.1 version ?

It's not on the website anymore, and I've lost it myself after testing the latest version (the problem is still there, and it's there in the earliest version from 05-20 as well)
You could pull it out of the repository with something like svn update/checkout -r {20050519}. Note the 19 rather than 18 in that argument - it means the state that it was in at 00:00 on the 19th.

Not much help if you don't know or don't have subversion, in which case I apologise.

Max

Richie
2005-06-03, 10:21
> Does anyone have the SlimServer_v2005-05-18 6.1 version ?

I've still got a copy. I don't have a website to post it on though. If
you're really desperate for it let me know your email address and I'll
split it into chunks with WinRAR and I'll email it to you.

Richard

mirage62
2005-06-06, 01:30
Some more info about this:

I run SlimServer from a cmd-file (not service) on XP SP2
MusicMagic is done analysing, and SlimServer has scanned the files (the mmm-icon is present). I've set the update-inverval to 0 in the MusicMagic plugin setup page to disable further scanning.

The problems:
- the web-interface stops working, no response. I can start softsqueeze, and the SB1 is still on so the server is running.
- streaming stops, or playback stops anyway (a wma stream)
- wmadec seems to be using a lot of memory, and it's increasing.
- cpu goes to 100%, but not allways. When it does it's slimserver thats running at 100%, not MusicMagic

There's no errors in the log file (there is entrys but they are the same with or without MusicMagic running)

Later today I will try to verify that the 18/5 version is working, I hope to get it by email

If I can give any more info, please let me know.

Thanks,
Peter

mirage62
2005-06-08, 05:13
I've been running without any problems for more than 2 days now with the 6.1 18/5 version, so it seems that something gone wrong in the 19/5 version and foreward.

Can I suply any debug-info to help a solution of this problem ?

Peter