PDA

View Full Version : Trouble installing 6.0.2 slimserver on Debian Linux 2.2.20



meatWAD
2005-05-24, 16:08
Hello,
I installed slimserver 6.0.2 and it would not start. The error message suggested I run a script to build additional modules that were required by slimserver. The script is build-perl-modules.pl.

The script failed on the second package, DBI-1.46.
The error told me that it could not find Test/More.pm.
I am not a perl expert by any means, in fact I do not use perl much at all.
Here is what I did to fix this, first I downloaded the packages to install them manually. I got them from http://svn.slimdevices.com/vendor/src which is the same place the script gets the packages from.

Next I ran the Makefile.PL that comes with the DBI package and got the same error. What I did was go into the SlimServer_v6.0.2 directory, then into CPAN/Test. I then copied More.pm, Builder.pm and Simple.pm into a Test directory that was in my '@INC'. In my case this was /usr/share/perl/5.6.1/Test. Once I did this the DBI module installed successfully.

Not sure if this is the "correct" way to resolve this issue but it seems to have worked as Slimserver 6.0.2 comes up and runs just fine.

Maybe this will help someone else and if some of the perl experts out there care to comment on a better way to resolve this issue I am all ears.....


Peace
meatWAD

street_samurai
2005-06-03, 11:44
Hi Meatwad,

I'm by no means a Linux guru but I have successfully installed SlimServer on my Debian boxes. I originally installed it on a 2.2 box (then realized that its 400mhz celeron processor really didn't have the power to be a web, ftp, ssh and slimserver all at the same time), so i've installed it on my 2.4 Sarge box also.

I too got errors when running the setup scripts.

What I ended up doing was downloading the latest stable maintenace release cpan-arch: 6.0.3 build from here:

http://www.slimdevices.com/downloads/nightly/latest/6.0.3/

and not bothering with the setup script. I just ran ./slimserver and everything worked swimmingly.

I also used this startup script:

http://wiki.slimdevices.com/index.cgi?DebianStartupScript2

With some light modification it worked well.

I hesistated to reply to your post because I don't really know why this works without running the setup script... but it does. Since no one else has responded to your post... maybe this will help,

ss.

gorstk
2005-06-05, 11:16
street_samurai wrote:
> Hi Meatwad,
>
> I'm by no means a Linux guru but I have successfully installed
> SlimServer on my Debian boxes. I originally installed it on a 2.2 box
> (then realized that its 400mhz celeron processor really didn't have the
> power to be a web, ftp, ssh and slimserver all at the same time), so
> i've installed it on my 2.4 Sarge box also.

I was /just/ about doing the above on a 633mhz celeron, but then I
upgraded to a 1ghz pentium 3 for 25 pounds on ebay and ahvent looked back!

Is that not an option (either slot 1 or sock 478 or whateever it is seem
to be at a reasonable price)

I have a spare socket 478 633mhz celeron if you want that!

street_samurai
2005-06-06, 15:55
street_samurai wrote:[color=blue]
I have a spare socket 478 633mhz celeron if you want that!

Hehe, thanks for the offer.

I just picked up a 1.8ghz AMD off of craigslist (the Sarge box I mentioned above). I'm in the process of moving all my services (apache, qmail, ftp, ssh, and slimserver) to the new box. I'm sure it'll be much better!

ss.