PDA

View Full Version : Slimserver 5/24/2005 nightly and iTunes 4.8



Roy Owen
2005-05-24, 04:51
I've just done a clean install of the Slimserver 5/24/2005 nightly and the
iTunes plugin will not enable. This is on a test workstation not my main
server. Thought I'd do it here first. iTunes version 4.8.0.31<http://4.8.0.31>.
Any ideas on how to get it going? Thanks

--
Do meddle in the affairs of Dragons,
for you are crunchy and good with Tabasco.

Craig, James (IT)
2005-05-24, 05:00
Can you give any more information?
Like your OS etc. and a log file showing any errors?

and this is the 'iTunes' library scanner - not the 'iTunes update'
plugin?

(I have not had any problems with iTunes 4.8)

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

Roy Owen
2005-05-24, 05:10
OS is Windows XP SP2 latest patches.
Here is the logfile

2005-05-24 07:58:21.4791 Your data source needs to be configured.
Please open your web browser,
2005-05-24 07:58:21.4792 go to the following URL, and click on the
"Server Settings" link.

2005-05-24 07:58:21.4793 The URL to access SlimServer is now:
http://ROwen:9000/
2005-05-24 07:58:54.0058 Podcast: updateFeedNames urls:
2005-05-24 07:59:04.3182 Podcast: updateFeedNames urls:
2005-05-24 08:06:43.0312 Podcast: updateFeedNames urls:
2005-05-24 08:07:50.7656 iTunes: unable to find iTunes Music Library.xml.
2005-05-24 08:07:51.0312 DBI: Supressing periodic commit - no dirty items
2005-05-24 08:07:57.6309 Podcast: updateFeedNames urls:
2005-05-24 08:07:57.6372 iTunes: unable to find iTunes Music Library.xml.
2005-05-24 08:08:02.6562 iTunes: unable to find iTunes Music Library.xml.
2005-05-24 08:08:21.0322 DBI: Supressing periodic commit - no dirty items

I am unable to get the iTunes Library option to show up so I can set the
path to the iTunes library.

On 5/24/05, Craig, James (IT) <James.Craig (AT) morganstanley (DOT) com> wrote:
>
> Can you give any more information?
> Like your OS etc. and a log file showing any errors?
> and this is the 'iTunes' library scanner - not the 'iTunes update'
> plugin?
> (I have not had any problems with iTunes 4.8)
> *James *
> ------------------------------
>
> NOTICE: If received in error, please destroy and notify sender. Sender
> does not waive confidentiality or privilege, and use is prohibited.
>
>

Philip Downer
2005-05-24, 06:54
> I am unable to get the iTunes Library option to show up so I can set
the path to the iTunes library.

Just a quick check, but have you enabled the iTunes plugin? I seem to
remember that if the plugin has been disabled then the iTunes section
won't appear in the server settings.

Phil.

Roy Owen
2005-05-24, 07:03
It won't enable. I check the option box and as soon as the browser refershes
the check is gone.

On 5/24/05, Philip Downer <pdowner (AT) centroidal (DOT) com> wrote:
>
>
> > I am unable to get the iTunes Library option to show up so I can set
> the path to the iTunes library.
>
> Just a quick check, but have you enabled the iTunes plugin? I seem to
> remember that if the plugin has been disabled then the iTunes section
> won't appear in the server settings.
>
> Phil.
>

kdf
2005-05-24, 07:13
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> It won't enable. I check the option box and as soon as the browser refershes
> the check is gone.
>
>
the itunes section should be there no matter what. if not, then the code that
controls that was broken during the reworking a few weeks ago.

perhaps michael can explain more, if this is in fact, no longer the design.

-kdf

kdf
2005-05-24, 07:27
ah, yes, it appears I was ignored when I mentioned that the itunes settings tab
needs to always be on. disabling the plugin, removes the tab. thus, if the
plugin fails to init (ie when the xml file isn't found automatically) then the
plugin is disabled and the itunes settings tab (and any way to actually FIX the
xml find locations) is gone.

commenting out line 233 fixes the problem.

will merge this in for tomorrow's build.

-kdf

Roy Owen
2005-05-24, 07:39
Thanks kdf, I look forward with baited breath. BTW, I've also put in a
feature request at Apple to be able to specify the location of the library
file in iTunes as well.



On 5/24/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
>
> ah, yes, it appears I was ignored when I mentioned that the itunes
> settings tab
> needs to always be on. disabling the plugin, removes the tab. thus, if the
> plugin fails to init (ie when the xml file isn't found automatically) then
> the
> plugin is disabled and the itunes settings tab (and any way to actually
> FIX the
> xml find locations) is gone.
>
> commenting out line 233 fixes the problem.
>
> will merge this in for tomorrow's build.
>
> -kdf
>

kdf
2005-05-24, 07:52
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> Thanks kdf, I look forward with baited breath. BTW, I've also put in a
> feature request at Apple to be able to specify the location of the library
> file in iTunes as well.

yeah, they had an option for that at least sometime along the way, but they
ignored what you put in it.

the fix I've suggested for you will only work on first start. it appears that
once a plugin fails, it is added to the disabled list. Once disabled, there is
no way to create the itunes tab. This means this fix will not work for you
since you have already restarted the server since. However, the fix should
work if you erase your prefs (as if you were starting new like before). I'll
be filing a bug report on this problem.

-kdf

kdf
2005-05-24, 07:52
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> Thanks kdf, I look forward with baited breath. BTW, I've also put in a
> feature request at Apple to be able to specify the location of the library
> file in iTunes as well.

yeah, they had an option for that at least sometime along the way, but they
ignored what you put in it.

the fix I've suggested for you will only work on first start. it appears that
once a plugin fails, it is added to the disabled list. Once disabled, there is
no way to create the itunes tab. This means this fix will not work for you
since you have already restarted the server since. However, the fix should
work if you erase your prefs (as if you were starting new like before). I'll
be filing a bug report on this problem.

-kdf

Roy Owen
2005-05-24, 07:58
Shouldn't I be able to just open the prefs file and remove iTunes from the
disabled list?

On 5/24/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:
>
> > Thanks kdf, I look forward with baited breath. BTW, I've also put in a
> > feature request at Apple to be able to specify the location of the
> library
> > file in iTunes as well.
>
> yeah, they had an option for that at least sometime along the way, but
> they
> ignored what you put in it.
>
> the fix I've suggested for you will only work on first start. it appears
> that
> once a plugin fails, it is added to the disabled list. Once disabled,
> there is
> no way to create the itunes tab. This means this fix will not work for you
> since you have already restarted the server since. However, the fix should
> work if you erase your prefs (as if you were starting new like before).
> I'll
> be filing a bug report on this problem.
>
> -kdf
>

kdf
2005-05-24, 08:05
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> Shouldn't I be able to just open the prefs file and remove iTunes from the
> disabled list?

you can do that too.

Roy Owen
2005-05-24, 08:08
Okay, thanks.

On 5/24/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:
>
> > Shouldn't I be able to just open the prefs file and remove iTunes from
> the
> > disabled list?
>
> you can do that too.
>
>

mherger
2005-05-24, 08:21
> disabling the plugin, removes the tab. thus, if the

Should not. iTunes was adding the setting itself, independantly of the
disabled state, when enabled() was called. But though addGroups() is
called, the settings group isn't added. I'll have a look at it.

> commenting out line 233 fixes the problem.

Which file's line 233?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

kdf
2005-05-24, 08:30
Quoting Michael Herger <slim (AT) herger (DOT) net>:

> > disabling the plugin, removes the tab. thus, if the
>
> Should not. iTunes was adding the setting itself, independantly of the
> disabled state, when enabled() was called. But though addGroups() is
> called, the settings group isn't added. I'll have a look at it.

should not, and I had believe that was the case too until I tried it.
unfortunately, trying to fix it has just gotten annoying again. I'm going back
to my plan of just staying away from itunes. I've never understood why it had
some sort of special status, but had tried to follow my instructions. All that
itunes means to me directly is a headache.

>
> > commenting out line 233 fixes the problem.
>
> Which file's line 233?

iTunes.pm
and that doesn't actually work anyway. line 232 AND 233 would need to be
removed, which then means the use/not use settings are also present. it looks
as though delGroup is removing too much. But I gave up trying to keep track.

-kdf

mherger
2005-05-24, 08:45
> iTunes.pm
> and that doesn't actually work anyway. line 232 AND 233 would need to be
> removed, which then means the use/not use settings are also present. it
> looks as though delGroup is removing too much. But I gave up trying to
> keep track.

This would imho still be the best choice. Most users who don't care can
live with those settings. Those who need it, can't do without. What was
the inital behaviour, anyway?

I'm close to removing it from the filesystem - saves some memory, too :-)

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

kdf
2005-05-24, 13:01
Quoting Michael Herger <slim (AT) herger (DOT) net>:

> > iTunes.pm
> > and that doesn't actually work anyway. line 232 AND 233 would need to be
> > removed, which then means the use/not use settings are also present. it
> > looks as though delGroup is removing too much. But I gave up trying to
> > keep track.
>
> This would imho still be the best choice. Most users who don't care can
> live with those settings. Those who need it, can't do without. What was
> the inital behaviour, anyway?
>
> I'm close to removing it from the filesystem - saves some memory, too :-)
>
it is at Dean's request (CTO after all) that iTunes settings are always present.
use/don't use setting in server settings should only be present if itunes music
library is found and is readable. That was the last version of the design that
I had been given

-kdf

kdf
2005-05-24, 13:01
Quoting Michael Herger <slim (AT) herger (DOT) net>:

> > iTunes.pm
> > and that doesn't actually work anyway. line 232 AND 233 would need to be
> > removed, which then means the use/not use settings are also present. it
> > looks as though delGroup is removing too much. But I gave up trying to
> > keep track.
>
> This would imho still be the best choice. Most users who don't care can
> live with those settings. Those who need it, can't do without. What was
> the inital behaviour, anyway?
>
> I'm close to removing it from the filesystem - saves some memory, too :-)
>
it is at Dean's request (CTO after all) that iTunes settings are always present.
use/don't use setting in server settings should only be present if itunes music
library is found and is readable. That was the last version of the design that
I had been given

-kdf

kdf
2005-05-25, 00:29
Roy,

I've merged in the commented line at svn change 3290. Hopefully this will have
made it in time for today's build. Give that a try and let us know if this
gives you back the settings tab sso that you can reset the locations.

-kdf

Roy Owen
2005-05-25, 04:53
kdf,
I tried your fix and it didn't work. However I noticed that you commented
out line 232 in itunes.pl and not 233. If line 233 is comented out both the
use iTunes option and the iTunes tab appear in the web interface. (I
installed Active perl 2.8 to test).

On 5/25/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> Roy,
>
> I've merged in the commented line at svn change 3290. Hopefully this will
> have
> made it in time for today's build. Give that a try and let us know if this
> gives you back the settings tab sso that you can reset the locations.
>
> -kdf
>

kdf
2005-05-25, 06:25
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> kdf,
> I tried your fix and it didn't work. However I noticed that you commented
> out line 232 in itunes.pl and not 233. If line 233 is comented out both the
> use iTunes option and the iTunes tab appear in the web interface. (I
> installed Active perl 2.8 to test).

I know, but the the itunes option should only be there if everything is ok.
line 233 properly removes that, but really shouldn't remove the tab (even
though it does).

strangely, on windows, you shouldn't have had to change any itunes settings to
have it work based on a default itunes install. where is your itunes xml file?

-k

Roy Owen
2005-05-25, 06:33
On a networked (netware) drive. I don't start slimserver until after I've
logged into the network but for some reason it can't open the library file.
If I comment out line 233 and set up iTunes manually it works fine after
that.

On 5/25/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:
>
> > kdf,
> > I tried your fix and it didn't work. However I noticed that you
> commented
> > out line 232 in itunes.pl and not 233. If line 233 is comented out both
> the
> > use iTunes option and the iTunes tab appear in the web interface. (I
> > installed Active perl 2.8 to test).
>
> I know, but the the itunes option should only be there if everything is
> ok.
> line 233 properly removes that, but really shouldn't remove the tab (even
> though it does).
>
> strangely, on windows, you shouldn't have had to change any itunes
> settings to
> have it work based on a default itunes install. where is your itunes xml
> file?
>
> -k
>
>

kdf
2005-05-25, 08:11
Roy,

since you now have ActivePerl installed, could you try this patch and let me
know if that works. If you have to patch manually, it shouldn't be too bad
since its only 3 lines that are changing.

-kdf

Roy Owen
2005-05-25, 10:30
kdf,
I'm not sure how to read the diff file. I assume that I remove the lines
preceded by '-' and add the lines preceded by '+'?

On 5/25/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
>
> Roy,
>
> since you now have ActivePerl installed, could you try this patch and let
> me
> know if that works. If you have to patch manually, it shouldn't be too bad
> since its only 3 lines that are changing.
>
> -kdf
>
>
>

mherger
2005-05-25, 14:11
> I'm not sure how to read the diff file. I assume that I remove the lines
> preceded by '-' and add the lines preceded by '+'?

Exactly. You will see that you have to remove the - lines as the + lines
don't exist in your code ;-)

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

kdf
2005-05-26, 00:08
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> kdf,
> I'm not sure how to read the diff file. I assume that I remove the lines
> preceded by '-' and add the lines preceded by '+'?

that's exactly right :)

I'll be merging the fix soon anyway.

-kdf

Roy Owen
2005-05-26, 04:39
kdf,
That patch did not work.

On 5/26/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:
>
> > kdf,
> > I'm not sure how to read the diff file. I assume that I remove the lines
> > preceded by '-' and add the lines preceded by '+'?
>
> that's exactly right :)
>
> I'll be merging the fix soon anyway.
>
> -kdf
>

kdf
2005-05-26, 07:05
Thanks Roy. Best I can suggest at this point is to take a look at the latest
nightly. A slightly modified version of my patch, and one from Micheal Herger
should be fixing this problem, and preventing the plugin from being marked as
disabled when the library find fails. Best I can tell from simulating is that
it should be working.

sorry for all the fussing about.

-kdf

Roy Owen
2005-05-26, 07:14
Thanks for all your help

On 5/26/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
>
> Thanks Roy. Best I can suggest at this point is to take a look at the
> latest
> nightly. A slightly modified version of my patch, and one from Micheal
> Herger
> should be fixing this problem, and preventing the plugin from being marked
> as
> disabled when the library find fails. Best I can tell from simulating is
> that
> it should be working.
>
> sorry for all the fussing about.
>
> -kdf
>

Roy Owen
2005-05-26, 07:26
Just installed the latest nightly. I think it's working properly, I'll do
some further testing.

On 5/26/05, Roy Owen <yddraig (AT) gmail (DOT) com> wrote:
>
> Thanks for all your help
>
> On 5/26/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
> >
> >
> > Thanks Roy. Best I can suggest at this point is to take a look at the
> > latest
> > nightly. A slightly modified version of my patch, and one from Micheal
> > Herger
> > should be fixing this problem, and preventing the plugin from being
> > marked as
> > disabled when the library find fails. Best I can tell from simulating is
> > that
> > it should be working.
> >
> > sorry for all the fussing about.
> >
> > -kdf
> >

Roy Owen
2005-05-26, 07:36
iTunes is really broken now. I did a rescan with clear library checked and
now Slimserver can't locate any of my iTunes files. Also the Use iTunes
option on the main server settings page is mising.

On 5/26/05, Roy Owen <yddraig (AT) gmail (DOT) com> wrote:
>
> Just installed the latest nightly. I think it's working properly, I'll do
> some further testing.
>
> On 5/26/05, Roy Owen < yddraig (AT) gmail (DOT) com> wrote:
> >
> > Thanks for all your help
> >
> > On 5/26/05, kdf <slim-mail (AT) deane-freeman (DOT) com > wrote:
> > >
> > >
> > > Thanks Roy. Best I can suggest at this point is to take a look at the
> > > latest
> > > nightly. A slightly modified version of my patch, and one from Micheal
> > > Herger
> > > should be fixing this problem, and preventing the plugin from being
> > > marked as
> > > disabled when the library find fails. Best I can tell from simulating
> > > is that
> > > it should be working.
> > >
> > > sorry for all the fussing about.
> > >
> > > -kdf
> > >

kdf
2005-05-26, 07:47
have you disabled and re-enabled itunes plugin?

have you restarted the server?

if you have done both, and nothign works...then consider no longer using itunes.

I long since gave up on it myself
-kdf

Roy Owen
2005-05-26, 08:15
I suspect it's the fact that the iTunes Library.xml file is on a Netware
volume. It shouldn't be a problem for most people.

On 5/26/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> have you disabled and re-enabled itunes plugin?
>
> have you restarted the server?
>
> if you have done both, and nothign works...then consider no longer using
> itunes.
>
> I long since gave up on it myself
> -kdf
>

kdf
2005-05-27, 00:03
Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:

> I suspect it's the fact that the iTunes Library.xml file is on a Netware
> volume. It shouldn't be a problem for most people.

what does the d_itunes log look like? If it finds the xml file, you should be
getting the use itunes option on server settings. The settings tab should inly
disappear if you specifically disable the plugin in server settings->plugins

-k

Roy Owen
2005-06-01, 05:49
kdf,
When I started slim.exe from the command line (slim --logfile
SlimServer.log--d_itunes) it found everything like it was supposed to.
This indicates (to
me) a network/service issue. I guess I'll just place slim.exe in my windows
startup folder. Thanks for all your help.

On 5/27/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
>
> Quoting Roy Owen <yddraig (AT) gmail (DOT) com>:
>
> > I suspect it's the fact that the iTunes Library.xml file is on a Netware
> > volume. It shouldn't be a problem for most people.
>
> what does the d_itunes log look like? If it finds the xml file, you should
> be
> getting the use itunes option on server settings. The settings tab should
> inly
> disappear if you specifically disable the plugin in server
> settings->plugins
>
> -k
>