PDA

View Full Version : Bug 952 - ALBUM in variable artwork: How about a temporary fix?



JJZolx
2005-05-20, 12:20
http://bugs.slimdevices.com/show_bug.cgi?id=952

Any chance that this issue can be fixed? Is this just an issue of substitution for the token ALBUM or is _all_ variable artwork file naming broken?

From the bug dialog, it appears some thought is being given to changing the implmentation to make it more efficient. Until that's done, how about a fix for the way the current implementation is supposed to function?
________
Aprilia Pegaso 650 (http://www.cyclechaos.com/wiki/Aprilia_Pegaso_650)

kdf
2005-05-20, 12:24
Quoting JJZolx <JJZolx.1pchno (AT) no-mx (DOT) forums.slimdevices.com>:

>
> http://bugs.slimdevices.com/show_bug.cgi?id=952
>
> Any chance that this issue can be fixed? Is this just an issue of
> substitution for the token ALBUM or is _all_ variable artwork file
> naming broken?
>
> >From the bug dialog, it appears some thought is being given to changing
> the implmentation to make it more efficient. Until that's done, how
> about a fix for the way the current implementation is supposed to
> function?

it is all broken becuase the info isn't in the db at the time the server checks
artwork (which would require the info to be there when using any of the
infoFormat variables). The regex used in that case is horribly complicated.
Dan mentioned he had an idea, but is now known, the SqueezeNetwork has been
taking the time leading up to the recent release.

-kdf