PDA

View Full Version : How to play ape files under Linux



jeibie
2005-05-18, 04:46
Hi,

Ive asked same question under Linux forum but got no
answer until now.

Maybe I will get some answer here:

Is it possible to play ape files with slimserver
that runs under Linux?

I have a mac version running under Linux that creates
wav files but this is quite uncomfortable - is there
a bettter solution out?
Or have someone wrote any scripts to convert ape files
on the fly?

Thanks
Jeibie

Christian Pernegger
2005-05-18, 06:02
If you have a working mac binary in your path it should work out of
the box, assuming it's checked under "Home / Server Settings / File
Types".

Sources that will compile under Linux can be found here:
http://sourceforge.net/projects/mac-port/

One of the more recent builds had a problem where it required write
access even to files it was just decoding. If that bites you just use
an older version, or maybe it's fixed now.

C.

jeibie
2005-05-19, 12:00
Thanks, I must me blind not seeing ape extensions in slimserver
config...

I installed latest mac from sourceforge and it seems mac is now
running correct. Manually decoding ape to wav and playing with
winamp works correct.

But if I try to play ape file the only thing it came out of the
squeezebox is a strong noice.
Is this a problem with lame?
Btw the Linux system is Debian sid.

Thanks
Jeibie

Christian Pernegger
2005-05-19, 12:55
> Manually decoding ape to wav and playing with winamp works correct.
>
> But if I try to play ape file the only thing it came out of the squeezebox is a strong noice.

Are you saying you're transcoding to mp3?

Sounds like a byte-order problem anyway. In convert.conf there should
be an entry like:

ape mp3 * *
[mac] $FILE$ - -d | [lame] --resample 44100 -x --silent -q 9
-b $BITRATE$ - -

Try removing the '-x' option from the lame part of the command, see if it helps.

C.

jeibie
2005-05-19, 13:56
> Manually decoding ape to wav and playing with winamp works correct.
>
> But if I try to play ape file the only thing it came out of the squeezebox is a strong noice.

Are you saying you're transcoding to mp3?
yes, but thats default in convert.conf


Sounds like a byte-order problem anyway. In convert.conf there should
be an entry like:

ape mp3 * *
[mac] $FILE$ - -d | [lame] --resample 44100 -x --silent -q 9
-b $BITRATE$ - -

Try removing the '-x' option from the lame part of the command, see if it helps.


The man page of lame tells me the option of --resample is 44.1 and not 44100.
I changed that and no it works.
So it seems there is some problem with my lame version.

Thanks for your help.
jeibie