PDA

View Full Version : Slimserver won't start (mac)



natemorriss
2005-05-05, 19:16
I installed 6.0.1 and now 6.0.2 and neither version would start. I click the start button on the control panel it fades out and then after a while it comes back on. I tried one of the older beta versons and it started but I switched back to 5.4.1 because it shut down too much.

What can I do to install the software.

Details:
SliMP3
Mac os 10.3.9
iTunes
all music on external HD
Firmware 2.3

Please help...

Allan Hise
2005-05-06, 00:58
On Thu, 5 May 2005, natemorriss wrote:

> I installed 6.0.1 and now 6.0.2 and neither version would start. I
> click the start button on the control panel it fades out and then after
> a while it comes back on. I tried one of the older beta versons and it
> started but I switched back to 5.4.1 because it shut down too much.
>
> What can I do to install the software.
>
> Details:
> SliMP3
> Mac os 10.3.9
> iTunes
> all music on external HD
> Firmware 2.3
>
> Please help...

Anything in the log file?

natemorriss
2005-05-06, 02:41
Yes but I'm not sure what it means. There's a lot of begin failed...

This is the entire log file.

mkdir /Users/nmorriss/Music: File exists at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Utils/Prefs.pm line 115
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Plugins.pm line 20.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Plugins.pm line 20.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Common.pm line 15.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Common.pm line 15.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Settings.pm line 11.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Buttons/Settings.pm line 11.
Compilation failed in require at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Display/Display.pm line 14.
BEGIN failed--compilation aborted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Display/Display.pm line 14.
Compilation failed in require at ./slimserver.pl line 205.
BEGIN failed--compilation aborted at ./slimserver.pl line 205.

dean
2005-05-06, 08:17
Nate,

This may be related to a known bug having to do with the use of a Mac
alias for your music folder. Do you have an alias set up to point to
your music library?

-dean

On May 6, 2005, at 2:41 AM, natemorriss wrote:

>
> Yes but I'm not sure what it means. There's a lot of begin failed...
>
> This is the entire log file.
>
> mkdir /Users/nmorriss/Music: File exists at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Utils/Prefs.pm
> line 115
> Compilation failed in require at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Buttons/Plugins.pm
> line 20.
> BEGIN failed--compilation aborted at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Buttons/Plugins.pm
> line 20.
> Compilation failed in require at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Buttons/Common.pm
> line 15.
> BEGIN failed--compilation aborted at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Buttons/Common.pm
> line 15.
> Compilation failed in require at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Buttons/Settings.pm
> line 11.
> BEGIN failed--compilation aborted at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Buttons/Settings.pm
> line 11.
> Compilation failed in require at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Display/Display.pm
> line 14.
> BEGIN failed--compilation aborted at
> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
> Display/Display.pm
> line 14.
> Compilation failed in require at ./slimserver.pl line 205.
> BEGIN failed--compilation aborted at ./slimserver.pl line 205.
>
>
> --
> natemorriss
>

natemorriss
2005-05-06, 15:42
Dean-

I was suspecting something of the sort. I think I have a symbolic link not an alias though. Also the first beta of Slimserver version 6 worked. It just seemed to quit often.

Will I just checked and it does appear to be an alias. Is there a work around?

NATE

Dan Sully
2005-05-06, 17:32
* natemorriss shaped the electrons to say...

>Will I just checked and it does appear to be an alias. Is there a work around?

Yes - use a symlink instead.

-D
--
<iNoah> my pdp goes to 11.

natemorriss
2005-05-06, 18:42
I created a symlink and everything works great.

Thank you for helping me out.

NATE