PDA

View Full Version : MusicMagic and 6.02 - not working?



Simon Still
2005-05-04, 13:16
I'm trying to enable musicmagic in 6.02. I'm was never sure how it
worked in 6.01 (a lot of fiddling with server settings was needed
IIRC). Now in 6.02 when i try to enable the plugin the checkbox
unchecks when i hit "change" (ie, checkbox unchecked, check it, hit
change to 'save' - checkbox is unticked again).

kdf
2005-05-04, 13:26
1) you need a paid version of musicmagic, or at least an active trial key.

2) you need to enable the API service from musicmagic in the options section.

3) ideally musicmagic should be running before the server starts

4) d_musicmagic shows the connection attempts in the log, so that you can
confirm that the server is getting a proper response from musicmagic.

-kdf

Simon Still
2005-05-04, 14:25
On 5/4/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
> 1) you need a paid version of musicmagic, or at least an active trial key..
yes
> 2) you need to enable the API service from musicmagic in the options section.
yes (or at least it was before - i had it working under 6.01)
> 3) ideally musicmagic should be running before the server starts
I stopped the service and restarted it.
> 4) d_musicmagic shows the connection attempts in the log, so that you can
> confirm that the server is getting a proper response from musicmagic.

shows:
2005-05-04 22:22:32.3111 MusicMagic: Testing for API on localhost:10002
2005-05-04 22:22:37.3211 MusicMagic: Cannot Connect

strangely enough the api wasn't running in musicmagic. I wonder what
stopped it? That's the first time i've needed to touch it since i
installed it a month or so ago. Odd

Thanks kdf

kdf
2005-05-04, 14:36
Musicmagic is supposed to remember the state of the API. However if it crashes
for some reason, then it seems to get reset. I've had to check on it a few
times myself. There may be other things that cause it to turn off, but I
haven't isolated anything else. Sadly, there doesn't seem to be a way to force
it on as a command-line option.

-kdf

Simon Still
2005-05-04, 23:04
On 5/4/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
> Musicmagic is supposed to remember the state of the API. However if it crashes
> for some reason, then it seems to get reset. I've had to check on it a few
> times myself. There may be other things that cause it to turn off, but I
> haven't isolated anything else. Sadly, there doesn't seem to be a way to force
> it on as a command-line option.

Nor an option to run it as a service - my server is used for TV and
web browsing and since MM is an application it gets shut down
sometimes. Trying to use it on a SB, then having to go downstairs,
start MM, re-enable it in SlimServer kind of takes the fun out of it.