PDA

View Full Version : Softsqueeze dropouts



coldslabs
2005-05-03, 12:35
I've gotten my SoftSqueeze and SSH installation to function so I can
listen to music while I'm at work, but after a few songs Softsqueeze
stops, becomes unresponsive and I have to restart Sotsqueeze and
reconnect to get it working again. I've tested this from work with the
following configurations:

OSX 10.3
Java 1.42
Softsqueeze 2.0b6
JLayer

OSX 10.4
Java 1.42 and 1.5
Softsqueeze 2.0b6 and 2.0b3
JLayer and Java MP3 Plugin

WinXP
Java 1.5
Softsqueeze 2.0b6
JLayer
Primary sound Driver

In all cases I've been using SlimServer 6.01. The debug outputs below
are from my WinXP machine. Anyone have any suggestions or any idea of
what is going wrong? Please let me know if more info would be helpful.

++++++++++++++++++++++++
SoftSqueeze DEBUG outputs
++++++++++++++++++++++++
SoftSqueeze stopped playing. Had to reset to make it work.
--------------------------------
587137 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes written=4608
587137 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes read=0
587137 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes written=0
587137 [AudioDecoder-2] DEBUG javasound - decoder stopped
587637 [SlimTCP-1] DEBUG javasound - gain=0.6171875 dB=-4.1916575 max=6.0206
607715 [AudioMixer-0] DEBUG javasound - drain line inState=2
608434 [AudioMixer-0] DEBUG javasound - audio mixer paused (stopping
player) available=0
608434 [AudioMixer-0] DEBUG javasound - audio mixer paused (waiting)

==================================

softSqueeze stopped playing. had to reset to make it work.
------------------------------------------
473762 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=128000,open:true
473762 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
read=128000 bufLen=128000 fillLen=128000 available=1%
474512 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=128000,open:true
474512 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
read=51200 bufLen=51200 fillLen=128000 available=4%
474887 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=51200,open:true
474887 [AudioMixer-0] DEBUG javasound - drain line inState=2
475528 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
read=0 bufLen=0 fillLen=128000 available=17%
475528 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=0,open:true
475591 [AudioMixer-0] DEBUG javasound - audio mixer paused (stopping
player) available=0
475591 [AudioMixer-0] DEBUG javasound - audio mixer paused (waiting)

===================================

Softsqueeze stopped playing. Had to reset
---------------------------------
187593 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes read=4608
187593 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes written=4608
187593 [AudioDecoder-2] DEBUG player - buffer underrun;
audioStream=com.slim.softsqueeze.audio.AudioStream @174cb21
isOpen=closed
187593 [AudioDecoder-2] DEBUG player - status=STMd fullness=0
bytesRx=3361227 elapsedSeconds=188
187593 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes read=4608
187593 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes written=4608
187593 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes read=0
187593 [AudioDecoder-2] DEBUG javasound - decoderFrame: bytes written=0
187593 [AudioDecoder-2] DEBUG javasound - decoder stopped
188061 [SlimTCP-1] DEBUG player - audg leftLvl=79 rightLvl=79
188061 [SlimTCP-1] DEBUG javasound - gain=0.6171875 dB=-4.1916575 max=6.0206
188061 [SlimTCP-1] DEBUG player - httpRequest=GET
/stream.mp3?player=01:12:6e:d6:8b:a9 HTTP/1.0
188061 [SlimTCP-1] DEBUG player - parsed strm: command=s format=109
crossfade=0 ipaddr=127.0.0.1 port=9000
file=/stream.mp3?player=01:12:6e:d6:8b:a9 authType=null
authPassword=null autostart=1
188061 [SlimTCP-1] DEBUG player - connect: state 2
188061 [SlimTCP-1] DEBUG player - status=STMc fullness=0
bytesRx=3361227 elapsedSeconds=189
188061 [SlimTCP-1] DEBUG player - status=STMh fullness=0
bytesRx=3361227 elapsedSeconds=189
208171 [AudioMixer-0] DEBUG player - buffer underrun;
audioStream=com.slim.softsqueeze.audio.AudioStream @174cb21
isOpen=closed
208171 [AudioMixer-0] DEBUG javasound - drain line inState=2
208889 [AudioMixer-0] DEBUG player - status=STMu fullness=0 bytesRx=0
elapsedSeconds=210
208952 [AudioMixer-0] DEBUG javasound - audio mixer paused (stopping
player) available=0
208952 [AudioMixer-0] DEBUG javasound - audio mixer paused (waiting)

===============================================

softsqueeze stopped playing. Had to reset.
-----------------------------------
186686 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=128000,open:true
186686 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=36864000
W=37057536 A=193536
186686 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=36864000
W=37057536 A=193536
186686 [AudioMixer-0] DEBUG audiobuffer.verbose - buf R=36992000
W=37057536 #=128000
186686 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
read=128000 bufLen=128000 fillLen=128000 available=9%
187436 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=128000,open:true
187436 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=36992000
W=37057536 A=65536
187436 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=36992000
W=37057536 A=65536
187436 [AudioMixer-0] DEBUG audiobuffer.verbose - buf R=37057536
W=37057536 #=65536
187436 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
read=65536 bufLen=65536 fillLen=128000 available=12%
187811 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=65536,open:true
187811 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=37057536 W=37057536 A=0
187811 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=37057536 W=37057536 A=0
187811 [AudioMixer-0] DEBUG audiobuffer.verbose - audio buffer underrun
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=0 W=0 A=0
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=37057536 W=37057536 A=0
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=0 W=0 A=0
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=0 W=0 A=0
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=37057536 W=37057536 A=0
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=37057536 W=37057536 A=0
188483 [AudioMixer-0] DEBUG player.verbose - status=STMu fullness=0
bytesRx=0 elapsedSeconds=210
188483 [AudioMixer-0] DEBUG audiobuffer.verbose - buf R=37057536
W=37057536 Buffer empty, waiting ...
188483 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
read=0 bufLen=0 fillLen=128000 available=12%
188483 [AudioMixer-0] DEBUG javasound.verbose - playFrame: bytes
written=0,open:true
188545 [AudioMixer-0] DEBUG audiobuffer.verbose - avil R=37057536 W=37057536 A=0
Reply With Quote