View Full Version : Problems with WinAmp (403 Forbidden)

2005-04-28, 23:43

I use remote streaming to be able to listen to my music at work. For that I use Winamp and the stream.mp3 link. My slimserver is password protected.

It all worked fine for some time but after restarting Slimserver (no changes, just restart) I try to connect (using winamp) to http://my.host.com:9000/stream.mp3 but it fails: [HTTP/1.0 403 Forbidden]. This probably related to the fact that I have to enter a password. But I gave that password the first time I connected to the slimserver (months ago) and now Winamp does not ask for it anymore. I have not changed the password since. Using the link:
http://user:password@my.host.com:9000/stream.mp3 does not work.

So I used my IP-address to connect to my slimserver: WinAmp asked for username password (still the same) and I was able to listen to music again.

Yesterday I installed the latest version of Slimserver so I had to restart it again and now I can't get winamp to connect and because I have used both name and ip-address for my server I am out of options.

The strange thing is: winamp will ask for a password the first time you connect to a URL. It has to be given in the format: user#password. After that connecting to the same URL will never pop-up a password question. (It will just work). Now it just tries to connect and then finds out it is not allowed. I don't know why: I can not provide a password (winamp does not aks it) and it looks like winamp is not using the password it has cached.

I think this is related to winamp not slimserver but maybe someone out there has had the same problem and can help me.

Any suggestions?

2005-05-03, 01:57
I switched to iTunes:

contrary to winamp it does allow a password to be entered
contrary to Windows Media Player it does show track names etc.

So Winamp: exit stage left