PDA

View Full Version : slim.exe - odd behaviour



jhurley
2005-04-28, 01:37
I've been trying to update successfully to a nightly update for some while to cure a couple of issues regarding updating of itunes based playlists (it doesn't find the newly created ones) and inclusion in the library of all tracks from 'multi-disc' sets (it randomly includes a subset of tracks from 2 and 3 disc sets).

I had previously tried a number of different 6.0 and 6.1 releases, but in each case, through difficulties or inability to achieve consistent playback, have reverted to 6.0.b3, as my last 'working' version.

I have just installed the 2005-04-27 nightly 6.1 release using the win executable on a WinXP SP2 machine. I also upgraded firmware on the player, an original non-updated display version SB1 (just in case).

I use the itunes updater plug-in, and therefore have my server set NOT to run as a service, but to strat when I start the application.

All seemed well, but when I try to play any track, either from the player or the PC, the player loses contact with the server.

On my PC, this is evidenced by the slim.exe 'process' stopping and disappearing from the list of running processes.

Ideas?

jhurley
2005-04-28, 01:48
I have just installed the 2005-04-27 nightly 6.0.x release and experienced exactly the same issue.

jhurley
2005-04-28, 01:54
I have just installed the 6.0.2 release from the main support page and experienced the same issue.

kdf
2005-04-28, 02:05
try turning on d_source in server settings->debugging and see what you
get in the log when it fails.

-kdf

jhurley
2005-04-28, 02:34
try turning on d_source in server settings->debugging and see what you
get in the log when it fails.

-kdf

Done, and I can view my current log from link on the debugging page.

Unfortunately, when it crashes and I restart it, I get a fresh log, and no error messages from the previous crash.

Any idea where the actual log file is stored?

jhurley
2005-04-28, 02:48
From the logfile...

2005-04-28 10:45:29.3281 iTunesUpdate: Creating new PlayerStatus for Squeezebox (00:04:20:05:34:98)
2005-04-28 10:45:29.3288 iTunesUpdate: Starting a new song
Undefined subroutine &Slim::Music::Info::durationSeconds called at C:/Program Files/SlimServer/server/Plugins/iTunesUpdate.pm line 687.

Seems my problem may be the iTunesUpdate plugin?

Craig, James (IT)
2005-04-28, 02:49
>Any idea where the actual log file is stored?

Unfortunately It's not stored anywhere by default, you need to use the
"--logfile <filename>" option to start SlimServer.


James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

Craig, James (IT)
2005-04-28, 02:51
A ha!
Yes I think you need to upgrade to the latest version of the plugin.
I think I made a blunder in making the 5.4 plugin version appear to work
on SlimServer 6.0


James

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of jhurley
Sent: 28 April 2005 10:49
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] Re: slim.exe - odd behaviour


>From the logfile...

2005-04-28 10:45:29.3281 iTunesUpdate: Creating new PlayerStatus for
Squeezebox (00:04:20:05:34:98)
2005-04-28 10:45:29.3288 iTunesUpdate: Starting a new song
Undefined subroutine &Slim::Music::Info::durationSeconds called at
C:/Program Files/SlimServer/server/Plugins/iTunesUpdate.pm line 687.

Seems my problem may be the iTunesUpdate plugin?


--
jhurley

jhurley
2005-04-28, 03:05
Thanks James.

Having got the logfile working and seen the error, I checked for an updated plugin straight away - now installed and all is OK.

I must've got thrown due to the plugin working OK on initial v6 versions, but then failing on later ones.

Ho hum.

Thanks all for your help.

Jon