PDA

View Full Version : .ape and slim crash 4_26 nightly



Matt Alioto
2005-04-27, 08:19
Hi

I get the following errors when scan hits a particular .ape file.
I have others that don't seem to have a problem.
This causes slimserver to become unresponsive.
Process still runs but SB and SB2 loose connection and web interface
times out.
Running on Solaris 10, 6.0.2 4/26/05 candidate release.
Perl 5.8.5
Looks like it might be a tag issue but not sure how to find out what is
wrong with the tags and fix.

2005-04-27 07:34:31.1488 Converting
file:///export/Mp3/House/FurureSoundsofJazz/Future%20Sounds%20Of%20Jazz%
20-%20Vol.%208/
Future%20Sounds%20of%20Jazz%20-%20Vol.%208%20-%20eac-APE-cov/VA%20-%20Fu
ture%20Sounds%20of%20Jazz%20-%20Vo
l.%208.ape to /export/Mp3/House/FurureSoundsofJazz/Future Sounds Of Jazz
- Vol. 8/Future Sounds of Jazz - Vol. 8 - eac-APE
/Future Sounds of Jazz - Vol. 8.ape
2005-04-27 07:34:31.1507 ape file type for
file:///export/Mp3/House/FurureSoundsofJazz/Future%20Sounds%20Of%20Jazz%
20-%20Vol.%2
08/Future%20Sounds%20of%20Jazz%20-%20Vol.%208%20-%20eac-APE-cov/Future%2
0Sounds%20of%20Jazz%2
0-%20Vol.%208.ape
2005-04-27 07:34:31.1648 New track for
file:///export/Mp3/House/FurureSoundsofJazz/Future%20Sounds%20Of%20Jazz%
20-%20Vol.%208/Future%20Sounds%20of%20Jazz%20-%20Vol.%208%20-%20eac-APE-
cov/VA%20-%20Future%20Sounds%20of%20Jazz%20-%2
0Vol.%208.ape
2005-04-27 07:34:31.1660 readTag was set for
file:///export/Mp3/House/FurureSoundsofJazz/Future%20Sounds%20Of%20Jazz%
20-%20Vol.
%208/Future%20Sounds%20of%20Jazz%20-%20Vol.%208%20-%20eac-APE-cov/Future
%20Sounds%20of%20Jazz%20-%20Vol.%208.ape
2005-04-27 07:34:31.1677 reading tags for:
file:///export/Mp3/House/FurureSoundsofJazz/Future%20Sounds%20Of%20Jazz%
20-%20Vol.%2
08/Future%20Sounds%20of%20Jazz%20-%20Vol.%208%20-%20eac-APE-cov/Future%2
0Sounds%20of%20Jazz%2
0-%20Vol.%208.ape
2005-04-27 07:34:31.1718 Trying to load Slim::Formats::APE
substr outside of string at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 209.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 227.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 228.
substr outside of string at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 228.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 227.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 228.
:
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 209.
substr outside of string at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 228.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 227.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 228.
substr outside of string at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 228.
Use of uninitialized value in pattern match (m//) at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 202.
Use of uninitialized value in substitution (s///) at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 206.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 208.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 208.
Use of uninitialized value in substr at
/usr/share/src/SlimServer_v6.0.2/CPAN/Audio/APETags.pm line 209.

Thanks

Matt

The information contained in this e-mail is strictly confidential and for the
intended use of the addressee only; it may also be legally privileged and/or
price sensitive. Notice is hereby given that any disclosure, use or copying
of the information by anyone other than the intended recipient is prohibited
and may be illegal. If you have received this message in error, please
notify the sender immediately by return e-mail. All e-mail sent to this
address will be received by Acacia Pacific Holding's e-mail system and is
subjected to archiving and review by someone other than the recipient.

Acacia Pacific Holdings has taken every reasonable precaution to ensure that
any attachment to this e-mail has been swept for viruses. We accept no
liability for any damage sustained as a result of software viruses and
advise you carry out your own virus checks before opening any attachment.

Ben Sandee
2005-04-27, 08:25
On 4/27/05, Matt Alioto <malioto (AT) acpac (DOT) com> wrote:
> Hi
>
> I get the following errors when scan hits a particular .ape file.
> I have others that don't seem to have a problem.
> This causes slimserver to become unresponsive.
> Process still runs but SB and SB2 loose connection and web interface
> times out.
> Running on Solaris 10, 6.0.2 4/26/05 candidate release.
> Perl 5.8.5
> Looks like it might be a tag issue but not sure how to find out what is
> wrong with the tags and fix.

Matt,

Others may have some other diagnostic advice for you, what I would
suggest is that you file a bug and attach the file in question. I
think it's safe to say that even if your tags are not quite perfect it
shouldn't crash slimserver.

http://bugs.slimdevices.com/

Is this a new problem (i.e. you recently upgraded the server) or is it
a new file that has never been scanned before?

Ben

Matt Alioto
2005-04-27, 09:05
>
> I get the following errors when scan hits a particular .ape file.
> I have others that don't seem to have a problem.
> This causes slimserver to become unresponsive.
> Process still runs but SB and SB2 loose connection and web interface
> times out.
> Running on Solaris 10, 6.0.2 4/26/05 candidate release.
> Perl 5.8.5
> Looks like it might be a tag issue but not sure how to find out what
is
> wrong with the tags and fix.

Matt,

Others may have some other diagnostic advice for you, what I would
suggest is that you file a bug and attach the file in question. I
think it's safe to say that even if your tags are not quite perfect it
shouldn't crash slimserver.

http://bugs.slimdevices.com/

Is this a new problem (i.e. you recently upgraded the server) or is it
a new file that has never been scanned before?

Ben

Hi Ben
A bit of both. Upgraded yesterday and added music. Maybe not a good
idea.
The track in question was added yesterday. I will move track and
rescan.
If it is track specific and possible tag issue I'll file bug.

Thanks for the info

kdf
2005-04-27, 12:28
Please file a bug and attach the track to the report. This looks like you have
some sort of corrupted tags that cause the parser to run past the end of the
file. One case that caused this in the past was ID3 tags written in and
overlapping the APEtags. The current module should be handling this, but its
hard to guess at how many ways corruption can occur.

Other useful details to include in the report:
What did you use to rip, encode, tag the problem file(s)

http://bugs.slimdevices.com

-kdf