View Full Version : Stream slimserver to PDA (Pocket PC)

2005-04-24, 16:19
I have SlimServer streaming to my PC without a problem. However I'd like to be able to have my iPAQ pickup the stream too.

I heard that this does work, but I must be missing something obvious.

I've tried opening http://myip:9000/stream.mp3 but neither WMP or GSPlayer will pick it up.

Anyone have any experience with this?


2005-04-24, 16:22
I take it back. It's working!?!?

Not quite sure why. But it's all working great. :)

2005-04-24, 17:50
ok - last question.

I modified the bitrate settings to limit to 128Kb/s. However the PPC (GSplayer) still reports a 320Kb/s stream. I've reset the PPC and stopped and started the Slimstream server.

The source media is AAC 192Kb/s. So by my understanding, setting the Maximum Bitrate for that player:
- if an MP3 is 128Kb/s or lower it is sent without re-encoding.
- if an MP3 file is >128Kb/s it is re-encoded to 128Kb/s and streamed.
- if a file comes from another format (AAC for example) it is sent at 128Kb/s.

Why does my stream still get reported as 320Kb/s?

Aaron Zinck
2005-04-24, 18:26
> Why does my stream still get reported as 320Kb/s?

does it report this even while you're actually streaming music? While I
don't know the details of how it works the silence that is "broadcast" while
no music is playing is 320K. When the music starts it should then report
the correct bitrate. If not, then it's likely that windows media player on
the pda isn't refreshing the bitrate it's showing on its interface despite
receiving the correct (128) bitrate.

Have you tried this with a computer? That would verify whether or not
slimserver is potentially at fault.

2005-04-24, 18:34
You could also use a bandwidth meter to see what's actually being used (if slimserver is on XP, there's a network graph on the task manager).

2005-04-24, 18:46
It's working. I don't know what it was. I left Slimserver disabled for the last couple of hours and just restarted the server and it's not being reported correctly by GSPlayer.

Does Slimserver maybe check the preferences on a timed basis as opposed to startup maybe?

I know that I was meticulous in checking the PDA and the Slimserver components specifically so I didn't have to write one of these embarrassing "it's working now" posts...

But - it's working now. Not showing 128Kb/s.

I should have checked activity monitor previously to see the bitrate.

Oh well.

Thanks again guys.

2005-05-06, 14:58
How do you get GSPlayer to work using security stream connection. http://username:password@localhost:9000/stream.mp3? If I disable security .. it works, but as soon as I enable and put in url string into GSPlayer.. it does not connect. Any ideas?