PDA

View Full Version : SlimServer 6.0.1 - FLAC issues



parkyna
2005-04-22, 02:56
Hi there,

I'm a SB user running SlimServer on a Buffalo LinkStation (thanks to Marc D. Field for this successful project). Previously I ran SlimServer 5.4.1 streaming only MP3s or WAV.

I upgraded to SlimServer 6.0.1 because of the in-built FLAC streaming capabilities. This works fine with SoftSqueeze (v2.014b I believe) and initially worked ok with SB. However, it has stopped working even though it is a ticked supported file type in the Server Settings area (via the web interface).

Whenever I try to select a FLAC file with the SB it finds the file, looks like it's going to play it and then comes up with a 'Can't Open File' error. I have made no changes other than to increase the number of FLAC files in my collection and a couple of reboots when Wipe Cache/ReScan didn't seem to work.

I've now uninstalled/re-installed Slim Server 6.0.1 several times and whatever I do I can't get the SB to play FLAC (it's fine with MP3 & WAV and SoftSqueeze CAN handle FLAC files).

Am I doing anything wrong? Did I dream that I got FLAC working with my SB in the first place? Should 6.0.1 work for a SB where SlimServer is insalled on a Buffalo LinkStation?

I'm going to buy a SB2 in the near future anyway but I'd really like to get this cracked with my SB in the short term if possible and to ensure the SB has a longer shelf-life (deployed in a different room for instance).

Sorry for the long note and thanks for any help advice you can give me. (PS. I'm an audio enthusiast rather than a techie so please simplify any advice/recommendations!).

Patrick Dixon
2005-04-22, 04:35
IIRC, FLAC streaming only works with SB2. For the SB1 you can only convert to WAV or MP3 at the server, and stream in one of those.

parkyna
2005-04-22, 05:28
Patrick - thanks for the confirmation and for saving me from pulling any more hair out! I must have dreamt that it worked after all.

Cheers,
Alan.

Patrick Dixon
2005-04-22, 05:41
A good excuse to get that SB2 (which is terrific BTW)

aybee
2005-04-23, 04:03
Although Slim support have been very helpful I haven't been able to resolve this with their assistance.

I cannot play Flac on SB1 when slimserver is running as a windows service - but they do when slimserver is running as an application. This started after upgrading for 5.4 to 6.

Sorry I cannot help!