PDA

View Full Version : Fishbone glitch



dbls
2005-04-16, 12:16
On either Win98 or WinXP SP2, when browsing the music folder,
nothing happens when I click on the letters a the top of the
lefthand panel (that is, the subfolder list doesn't scroll as
in other browse modes).

-:- dbls

kdf
2005-04-16, 13:39
Quoting dbls <dbls (AT) comcast (DOT) net>:

> On either Win98 or WinXP SP2, when browsing the music folder,
> nothing happens when I click on the letters a the top of the
> lefthand panel (that is, the subfolder list doesn't scroll as
> in other browse modes).
>
I'm not able to reproduce this. Are you using the latest nightly? Which
browser are you using, and have you tried to see if other skins work?

-kdf

dbls
2005-04-16, 14:33
----- Original Message -----
From: "kdf"


> Quoting dbls <dbls (AT) comcast (DOT) net>:
>
>> On either Win98 or WinXP SP2, when browsing the music folder,
>> nothing happens when I click on the letters a the top of the
>> lefthand panel (that is, the subfolder list doesn't scroll as
>> in other browse modes).
>>
> I'm not able to reproduce this. Are you using the latest nightly? Which
> browser are you using, and have you tried to see if other skins work?
>
> -kdf

SlimServer Version: 6.0.1 - 2895; using the standard Slim Web
Interface. If I turn on http_verbose, I see references to
"User-Agent: Mozilla/4.0" in the log, but I never see anything
that looks like a likely culprit. (My default browser is
FireFox.) Here's what I get if I click "P" at the top of the
list:

]
2005-04-16 17:29:25.5085 Request Headers: [
GET /log.txt HTTP/1.1
Connection: Keep-Alive
Accept: */*
Accept-Encoding: gzip, deflate
Accept-Language: en-us
Host: localhost:9000
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Cookie: SlimServer-Browserpage=browse.html%3Fdir%3D%26%26page%3DBROWS E_MUSIC_FOLDER; SlimServer-search=SEARCHFOR_ARTIST; SlimServer-player=127.0.0.1

]

-:- dbls

dbls
2005-04-18, 12:26
From: "kdf"


> Quoting dbls:
>
>> On either Win98 or WinXP SP2, when browsing the music folder,
>> nothing happens when I click on the letters a the top of the
>> lefthand panel (that is, the subfolder list doesn't scroll as
>> in other browse modes).
>>
> I'm not able to reproduce this. Are you using the latest nightly? Which
> browser are you using, and have you tried to see if other skins work?
>
> -kdf

This happens with Firefox, Internet Explorer and the standard
SlimServer web UI.

I've installed the latest nightly, following the link for 6.0.2 (SlimServer_v2005-04-18.exe) which for some reason still shows
up as 6.0.1 - 2895, the same version as the one I obtained via
the link in Server Settings ("A new version of SlimServer is
available") on the 14th.

This still exhibits the same behavior. For example, if I let the
pointer hover over the "M", the status bar shows
http://localhost:9000/browse.html?&player=00%3A04%3A20%3A05%3A11
%3A38&&start=0#M
but the list remains scrolled to the top when I click it.

Other modes work, though I just noticed that the Browse Music
Folder list is on a single page (i.e. all the letters are in
boldface), which isn't true in other modes. By the way, the
default skin behaves exactly the same as Fishbone.

I switched to ExBrowse2 (which had its own curious behavior, but
that's another thread), and the letter shortcuts do nothing in
any mode unless the desired letter links to a different page of
the list.

One thing - when I switch to ExBrowse2, I get this Internet
Explorer script error:

Line: 10
Char: 1
Error: Object doesn't support this property or method
Code: 0
URL: http://localhost:9000/setup.html?player=00%3A04%3A20
%3A05%3A11%3A38&playerid=&page=interface&skin=ExBrowse2
&itemsPerPage

After that, the skin seems to work other than the scrolling
shortcuts (except for some overlapping frames when the window
isn't maximized).

-:- dbls

dbls
2005-04-20, 14:24
----- Original Message -----
From: "dbls" <dbls (AT) comcast (DOT) net>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Monday, April 18, 2005 3:26 PM
Subject: Re: [slim] Fishbone glitch


> From: "kdf"
>
>
>> Quoting dbls:
>>
>>> On either Win98 or WinXP SP2, when browsing the music folder,
>>> nothing happens when I click on the letters a the top of the
>>> lefthand panel (that is, the subfolder list doesn't scroll as
>>> in other browse modes).
>>>
>> I'm not able to reproduce this. Are you using the latest nightly? Which
>> browser are you using, and have you tried to see if other skins work?
>>
>> -kdf
>

A further update - I now have version 6.0.2 - 2895 (April
20th nightly) installed. No change, but here's something
else I've noticed in each version: the first time I click
on a letter at the top of the Browse Music Folder pane,
the page refreshes, but doesn't change (remains scrolled
to the top), but after that, the clicks appear to do
nothing.

One other thing I just noticed: "Browse Music Folder" is
the only mode in which the letter shortcuts aren't
duplicated at the bottom of the list.

Let me see what happens with 6.1. -:- dbls

dbls
2005-04-20, 15:17
>> From: "kdf"
>>
>>
>>> Quoting dbls:
>>>
>>>> On either Win98 or WinXP SP2, when browsing the music folder,
>>>> nothing happens when I click on the letters a the top of the
>>>> lefthand panel (that is, the subfolder list doesn't scroll as
>>>> in other browse modes).
>>>>
>>> I'm not able to reproduce this. Are you using the latest nightly? Which
>>> browser are you using, and have you tried to see if other skins work?
>>>
>>> -kdf
>>
>
>
> Let me see what happens with 6.1. -:- dbls
>

I'm having the same issue with 6.1.

OTOH, is it just a coincindence, or is the web UI dramatically
more responsive in 6.1? If it stays this way, it's a *huge*
improvement.

-:- dbls

kdf
2005-04-20, 15:47
Quoting dbls <dbls (AT) comcast (DOT) net>:

> >> From: "kdf"
> >>
> >>
> >>> Quoting dbls:
> >>>
> >>>> On either Win98 or WinXP SP2, when browsing the music folder,
> >>>> nothing happens when I click on the letters a the top of the
> >>>> lefthand panel (that is, the subfolder list doesn't scroll as
> >>>> in other browse modes).
> >>>>
> >>> I'm not able to reproduce this. Are you using the latest nightly? Which
> >>> browser are you using, and have you tried to see if other skins work?
> >>>
> >>> -kdf
> >>
> >
> >
> > Let me see what happens with 6.1. -:- dbls
> >
>
> I'm having the same issue with 6.1.
>
> OTOH, is it just a coincindence, or is the web UI dramatically
> more responsive in 6.1? If it stays this way, it's a *huge*
> improvement.
>
I suggest you file a bug on this, and consider labelling it as browse music
folder problem, since you have said it also happens for you with the defualt
skin.

-kdf