PDA

View Full Version : Does SB2 support WPA2 (AES encryption) ?



rephlex
2005-04-08, 23:33
Just got my SB2 wireless and I can't get it to talk to my Linksys WRT54G unless I change my router from the more secure AES encryption to TKIP. SB2 works fine on TKIP but I'd like to continue running my wireless network on AES. If SB2 doesn't support WPA2 will it support it in the future ?

During setup I was a little stumped that the digital out didn't work unless I also had the analog hooked up to my receiver. Is there a reason why the digital out shuts down when there is no analog connection on the SB2 ?

-MarcW

One other thing.. the manual says to open port 3483 but the server 6.01 is actually running on 3486.

relen
2005-04-09, 05:12
The business of the digital coax output going off if the analog output isn't connected appears to be a grounding issue, from what has been said earlier on this point.

On Apr 7, Sean Adams wrote:
"We recently identified an electrical issue that would cause coax s/pdif not to sync with a few receivers - it has been fixed already in production, but some SB2s that shipped as recently as Monday will need the fix. If you have a MAC address of 00:04:20:05:A3:FA or lower, you can contact support@slimdevices.com to get it fixed."

I am not sure whether or not this is the same problem. Sean, would alternative grounding work around the issue you identified? Or are they different problems?

--Richard E

rephlex
2005-04-09, 10:04
Awww crap... I found the post you were refering to and of course my MAC address is lower than FA. This sucks.

Dan Sully
2005-04-09, 10:17
* rephlex shaped the electrons to say...

>Awww crap... I found the post you were refering to and of course my MAC
>address is lower than FA. This sucks.

Please contact support (AT) slimdevices (DOT) com - and we'll issue an RMA for your
unit. It will be fixed at no cost to you.

Sorry for the inconvience.

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?

dconry
2005-04-09, 10:50
Hi,

I was also wondering if the SB2 hardware was capable of ever capable of supporting AES encryption scheme in the future, with newer firmware/server software? I know most networking equipment that supports AES/CCMP has dedicated hardware to do this.

I've noticed a very low volume static while listening to my SB2 via headphones. This static seems to occur for a few seconds after each song begins to play. It is a small annoyance, but I wondered if this could also be related to the grounding issues mentioned above... I checked and my MAC address is also less than the threshold value.

Thanks in advance...

vidurapparao
2005-04-09, 13:38
Hi,

I was also wondering if the SB2 hardware was capable of ever capable of supporting AES encryption scheme in the future, with newer firmware/server software? I know most networking equipment that supports AES/CCMP has dedicated hardware to do this.


I believe AES is possible, but don't hold me to it, since we've done no testing with it.


I've noticed a very low volume static while listening to my SB2 via headphones. This static seems to occur for a few seconds after each song begins to play. It is a small annoyance, but I wondered if this could also be related to the grounding issues mentioned above... I checked and my MAC address is also less than the threshold value.


The grounding issue shouldn't effect the analog outputs. Are you running 6.0.1 and firmware 9? If not, I'd recommend upgrading immediately. The problem you're hearing could be related to the fix described at http://lists.slimdevices.com/archives/checkins/2005-March/005126.html

--Vidur

rephlex
2005-04-12, 09:24
Well,

I had to pay for shipping it back so I wouldn't necessarily say it is being fixed at no cost to me. On the flip-side I do understand that this is a very new product and stuff happens.

-MarcW


* rephlex shaped the electrons to say...

>Awww crap... I found the post you were refering to and of course my MAC
>address is lower than FA. This sucks.

Please contact support (AT) slimdevices (DOT) com - and we'll issue an RMA for your
unit. It will be fixed at no cost to you.

Sorry for the inconvience.

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?

Gregory P. Smith
2005-04-21, 10:53
On Sat, Apr 09, 2005 at 01:38:13PM -0700, vidurapparao wrote:
>
> dconry Wrote:
> > Hi,
> >
> > I was also wondering if the SB2 hardware was capable of ever capable of
> > supporting AES encryption scheme in the future, with newer
> > firmware/server software? I know most networking equipment that
> > supports AES/CCMP has dedicated hardware to do this.
> >
>
> I believe AES is possible, but don't hold me to it, since we've done no
> testing with it.

Add another vote to the WPA using AES would be great to have. I'd
prefer using it to TKIP.

-greg

dconry
2005-04-25, 11:54
FYI to Vidurapparao, the newer firmware version did lessen the line noise on the headphone output during networking activity (though, did not eliminate it entirely). Thanks for the tip... I am also going to try listening to the other outputs to see if the noise is present on those, as well.

And good news, about possible AES support in the future...

Pétur
2005-04-25, 13:09
Grrrr... I see you guys got WPA (TKIP) working at all, I'm stuck here with WEP :(

I'm connecting Ad-Hoc to a wireless network card from GigaByte (GN-WPKG) using 1.41 drivers (latest), and when I set it to WPA (either TKIP or AES) my SB2 refuses to connect to the server.

Using latest versions of SB2 and server.

Any tips welcome

Peter

vidurapparao
2005-04-25, 14:41
Peter,

Please file a bug with details about your particular setup at
http://bugs.slimdevices.com.

Thanks,
--Vidur

Pétur wrote:

>Grrrr... I see you guys got WPA (TKIP) working at all, I'm stuck here
>with WEP :(
>
>I'm connecting Ad-Hoc to a wireless network card from GigaByte
>(GN-WPKG) using 1.41 drivers (latest), and when I set it to WPA (either
>TKIP or AES) my SB2 refuses to connect to the server.
>
>Using latest versions of SB2 and server.
>
>Any tips welcome
>
>Peter
>
>
>
>

Jess Askey
2005-04-25, 20:27
Im running 4/24 nightly with my new SB2 (Just arrived today, thanks for
the Pony) and I have these errors in Biography and Forecaster (both said
they were good for 6.0 on their pages)...

2005-04-25 20:59:47.4340 Can't load Plugins::Biography::Plugin for
Plugins menu: Undefined subroutine
&Plugins::Biography::Plugin::getDisplayName called at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.

2005-04-25 21:20:43.6950 Can't load Plugins::Forecaster for Plugins
menu: Undefined subroutine &Plugins::Forecaster::getDisplayName called
at /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.


Both plugins do have the proper getdisplayname sub and their owner and
group are 'slimserver' with perms of 644. I verified that neither have
any CR/LF pairs in them too.

What am I missing?

mherger
2005-04-25, 22:48
Jess,

> 2005-04-25 20:59:47.4340 Can't load Plugins::Biography::Plugin for
> Plugins menu: Undefined subroutine
> &Plugins::Biography::Plugin::getDisplayName called at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
[..]
> Both plugins do have the proper getdisplayname sub and their owner and
> group are 'slimserver' with perms of 644. I verified that neither have
> any CR/LF pairs in them too.
>
> What am I missing?

Some perl module? Biography needs HTML::FormatText (see "requirements" on
my page).

To be sure run the server with the d_plugins parameter and see where it
fails. The messages you posted aren't the real problem.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

Jess Askey
2005-04-26, 00:04
Hi Mike,

thanks for the reply. I did have the d_plugins flag set just to get
these messages... here is a snip (farther down) of my entire log when I
refresh the plugins through the web interface... I don't get any other
errors, just the 'getDisplayName' problem for Biography and Forecast.
All the other plugins seem to work fine. I do have HTML::FormatText
installed via CPAN.

I know that HTML::FormatText is working because when I previously ran...
'perl ./Biography/Plugin.pm' , I got an HTML::FormatText not found
error. Now I just get..

# perl Plugin.pm
Can't locate Slim/Buttons/Common.pm in @INC (@INC contains:
/usr/local/slimserver/Plugins/Biography/Plugins/MHCPAN
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
Plugin.pm line 40.
BEGIN failed--compilation aborted at Plugin.pm line 40.

which should be expected running it directly Im guessing?

Here is my Plugin Load with d_plugins set. Any other flags I could try
that may help?

2005-04-26 00:45:17.4398 Requiring Plugins::Lyrics plugin.
2005-04-26 00:45:17.4486 Requiring Plugins::Rescan plugin.
2005-04-26 00:45:17.4645 Requiring Plugins::MusicMagic::Plugin plugin.
2005-04-26 00:45:17.4730 Requiring Plugins::Visualizer plugin.
2005-04-26 00:45:17.4867 Requiring Plugins::Biography::Plugin plugin.
2005-04-26 00:45:17.4879 Can't load Plugins::Biography::Plugin for
Plugins menu: Undefined subroutine
&Plugins::Biography::Plugin::getDisplayName called at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.

2005-04-26 00:45:17.4957 Requiring Plugins::Favorites::Plugin plugin.
2005-04-26 00:45:17.5060 Requiring Plugins::DateTime::Plugin plugin.
2005-04-26 00:45:17.5190 Requiring Plugins::RadioIO::Plugin plugin.
2005-04-26 00:45:17.5290 Requiring Plugins::Podcast::Plugin plugin.
2005-04-26 00:45:17.5454 Requiring Plugins::SavePlaylist plugin.
2005-04-26 00:45:17.5539 Requiring Plugins::SlimTris plugin.
2005-04-26 00:45:17.5625 Requiring Plugins::Picks::Plugin plugin.
2005-04-26 00:45:17.5738 Requiring Plugins::iTunes plugin.
2005-04-26 00:45:17.5822 Requiring Plugins::Forecaster plugin.
2005-04-26 00:45:17.5834 Can't load Plugins::Forecaster for Plugins
menu: Undefined subroutine &Plugins::Forecaster::getDisplayName called
at /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.

2005-04-26 00:45:17.5913 Requiring Plugins::RssNews plugin.
2005-04-26 00:45:17.6206 Requiring Plugins::Live365 plugin.
2005-04-26 00:45:17.6618 Requiring Plugins::ShoutcastBrowser::Plugin plugin.


Im running Mandrake 9.2, Perl 5.8.0, Nightly 6/24

thank you for any suggestions. I truly appreciate it.

jess


Michael Herger wrote:

> Jess,
>
>> 2005-04-25 20:59:47.4340 Can't load Plugins::Biography::Plugin for
>> Plugins menu: Undefined subroutine
>> &Plugins::Biography::Plugin::getDisplayName called at
>> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>
> [..]
>
>> Both plugins do have the proper getdisplayname sub and their owner
>> and group are 'slimserver' with perms of 644. I verified that
>> neither have any CR/LF pairs in them too.
>>
>> What am I missing?
>
>
> Some perl module? Biography needs HTML::FormatText (see "requirements"
> on my page).
>
> To be sure run the server with the d_plugins parameter and see where
> it fails. The messages you posted aren't the real problem.
>

mherger
2005-04-26, 00:17
> thanks for the reply. I did have the d_plugins flag set just to get
> these messages... here is a snip (farther down) of my entire log when I
> refresh the plugins through the web interface... I don't get any other
> errors, just the 'getDisplayName' problem for Biography and Forecast.
> All the other plugins seem to work fine. I do have HTML::FormatText
> installed via CPAN.

Please do _restart_ the server and send the very first few lines (when
it's checking for the plugins). Re-loading won't be enough.

> I know that HTML::FormatText is working because when I previously ran...
> 'perl ./Biography/Plugin.pm' , I got an HTML::FormatText not found
> error. Now I just get..
>
> # perl Plugin.pm
[..]
> which should be expected running it directly Im guessing?

You can't run a module directly.

> Here is my Plugin Load with d_plugins set. Any other flags I could try
> that may help?
>
> 2005-04-26 00:45:17.4398 Requiring Plugins::Lyrics plugin.
> 2005-04-26 00:45:17.4486 Requiring Plugins::Rescan plugin.
> 2005-04-26 00:45:17.4645 Requiring Plugins::MusicMagic::Plugin plugin.
> 2005-04-26 00:45:17.4730 Requiring Plugins::Visualizer plugin.
> 2005-04-26 00:45:17.4867 Requiring Plugins::Biography::Plugin plugin.
> 2005-04-26 00:45:17.4879 Can't load Plugins::Biography::Plugin for
> Plugins menu: Undefined subroutine
> &Plugins::Biography::Plugin::getDisplayName called at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.

IMHO it will return these errors after it had failed to load the plugins
in the very first place. That's why you should restart the server to have
the most important error messages.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

Jess Askey
2005-04-26, 00:20
Well, I just stopped and restarted slimserver twice to try and see if
there were additional log entries for the plugins on a fresh
startup(there weren't). But, this time Biography started up fine.
Forcast, still didn't start. Strange.

Jess Askey wrote:

> Hi Mike,
>
> thanks for the reply. I did have the d_plugins flag set just to get
> these messages... here is a snip (farther down) of my entire log when
> I refresh the plugins through the web interface... I don't get any
> other errors, just the 'getDisplayName' problem for Biography and
> Forecast. All the other plugins seem to work fine. I do have
> HTML::FormatText installed via CPAN.
>
> I know that HTML::FormatText is working because when I previously
> ran... 'perl ./Biography/Plugin.pm' , I got an HTML::FormatText not
> found error. Now I just get..
>
> # perl Plugin.pm
> Can't locate Slim/Buttons/Common.pm in @INC (@INC contains:
> /usr/local/slimserver/Plugins/Biography/Plugins/MHCPAN
> /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
> /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
> Plugin.pm line 40.
> BEGIN failed--compilation aborted at Plugin.pm line 40.
>
> which should be expected running it directly Im guessing?
>
> Here is my Plugin Load with d_plugins set. Any other flags I could try
> that may help?
>
> 2005-04-26 00:45:17.4398 Requiring Plugins::Lyrics plugin.
> 2005-04-26 00:45:17.4486 Requiring Plugins::Rescan plugin.
> 2005-04-26 00:45:17.4645 Requiring Plugins::MusicMagic::Plugin plugin.
> 2005-04-26 00:45:17.4730 Requiring Plugins::Visualizer plugin.
> 2005-04-26 00:45:17.4867 Requiring Plugins::Biography::Plugin plugin.
> 2005-04-26 00:45:17.4879 Can't load Plugins::Biography::Plugin for
> Plugins menu: Undefined subroutine
> &Plugins::Biography::Plugin::getDisplayName called at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>
> 2005-04-26 00:45:17.4957 Requiring Plugins::Favorites::Plugin plugin.
> 2005-04-26 00:45:17.5060 Requiring Plugins::DateTime::Plugin plugin.
> 2005-04-26 00:45:17.5190 Requiring Plugins::RadioIO::Plugin plugin.
> 2005-04-26 00:45:17.5290 Requiring Plugins::Podcast::Plugin plugin.
> 2005-04-26 00:45:17.5454 Requiring Plugins::SavePlaylist plugin.
> 2005-04-26 00:45:17.5539 Requiring Plugins::SlimTris plugin.
> 2005-04-26 00:45:17.5625 Requiring Plugins::Picks::Plugin plugin.
> 2005-04-26 00:45:17.5738 Requiring Plugins::iTunes plugin.
> 2005-04-26 00:45:17.5822 Requiring Plugins::Forecaster plugin.
> 2005-04-26 00:45:17.5834 Can't load Plugins::Forecaster for Plugins
> menu: Undefined subroutine &Plugins::Forecaster::getDisplayName called
> at /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>
> 2005-04-26 00:45:17.5913 Requiring Plugins::RssNews plugin.
> 2005-04-26 00:45:17.6206 Requiring Plugins::Live365 plugin.
> 2005-04-26 00:45:17.6618 Requiring Plugins::ShoutcastBrowser::Plugin
> plugin.
>
>
> Im running Mandrake 9.2, Perl 5.8.0, Nightly 6/24
>
> thank you for any suggestions. I truly appreciate it.
>
> jess
>
>
> Michael Herger wrote:
>
>> Jess,
>>
>>> 2005-04-25 20:59:47.4340 Can't load Plugins::Biography::Plugin for
>>> Plugins menu: Undefined subroutine
>>> &Plugins::Biography::Plugin::getDisplayName called at
>>> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>>
>>
>> [..]
>>
>>> Both plugins do have the proper getdisplayname sub and their owner
>>> and group are 'slimserver' with perms of 644. I verified that
>>> neither have any CR/LF pairs in them too.
>>>
>>> What am I missing?
>>
>>
>>
>> Some perl module? Biography needs HTML::FormatText (see
>> "requirements" on my page).
>>
>> To be sure run the server with the d_plugins parameter and see where
>> it fails. The messages you posted aren't the real problem.
>>
>
>
>

Jess Askey
2005-04-26, 00:23
These were the only additional log entries...prior to the Plugins loading.

Use of uninitialized value in concatenation (.) or string at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 82, <DATA> line 1.
Use of uninitialized value in string comparison (cmp) at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
Use of uninitialized value in string comparison (cmp) at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
Use of uninitialized value in string comparison (cmp) at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
Use of uninitialized value in string comparison (cmp) at
/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.

Not sure what the problem was, but looks like Mike is off the hook. ;-)

Thank you for the Biography plugin as well!!

jess


Jess Askey wrote:

> Well, I just stopped and restarted slimserver twice to try and see if
> there were additional log entries for the plugins on a fresh
> startup(there weren't). But, this time Biography started up fine.
> Forcast, still didn't start. Strange.
>
> Jess Askey wrote:
>
>> Hi Mike,
>>
>> thanks for the reply. I did have the d_plugins flag set just to get
>> these messages... here is a snip (farther down) of my entire log when
>> I refresh the plugins through the web interface... I don't get any
>> other errors, just the 'getDisplayName' problem for Biography and
>> Forecast. All the other plugins seem to work fine. I do have
>> HTML::FormatText installed via CPAN.
>>
>> I know that HTML::FormatText is working because when I previously
>> ran... 'perl ./Biography/Plugin.pm' , I got an HTML::FormatText not
>> found error. Now I just get..
>>
>> # perl Plugin.pm
>> Can't locate Slim/Buttons/Common.pm in @INC (@INC contains:
>> /usr/local/slimserver/Plugins/Biography/Plugins/MHCPAN
>> /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
>> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
>> /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
>> Plugin.pm line 40.
>> BEGIN failed--compilation aborted at Plugin.pm line 40.
>>
>> which should be expected running it directly Im guessing?
>>
>> Here is my Plugin Load with d_plugins set. Any other flags I could
>> try that may help?
>>
>> 2005-04-26 00:45:17.4398 Requiring Plugins::Lyrics plugin.
>> 2005-04-26 00:45:17.4486 Requiring Plugins::Rescan plugin.
>> 2005-04-26 00:45:17.4645 Requiring Plugins::MusicMagic::Plugin plugin.
>> 2005-04-26 00:45:17.4730 Requiring Plugins::Visualizer plugin.
>> 2005-04-26 00:45:17.4867 Requiring Plugins::Biography::Plugin plugin.
>> 2005-04-26 00:45:17.4879 Can't load Plugins::Biography::Plugin for
>> Plugins menu: Undefined subroutine
>> &Plugins::Biography::Plugin::getDisplayName called at
>> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>>
>> 2005-04-26 00:45:17.4957 Requiring Plugins::Favorites::Plugin plugin.
>> 2005-04-26 00:45:17.5060 Requiring Plugins::DateTime::Plugin plugin.
>> 2005-04-26 00:45:17.5190 Requiring Plugins::RadioIO::Plugin plugin.
>> 2005-04-26 00:45:17.5290 Requiring Plugins::Podcast::Plugin plugin.
>> 2005-04-26 00:45:17.5454 Requiring Plugins::SavePlaylist plugin.
>> 2005-04-26 00:45:17.5539 Requiring Plugins::SlimTris plugin.
>> 2005-04-26 00:45:17.5625 Requiring Plugins::Picks::Plugin plugin.
>> 2005-04-26 00:45:17.5738 Requiring Plugins::iTunes plugin.
>> 2005-04-26 00:45:17.5822 Requiring Plugins::Forecaster plugin.
>> 2005-04-26 00:45:17.5834 Can't load Plugins::Forecaster for Plugins
>> menu: Undefined subroutine &Plugins::Forecaster::getDisplayName
>> called at /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174,
>> <DATA> line 1.
>>
>> 2005-04-26 00:45:17.5913 Requiring Plugins::RssNews plugin.
>> 2005-04-26 00:45:17.6206 Requiring Plugins::Live365 plugin.
>> 2005-04-26 00:45:17.6618 Requiring Plugins::ShoutcastBrowser::Plugin
>> plugin.
>>
>>
>> Im running Mandrake 9.2, Perl 5.8.0, Nightly 6/24
>>
>> thank you for any suggestions. I truly appreciate it.
>>
>> jess
>>
>>
>> Michael Herger wrote:
>>
>>> Jess,
>>>
>>>> 2005-04-25 20:59:47.4340 Can't load Plugins::Biography::Plugin for
>>>> Plugins menu: Undefined subroutine
>>>> &Plugins::Biography::Plugin::getDisplayName called at
>>>> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>>>
>>>
>>>
>>> [..]
>>>
>>>> Both plugins do have the proper getdisplayname sub and their owner
>>>> and group are 'slimserver' with perms of 644. I verified that
>>>> neither have any CR/LF pairs in them too.
>>>>
>>>> What am I missing?
>>>
>>>
>>>
>>>
>>> Some perl module? Biography needs HTML::FormatText (see
>>> "requirements" on my page).
>>>
>>> To be sure run the server with the d_plugins parameter and see where
>>> it fails. The messages you posted aren't the real problem.
>>>
>>
>>
>>

mherger
2005-04-26, 00:29
On Tue, 26 Apr 2005 09:20:42 +0200, Jess Askey <jess (AT) askey (DOT) org> wrote:

> Well, I just stopped and restarted slimserver twice to try and see if
> there were additional log entries for the plugins on a fresh

Did you start "slimserver.pl -d_plugins"?

> startup(there weren't). But, this time Biography started up fine.

Which is strange...



> Forcast, still didn't start. Strange.
>
> Jess Askey wrote:
>
>> Hi Mike,
>>
>> thanks for the reply. I did have the d_plugins flag set just to get
>> these messages... here is a snip (farther down) of my entire log when I
>> refresh the plugins through the web interface... I don't get any other
>> errors, just the 'getDisplayName' problem for Biography and Forecast.
>> All the other plugins seem to work fine. I do have HTML::FormatText
>> installed via CPAN.
>>
>> I know that HTML::FormatText is working because when I previously
>> ran... 'perl ./Biography/Plugin.pm' , I got an HTML::FormatText not
>> found error. Now I just get..
>>
>> # perl Plugin.pm
>> Can't locate Slim/Buttons/Common.pm in @INC (@INC contains:
>> /usr/local/slimserver/Plugins/Biography/Plugins/MHCPAN
>> /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
>> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
>> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
>> /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
>> /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
>> Plugin.pm line 40.
>> BEGIN failed--compilation aborted at Plugin.pm line 40.
>>
>> which should be expected running it directly Im guessing?
>>
>> Here is my Plugin Load with d_plugins set. Any other flags I could try
>> that may help?
>>
>> 2005-04-26 00:45:17.4398 Requiring Plugins::Lyrics plugin.
>> 2005-04-26 00:45:17.4486 Requiring Plugins::Rescan plugin.
>> 2005-04-26 00:45:17.4645 Requiring Plugins::MusicMagic::Plugin plugin.
>> 2005-04-26 00:45:17.4730 Requiring Plugins::Visualizer plugin.
>> 2005-04-26 00:45:17.4867 Requiring Plugins::Biography::Plugin plugin.
>> 2005-04-26 00:45:17.4879 Can't load Plugins::Biography::Plugin for
>> Plugins menu: Undefined subroutine
>> &Plugins::Biography::Plugin::getDisplayName called at
>> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>>
>> 2005-04-26 00:45:17.4957 Requiring Plugins::Favorites::Plugin plugin.
>> 2005-04-26 00:45:17.5060 Requiring Plugins::DateTime::Plugin plugin.
>> 2005-04-26 00:45:17.5190 Requiring Plugins::RadioIO::Plugin plugin.
>> 2005-04-26 00:45:17.5290 Requiring Plugins::Podcast::Plugin plugin.
>> 2005-04-26 00:45:17.5454 Requiring Plugins::SavePlaylist plugin.
>> 2005-04-26 00:45:17.5539 Requiring Plugins::SlimTris plugin.
>> 2005-04-26 00:45:17.5625 Requiring Plugins::Picks::Plugin plugin.
>> 2005-04-26 00:45:17.5738 Requiring Plugins::iTunes plugin.
>> 2005-04-26 00:45:17.5822 Requiring Plugins::Forecaster plugin.
>> 2005-04-26 00:45:17.5834 Can't load Plugins::Forecaster for Plugins
>> menu: Undefined subroutine &Plugins::Forecaster::getDisplayName called
>> at /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line
>> 1.
>>
>> 2005-04-26 00:45:17.5913 Requiring Plugins::RssNews plugin.
>> 2005-04-26 00:45:17.6206 Requiring Plugins::Live365 plugin.
>> 2005-04-26 00:45:17.6618 Requiring Plugins::ShoutcastBrowser::Plugin
>> plugin.
>>
>>
>> Im running Mandrake 9.2, Perl 5.8.0, Nightly 6/24
>>
>> thank you for any suggestions. I truly appreciate it.
>>
>> jess
>>
>>
>> Michael Herger wrote:
>>
>>> Jess,
>>>
>>>> 2005-04-25 20:59:47.4340 Can't load Plugins::Biography::Plugin for
>>>> Plugins menu: Undefined subroutine
>>>> &Plugins::Biography::Plugin::getDisplayName called at
>>>> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 174, <DATA> line 1.
>>>
>>>
>>> [..]
>>>
>>>> Both plugins do have the proper getdisplayname sub and their owner
>>>> and group are 'slimserver' with perms of 644. I verified that
>>>> neither have any CR/LF pairs in them too.
>>>>
>>>> What am I missing?
>>>
>>>
>>>
>>> Some perl module? Biography needs HTML::FormatText (see "requirements"
>>> on my page).
>>>
>>> To be sure run the server with the d_plugins parameter and see where
>>> it fails. The messages you posted aren't the real problem.
>>>
>>
>>
>>

kdf
2005-04-26, 00:40
Quoting Jess Askey <jess (AT) askey (DOT) org>:

> These were the only additional log entries...prior to the Plugins loading.
>
> Use of uninitialized value in concatenation (.) or string at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 82, <DATA> line 1.
> Use of uninitialized value in string comparison (cmp) at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
> Use of uninitialized value in string comparison (cmp) at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
> Use of uninitialized value in string comparison (cmp) at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
> Use of uninitialized value in string comparison (cmp) at
> /usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.

this happens when a plugin has no valid name, such as when the getDisplayName
fails, or the strings are invalid. check your line endings, as they are
critical for the strings sections.

also for forecaster, make sure you have Weather::Cached and Weather::Com
installed.

still, very odd that you are not seeing more messages, especially at the very
start of running (command line will help to make sure you get every thing, not
just what slimserver starts logging)

=kdf

Jess Askey
2005-04-26, 01:04
Okay, I found a better error in my slimserver.log this time for
Forecaster and it looks like there was a missing semicolon at the end of
line 52.

Still dont' have a good reason why Biography started working, must have
just needed a clean restart after installing depencies instead of a rescan.

thank you both for your help again.

kdf wrote:

>Quoting Jess Askey <jess (AT) askey (DOT) org>:
>
>
>
>>These were the only additional log entries...prior to the Plugins loading.
>>
>>Use of uninitialized value in concatenation (.) or string at
>>/usr/local/slimserver/Slim/Buttons/Plugins.pm line 82, <DATA> line 1.
>>Use of uninitialized value in string comparison (cmp) at
>>/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
>>Use of uninitialized value in string comparison (cmp) at
>>/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
>>Use of uninitialized value in string comparison (cmp) at
>>/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
>>Use of uninitialized value in string comparison (cmp) at
>>/usr/local/slimserver/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.
>>
>>
>
>this happens when a plugin has no valid name, such as when the getDisplayName
>fails, or the strings are invalid. check your line endings, as they are
>critical for the strings sections.
>
>also for forecaster, make sure you have Weather::Cached and Weather::Com
>installed.
>
>still, very odd that you are not seeing more messages, especially at the very
>start of running (command line will help to make sure you get every thing, not
>just what slimserver starts logging)
>
>=kdf
>