PDA

View Full Version : New to 6.x: Scan Time?



XC90
2005-04-08, 14:34
Hello,
My OS X 10.3 boot drive finally crashed, so I bought a new drive and installed OS X 10.3.8 onto it. Having been running 5.4.x for over a year, I decided now was the time to upgrade tp 6.0.1.

The problem I'm having with 6.0.1 is that it's been 3 hours since it's been trying to scan 32,000 tracks. Is this normal? I used to be able to see progress at the "Home" menu on 5.4 by hitting reload and reading the text at the top; but with 6.0.1 there is no text on the "Home" menu top saying "X number of tracks on X albums by X artists." So, there's nothing to update. The only thing I see when clicking on "Browse Artists" (for example) os:

"Note: SlimServer is still scanning your music library, so some items may not appear in this area yet."

But, c'mon... 3 hours worth? What's the deal? Is this thing even really still scanning anyway (without that reload text I can't tell).

Thanks,
XC

* P.S. I have searched the Forum, but don't see anything in particular to this.

daveblazer
2005-04-08, 14:38
wow that's alot of songs i have slimserver on linux and it takes 20 to 30 mins for 11,000 songs with pictures

kdf
2005-04-08, 14:43
Quoting XC90 <XC90.1n6vob (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Hello,
> My OS X 10.3 boot drive finally crashed, so I bought a new drive and
> installed OS X 10.3.8 onto it. Having been running 5.4.x for over a
> year, I decided now was the time to upgrade tp 6.0.1.
>
> The problem I'm having with 6.0.1 is that it's been 3 hours since it's
> been trying to scan 32,000 tracks. Is this normal? I used to be able to
> see progress at the "Home" menu on 5.4 by hitting reload and reading the
> text at the top; but with 6.0.1 there is no text on the "Home" menu top
> saying "X number of tracks on X albums by X artists." So, there's
> nothing to update. The only thing I see when clicking on "Browse
> Artists" (for example) os:
>
> "Note: SlimServer is still scanning your music library, so some items
> may not appear in this area yet."
>
> But, c'mon... 3 hours worth? What's the deal? Is this thing even really
> still scanning anyway (without that reload text I can't tell).

initial scan needs to fill out the database which takes more time than 5.4. 32k
is a lot, so I really couln't say how long. 3 hours does seem a bit long, but
there are a lot of factors to consider. I'm also not sure how you saw an
updated count on 5.4.x since that message you see now was also there in 5.4.x.

if you want to see an updated count, use the player and go into
settings->information->library information->tracks

-kdf

XC90
2005-04-08, 14:47
A lot are sound effect clips.

It used to take 20-30 min's with 5.4. Is there *supposed* to be update text on the "Home" page for 6.0.1?
XC

XC90
2005-04-08, 15:20
initial scan needs to fill out the database which takes more time than 5.4. 32k
is a lot, so I really couln't say how long. 3 hours does seem a bit long, but
there are a lot of factors to consider. I'm also not sure how you saw an
updated count on 5.4.x since that message you see now was also there in 5.4.x.

if you want to see an updated count, use the player and go into
settings->information->library information->tracks

-kdf


Hi there,
Thanks for working this through with me. Additional info:

a) Perhaps it was 5.1, but there was no such message on the "Home" page that says what 6.0.1 is saying know. Why do I say this? Because there is no message on the "Home" page of 6.0.1... nothing... nada. Just a big blanks, light gray bar at the top. The only time it says the above message is when I click into "Browse Artists," "Browse Albums," etc. Than and only then, on that certain page, does it give the message.

b) Is there a way to see the track info on the web server part? I do not implement the "Settings" on the player and it is in another room altogether from where I'm working.

Thank you,
XC

kdf
2005-04-08, 15:28
Quoting XC90 <XC90.1n6xzn (AT) no-mx (DOT) forums.slimdevices.com>:

>
> kdf Wrote:
> >
> > initial scan needs to fill out the database which takes more time than
> > 5.4. 32k
> > is a lot, so I really couln't say how long. 3 hours does seem a bit
> > long, but
> > there are a lot of factors to consider. I'm also not sure how you saw
> > an
> > updated count on 5.4.x since that message you see now was also there in
> > 5.4.x.
> >
> > if you want to see an updated count, use the player and go into
> > settings->information->library information->tracks
> >
> > -kdf
>
>
> Hi there,
> Thanks for working this through with me. Additional info:
>
> a) Perhaps it was 5.1, but there was no such message on the "Home" page
> that says what 6.0.1 is saying know. Why do I say this? Because there is
> no message on the "Home" page of 6.0.1... nothing... nada. Just a big
> blanks, light gray bar at the top. The only time it says the above
> message is when I click into "Browse Artists," "Browse Albums," etc.
> Than and only then, on that certain page, does it give the message.

That message in the grey bar is suposed to be there while scanning is taking
place. Are you using iTunes? how about checking teh debugging with d_info,
then open http://serverIP:9000/log.txt

>
> b) Is there a way to see the track info on the web server part? I do
> not implement the "Settings" on the player and it is in another room
> altogether from where I'm working.
>
only by using the log, mentioned above.

-kdf

XC90
2005-04-08, 15:30
One last note... maybe it matters, maybe not.

When I first installed SlimServer 6.0.1 it started scanning when I started the server. About 5 minutes after that, I shut down the machine to take it back to my "server room." It was at that point that I started the server a second time and have had, what is going on, 4 hours of scanning (mind you, 5.4 or 5.1 [I forget which I had] performed the exact same feat with the exact same library in 20-30 min's).

Might the database have gotten corrupted that first time when it shut down if, as you mention, it tries to fill out the database that first run? Is there a way to wipe the database (which file do I delete?) and start it fresh?

Thanks again,
XC

* Also, I'm using a first-model SLIMP3 with Firmware 2.2.

XC90
2005-04-08, 15:47
OMG, OMG.

Well, it just stopped indexing at over 4 hours, and... the interface could not be any slower. I like to navigate browsing by the file system's "Music Folder" and this is just the slowest thing I could ever imagine.

Going back and forth betwen a folder that has 582 Artists takes at least 15-20 seconds. My olde SlimServer (whether it was 5.4 or 5.1) used to take about 2. I cannot believe the slow down with this 6.0.1. Has anyone else noticed this after upgrading? I'm talking about browding by the file system here.

Looks like I'd better do a search for uninstalling 6.0.1 and giving 5.4 a try.
XC

Dan Sully
2005-04-08, 15:51
* XC90 shaped the electrons to say...

>Well, it just stopped indexing at over 4 hours, and... the interface
>could not be any slower. I like to navigate browsing by the file
>system's "Music Folder" and this is just the slowest thing I could ever imagine.
>
>Going back and forth betwen a folder that has 582 Artists takes at
>least 15-20 seconds. My olde SlimServer (whether it was 5.4 or 5.1)
>used to take about 2. I cannot believe the slow down with this 6.0.1.
>Has anyone else noticed this after upgrading? I'm talking about
>browding by the file system here.

Browsing by Music Folder is a somewhat intensive process. Do you have "Sort
by Filename" turned on or off in the Settings page?

Some more information is needed too - How many directories are at your top level?

What type of machine is this? CPU? Memory?

What is the speed of Browse Artist, etc compared to Browse Music Folder?

-D
--
dd if=/dev/sarcasm of=/dev/clue

kdf
2005-04-08, 15:52
Quoting XC90 <XC90.1n6ygb (AT) no-mx (DOT) forums.slimdevices.com>:

>
> One last note... maybe it matters, maybe not.
>
> When I first installed SlimServer 6.0.1 it started scanning when I
> started the server. About 5 minutes after that, I shut down the machine
> to take it back to my "server room." It was at that point that I started
> the server a second time and have had, what is going on, 4 hours of
> scanning (mind you, 5.4 or 5.1 [I forget which I had] performed the
> exact same feat with the exact same library in 20-30 min's).
>
> Might the database have gotten corrupted that first time when it shut
> down if, as you mention, it tries to fill out the database that first
> run? Is there a way to wipe the database (which file do I delete?) and
> start it fresh?

server settings->performance->wipe cache
or
delete ~/Library/Caches/SlimServer/slimserversql.db and restart server

-kdf

JJZolx
2005-04-08, 16:10
Dumb question, but how do you know when a rescan has finished, and should you avoid browsing while rescanning?
________
volcano vaporizer (http://vaporizer.org/)

Dan Sully
2005-04-08, 16:16
* JJZolx shaped the electrons to say...

>Dumb question, but how do you know when a rescan has finished, and
>should you avoid browsing while rescanning?

Browsing while rescanning is ok. There's a line at the top which will say
"SlimServer is currently scanning your library.."

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?

Jack Coates
2005-04-08, 16:17
JJZolx wrote:
> Dumb question, but how do you know when a rescan has finished, and
> should you avoid browsing while rescanning?
>
>

When the grey bar on the left says "X albums containing Y songs by Z
artists". It's okay to use it while it's scanning.

--
Jack at Monkeynoodle dot Org: It's a Scientific Venture...
Riding the Emergency Third Rail Power Trip since 1996!

Steven Moore
2005-04-09, 05:53
If you are on os x you can use the activity monitor and when perl drops
from 90%cpu to around 3% or so it has finished scanning.
BTW it takes around 50 mins on my imac for around 9000 tracks, so 4hrs
for 36,000 is not far off.

Steven Moore

On 9 Apr 2005, at 12:17 am, Jack Coates wrote:

> JJZolx wrote:
>> Dumb question, but how do you know when a rescan has finished, and
>> should you avoid browsing while rescanning?
>
> When the grey bar on the left says "X albums containing Y songs by Z
> artists". It's okay to use it while it's scanning.
>
> --
> Jack at Monkeynoodle dot Org: It's a Scientific Venture...
> Riding the Emergency Third Rail Power Trip since 1996!
>

XC90
2005-04-09, 06:12
Thanks for the tips.

For my needs, I went back down to 5.1.5 like I had before (going from 6.0.1 to 5.4.1 to 5.1.5). The only way I use my SLIMP3 is "Browse Music Folder" - no iTunes, plugins or other bells and whistles. Anything above this release seems to really slow down the folder navigation on the player. In fairness, it could be because my player Firmware is 2.2 and the newer servers ask for an updated version.

See ya,
XC