PDA

View Full Version : SS 6.0.1: UTF-8 in file/directory name



Dolf Dijkstra
2005-04-04, 12:04
Hi,

Just upgraded my 5.4 slim server to 6.0.1 (on RH9) to host my new SB2.

After the scan I found my collection a bit small.

Looked in slimserver.log

utf8 "\xE9" does not map to Unicode at
/usr/local/slimserver/Slim/Formats/Parse.pm line 131.
[/music/test/own/Latin/Various Artists/Caf\xE9 Do Brazil/Marcos Valle - A
Vontage De Rever Voce 09.flac] does not exist or cannot be read: No such
file or directory at /usr/local/slimserver/CPAN/Audio/FLAC/Header.pm line
59, <GEN6> line 6. <similar lines reported often)

I have unloaded most of my music via a samba3 share. On windows explorer (on
XP) this directroty looks ok: Café Do Brazil (with the accented e). Linux ls
like it less, but I don't (didn't??) really care about what ls says because
5.4 did not have issues with these file/directory names.

Please don't tell me that I need to rename all my directories :(. There must
but a silver bullit somewhere.

Anybody who has dealt with this before or give me some hints on how to
recover?

Thanks

Dolf

Dan Sully
2005-04-04, 12:07
* Dolf Dijkstra shaped the electrons to say...

>utf8 "\xE9" does not map to Unicode at
>/usr/local/slimserver/Slim/Formats/Parse.pm line 131.
>[/music/test/own/Latin/Various Artists/Caf\xE9 Do Brazil/Marcos Valle - A
>Vontage De Rever Voce 09.flac] does not exist or cannot be read: No such
>file or directory at /usr/local/slimserver/CPAN/Audio/FLAC/Header.pm line
>59, <GEN6> line 6. <similar lines reported often)
>
>I have unloaded most of my music via a samba3 share. On windows explorer (on
>XP) this directroty looks ok: Café Do Brazil (with the accented e). Linux ls
>like it less, but I don't (didn't??) really care about what ls says because
>5.4 did not have issues with these file/directory names.
>
>Please don't tell me that I need to rename all my directories :(. There must
>but a silver bullit somewhere.

Is your music on the Windows machine (via Samba) or local to the RH9 machine?

What does your LC_CTYPE environment variable look like?

I'm assuming it's: en_US.UTF-8 (or similar).

Can you try setting it to:

export LC_CTYPE=en_US.ISO-8859-1

and rescanning?

-D
--
They're techno trousers, ex-NASA, fantastic for walkies!