PDA

View Full Version : 6.0 exits after clicking player settings for non-SB



Cormac Long
2005-04-04, 08:09
Folks,
I found the following just now when trying to use XMMS to connect my
server (Linux FC3 running 6.0).. it would connect, even play audio.. but
when I tried to click the "player settings for.." link the server would
crash/exit leaving the following in /tmp/slimserver.log..

Can't locate object method "playingModeOptions" via package
"Slim::Player::HTTP" at /usr/local/slimserver//Slim/Web/Setup.pm line
157.

Anyway I sorted it with an upgrade to the latest nightly which adds an
IF to check that the client is actually a player (SB) before accessing
the offending property...

just thought I'd post this in case anyone else sees the same behaviour.

--


Regards,
Cormac

kdf
2005-04-04, 09:53
Quoting Cormac Long <cormac_long (AT) yahoo (DOT) co.uk>:

> Folks,
> I found the following just now when trying to use XMMS to connect my
> server (Linux FC3 running 6.0).. it would connect, even play audio.. but
> when I tried to click the "player settings for.." link the server would
> crash/exit leaving the following in /tmp/slimserver.log..
>
> Can't locate object method "playingModeOptions" via package
> "Slim::Player::HTTP" at /usr/local/slimserver//Slim/Web/Setup.pm line
> 157.
>
> Anyway I sorted it with an upgrade to the latest nightly which adds an
> IF to check that the client is actually a player (SB) before accessing
> the offending property...
>
> just thought I'd post this in case anyone else sees the same behaviour.

Thanks for the report. Once you try the nightly, you sould have no more
problems with this one. It was reported shortly after the release, and has
since been fixed. This issue affected any clients connecting using the
stream.mp3 url and is fixed in both the 6.1 and 6.0.1 nightly builds.

-kdf