PDA

View Full Version : Is it time to recall 6? Anyone get it working on Suseor RH 7.2?



Johnny Stork
2005-04-01, 17:36
I guess I was a bit harsh, and premature with the "recall" in the subject. I take it back. I actually removed 5 and re-installed 5.4 just to keep things working and before I start heading down the path of trying to check permissions and paths, my question is why/how could that be a possibloe source of the problem if the same machine was running fine with 5.4? Actually, I am planning to rebuild that machine on RH4 before the end of April so I might just wait and try a clean install of 6 on the RH distro.

-----Original Message-----
From: Dan Sully [mailto:dan (AT) slimdevices (DOT) com]
Sent: Friday, April 01, 2005 4:15 PM
To: Slim Devices Discussion
Subject: [slim] Is it time to recall 6? Anyone get it working on
Suse or RH 7.2?


* Johnny Stork shaped the electrons to say...

> Ok, I have been happily running 5.4 on Suse 9 with no problems but now
> cannot get 6.0.1 to start on either the same Suse 9 box or a RH 7.2
> box. Under Suse, after uninstalling 5.4, I installed by rpm and tried
> to start the service and get the following:

SlimServer 6 does not work on RedHat 7.x - as RedHat has a broken perl there.

It should work on SuSe, but I've not tried it personally - I know a few
people on the list are running it.

The error below indicates that SlimServer is having trouble finding / writing
to the cache directory. Please make sure your permissions / users are
correct. You might also check your pref file to make sure it's not set to an
invalid path there.

> Use of uninitialized value in -e at
> /usr/local/slimserver/Slim/Utils/Prefs.pm line 123.
> Use of uninitialized value in -d at /usr/lib/perl5/5.8.3/File/Path.pm
> line 153.

-D
--
Minds are like parachutes... they work best when open.