PDA

View Full Version : slim.exe dies on any attempt to play



Steve Collier
2005-04-01, 05:53
Hi -

I have a recurrent problem that's happened intermittently in v5.x and still
persists in v6 now that I have installed a SB2 that arrived yesterday.

Slimserver starts up OK. When I watch the processes, slim.exe also starts up
and reaches about 50megs of memory to accommodate my database of songs from
when last it was working. Slimserver and the two squeezeboxes allow me to
see my record collection, browse albums, etc. But as soon as I try to play
anything, slim.exe dies after a few seconds, hence slimserver can't do
anything, including refresh its own window-panes. A restart of slim doesn't
fix it. Nor does a reboot. Nor does a reinstallation of slim over top top of
the old fix anything. Slim uses my iTunes library, which is still working
happily.

What do you suggest I do? If you suggest a full install, what do I have to
manually delete to guarantee everything fresh? Is there some less drastic
fix?

Please be patient as I am attempting to be an ordinary user, not a
programmer. For that reason I'm not a regular list subscriber because of the
traffic level - my email is steve.collier (AT) earthling (DOT) net. Thanks for any
help. It is frustrating having one of the new boxes and not being able to
use it!

---
On probably an unrelated issue I have seen these two error messages
generated by scripts (but not always):

Line: 221
Char: 4
Error: Object doesn't support the property or method

Line 228
Char 1
Error: parent playlist location is null or not an object

Stephen Glen Collier
2005-04-08, 04:07
Thanks to the suggestion to run slim.exe debugging in a cmd window from
Vidur (IIRC, from the plugin directory run "slim.exe --d_source"), I see
what is happening. The problem was iTunes updater (the 3rd party plugin that
lets one add iTunes ratings on the fly). Even though I had installed the v6
compatible version of this, the subdirectory under plugins for the old
version still existed. Somehow, the old version was activated when slim
started up. As soon as there was any attempt to play, this old version
didn't work, hence slim.exe died. I cured the problem by simply deleting
the old directory and its contents.

SteveC


-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Steve Collier
Sent: 1. april 2005 14:54
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] slim.exe dies on any attempt to play


Hi -
I have a recurrent problem that's happened intermittently in v5.x and still
persists in v6 now that I have installed a SB2 that arrived yesterday.
Slimserver starts up OK. When I watch the processes, slim.exe also starts up
and reaches about 50megs of memory to accommodate my database of songs from
when last it was working. Slimserver and the two squeezeboxes allow me to
see my record collection, browse albums, etc. But as soon as I try to play
anything, slim.exe dies after a few seconds, hence slimserver can't do
anything, including refresh its own window-panes. A restart of slim doesn't
fix it. Nor does a reboot. Nor does a reinstallation of slim over top top of
the old fix anything. Slim uses my iTunes library, which is still working
happily.
What do you suggest I do? If you suggest a full install, what do I have to
manually delete to guarantee everything fresh? Is there some less drastic
fix?
Please be patient as I am attempting to be an ordinary user, not a
programmer. For that reason I'm not a regular list subscriber because of the
traffic level - my email is steve.collier (AT) earthling (DOT) net. Thanks for any
help. It is frustrating having one of the new boxes and not being able to
use it!
---
On probably an unrelated issue I have seen these two error messages
generated by scripts (but not always):
Line: 221
Char: 4
Error: Object doesn't support the property or method
Line 228
Char 1
Error: parent playlist location is null or not an object