PDA

View Full Version : Windows Service Dead



Nick Locke
2005-03-27, 06:14
Hi, I have the "pukka" 6 beta from the front page of the web site.
Periodically, the Windows service dies with this.....

The description for Event ID ( 0 ) in Source ( Application ) cannot be found.
The local computer may not have the necessary registry information or message
DLL files to display messages from a remote computer. You may be able to use
the /AUXSOURCE= flag to retrieve this description; see Help and Support for
details.

The following information is part of the event: Can't call method "title" on
an undefined value at /PerlApp/Slim/Buttons/TrackInfo.pm line 223.

..... in the error log. The last bit seems to give a big clue!

Not being a Perl person, I haven't tried to find the line of code. It's
probably something simple. Thoughts welcome. Thanks

Nick

Dan Sully
2005-03-27, 10:18
* Nick Locke shaped the electrons to say...

>The description for Event ID ( 0 ) in Source ( Application ) cannot be found.
>The local computer may not have the necessary registry information or message
>DLL files to display messages from a remote computer. You may be able to use
>the /AUXSOURCE= flag to retrieve this description; see Help and Support for
>details.
>
>The following information is part of the event: Can't call method "title" on
>an undefined value at /PerlApp/Slim/Buttons/TrackInfo.pm line 223.
>
>.... in the error log. The last bit seems to give a big clue!

Thanks - I've been in a fix so it doesn't crash. Are you able to reproduce this?

What item did you select track info on?

Thanks.

-D
--
<iNoah> all your base class are belong to us

Nick Locke
2005-03-28, 00:25
Dan Sully <dan@...> writes:

>> Can't call method "title" on
>> an undefined value at
>> /PerlApp/Slim/Buttons/TrackInfo.pm line 223.
>
> Thanks - I've been in a fix so it
> doesn't crash. Are you able to reproduce this?
>
> What item did you select track info on?

I'm not deliberately selecting track info - I assume that happens as a side
effet of trying to play the track?

The only thing I can see is that the file name has an apostrophe (single
quote) in it, as does the Title MP3 tag.

Just tried going back to the previous version of SlimServer and it works fine
there. It is reproduceable on 6 - the service stops every time I try to play
that track.

Nick

Nick Locke
2005-04-01, 15:20
Nick Locke <nick@...> writes:

>
> Dan Sully <dan <at> ...> writes:
>
> >> Can't call method "title" on
> >> an undefined value at
> >> /PerlApp/Slim/Buttons/TrackInfo.pm line 223.
> >

Just tried the "production" release of 6. Seems to be fixed in there. Thanks
guys!