PDA

View Full Version : Special character problem in 6.0 (latest nightly)



Peter
2005-03-25, 16:22
Hi,

When I scan and read all my music-files and everything is perfect, but when
I add (or include) with this content:

D:\Music\Magi I Luften - 1985\2\14 - Lis S°rensen - Mine ějne De Skal Se.mp3

It results in this result when I browse it from the web-interface:

14. Lis S?en - Mine ?jne De Skal Se (Magi I Luften - 1985) from 2

The file that the playlist is refering to is already in the database, but it
seems that slimserver converts the playlist entry wrongly (The file is ANSI,
not UTF8). After I've browsed the playlist the slim database is wrong,
under albums there's a wrong empty entry named "2" and under artists i find
"Magi I Luften - 1985"

Thanks,
Peter

Dan Sully
2005-03-25, 16:24
* Peter shaped the electrons to say...

>When I scan and read all my music-files and everything is perfect, but when
>I add (or include) with this content:
>
>D:\Music\Magi I Luften - 1985\2\14 - Lis S├Şrensen - Mine ├śjne De Skal Se.mp3
>
>It results in this result when I browse it from the web-interface:
>
>14. Lis S?en - Mine ?jne De Skal Se (Magi I Luften - 1985) from 2
>
>The file that the playlist is refering to is already in the database, but it
>seems that slimserver converts the playlist entry wrongly (The file is ANSI,
>not UTF8). After I've browsed the playlist the slim database is wrong,
>under albums there's a wrong empty entry named "2" and under artists i find
>"Magi I Luften - 1985"

This sounds similar to bug http://bugs.slimdevices.com/show_bug.cgi?id=1139

I've been working up a patch for this - it should be in tonight after a bit more testing.

-D
--
There is no emergency. Nothing to see here. Move along.