PDA

View Full Version : Slimserver error in opening localhost connection



Doug Huskey
2005-03-23, 10:57
Thanks for the tips. I will try the additional switches tonight. I have a feeling some basic thing is hosed in my OS... I was having some funny problems under 2000 and the simple upgrade to XP didn't fix them, so I am now just about decided to wipe the disk and do a clean XP install and start over ... lot of trouble, but whats a mother to do lah? Bill Gates strikes again. ;)

I am able to run winamp and connect to the desktop slimserver from the laptop without problem, and can also open the browser with // <IP addr>:9000 to the other box, so I don't think its a firewall or port issue.

Anyway tonight will try the additional switches to learn what I can... and if I am ambitious I might just rebuild the whole laptop hard disk.

Doug

kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
Quoting Doug Huskey :

> Thanks for the tip on starting slimserver with debugging. Where are the
> command-line switches documented?

"c:\program files\slimserver\server\slim.exe" --help

> I started it up in a debug window and realized that it is not hanging but
> gets an error on when it attempts to open the graphic window with a local
> host connection:
>
> Timeout on connect to [localhost:10002]: 10035: Unknown error
>
This is the attempt to find musicmagic, should be harmless since it is just
timing out as it has been told to do.

> It is not possible to connect to it from a web browser after that, and
> although slim.exe is running it doesn't seem possible to get it to initiate a
> playlist or play.
>
> Any ideas as to what is going on ? or how I should debug this further?

do you have any firewall blocking port 9000? try d_http to check on any incoming
connections to the server, d_info to make sure its done scanning (which might
slow down an initial browser connection)

-kdf