PDA

View Full Version : 3/17 nightly Fishbone searching/display rough edges



Steve Baumgarten
2005-03-17, 19:20
In general the 3/17 nightly is looking good. I'm playing with both
Fishbone and Exbrowse2; so far Fishbone is still my favorite skin. But
here are a few odd things w/r/t searching and display in Fishbone:

1. The "search for songs" popup. Normally I don't want to search for
songs, but rather for artists or perhaps albums. So it would be nice to
have the default be one of those choices. Otherwise if you don't pay
attention and enter an artist name, you get no results. This is
basically worse than the live search, which at least attempts to match
everything.

2. Let's say I enter a song in the field next to the popup. I enter
"Dakota", which matches a track on the latest Stereophonics album. What
I see, however, is this:

Dakota from Language. Sex. Violence. Other?

No sign of the artist name there. In other situations I see

Title (Artist)

but not for these results. This is also true if I search using the
"Advanced Search" form (which makes me think that this is what the form
next to the popup submits to behind the scenes). However, I if search
using the "Live Search" form, I do get the artist.

3. If I click on an album name from search results, I see all the tracks
in the album (and the artist name, which may not have been presented to
me up until that point). But no artwork. Basically, although I'm in a
logical "album view" at that point, the look is different than if I did
a "browse albums" and then selected that album. (I think this is because
I'm actually in "Browse Songs" mode rather than "Browse Album" mode.)

4. I choose "Search Music" from the popup. This brings me to the "Live
Search" page, where whatever I enter is matched against artist, album,
track, etc. That's fine -- but why does the submit button read "Search
Songs"? Shouldn't it read "Search Music"?

5. When viewing song info the artwork should be constrained, I think, as
it is when viewing an album. Some of my JPGs are pretty big/high res.

6. In song info view, if I click the artist a whole new window pops up
with a browse for that artist. I'd expect just the frame to refresh with
that info.

So these are really just rough edges rather than major problems;
otherwise, as I mentioned above, Fishbone and Slimserver 6.0b1 3/17 are
looking very good -- way better than 5.4.

Nice work, guys!

SBB

kdf
2005-03-17, 21:24
Quoting Steve Baumgarten <sbb (AT) panix (DOT) com>:

> In general the 3/17 nightly is looking good. I'm playing with both
> Fishbone and Exbrowse2; so far Fishbone is still my favorite skin. But
> here are a few odd things w/r/t searching and display in Fishbone:
>
> 1. The "search for songs" popup. Normally I don't want to search for
> songs, but rather for artists or perhaps albums. So it would be nice to
> have the default be one of those choices. Otherwise if you don't pay
> attention and enter an artist name, you get no results. This is
> basically worse than the live search, which at least attempts to match
> everything.

I hear ya, but the search list is generated from teh server. I added the
hardcoded search for songs becuase it needed a default and I was just wasting
too much time trying to keep up with rewriting the cookies everytime anything
changed. When I figure out how to launch livesearch from the text field, I
will get rid of search for songs.

>
> 2. Let's say I enter a song in the field next to the popup. I enter
> "Dakota", which matches a track on the latest Stereophonics album. What
> I see, however, is this:
>
> Dakota from Language. Sex. Violence. Other?
>
> No sign of the artist name there. In other situations I see
>
> Title (Artist)


I'm not following you on this one. if I type in a word, I get a list of song,
with artist and album links

> 3. If I click on an album name from search results, I see all the tracks
> in the album (and the artist name, which may not have been presented to
> me up until that point). But no artwork. Basically, although I'm in a
> logical "album view" at that point, the look is different than if I did
> a "browse albums" and then selected that album. (I think this is because
> I'm actually in "Browse Songs" mode rather than "Browse Album" mode.)

possibly a bad link served up from pages then. I'll check on it.


> 4. I choose "Search Music" from the popup. This brings me to the "Live
> Search" page, where whatever I enter is matched against artist, album,
> track, etc. That's fine -- but why does the submit button read "Search
> Songs"? Shouldn't it read "Search Music"?

oddly, I got yelled at just a week or two ago for just the opposite. if you
click the button, what you get is the manual search, a search for songs. if
you simply type, you get the real live search that reacts to each key press.
This probably needs a description...

>
> 5. When viewing song info the artwork should be constrained, I think, as
> it is when viewing an album. Some of my JPGs are pretty big/high res.

another one I have been barked at about for having contrained (thus grainy).
you can edit the skin to have your own, anyone can. no offense, but I just
have to call and end to the ping pong at some point.

> 6. In song info view, if I click the artist a whole new window pops up
> with a browse for that artist. I'd expect just the frame to refresh with
> that info.

thanks, I'll fix that.

many thanks for all the feedback...keep it up :)
-kdf

Steve Baumgarten
2005-03-18, 08:02
kdf wrote:

> I hear ya, but the search list is generated from teh server. I added the
> hardcoded search for songs becuase it needed a default and I was just wasting
> too much time trying to keep up with rewriting the cookies everytime anything
> changed. When I figure out how to launch livesearch from the text field, I
> will get rid of search for songs.

That makes the most sense. I got the idea it was basically a compromise
right now between the old way of doing things and the new.

>>2. Let's say I enter a song in the field next to the popup. I enter
>>"Dakota", which matches a track on the latest Stereophonics album. What
>>I see, however, is this:
>>
>>Dakota from Language. Sex. Violence. Other?
>>
>
> I'm not following you on this one. if I type in a word, I get a list of song,
> with artist and album links

Let's say you type in a song title, as above. It matches perfectly, that
one song. What you see in the results looks exactly like this:

SongTitle from AlbumName

I'd expect it to look like this:

SongTitle from AlbumName (Artist)

In all other cases you get the artist name in parentheses after the
album name, but not when you do a Song Search from the popup or an
Advanced Search.

If you type "SongTitle" into Live Search vs. the Advanced Search, you'll
see the difference in output.

For me, not seeing the artist makes it harder to figure out if I got the
right match or not.

>>3. If I click on an album name from search results, I see all the tracks
>>in the album (and the artist name, which may not have been presented to
>>me up until that point). But no artwork. Basically, although I'm in a
>>logical "album view" at that point, the look is different than if I did
>>a "browse albums" and then selected that album. (I think this is because
>>I'm actually in "Browse Songs" mode rather than "Browse Album" mode.)
>
> possibly a bad link served up from pages then. I'll check on it.

Thanks. That's been the biggest annoyance (of all these minor
annoyances). I love seeing hte artwork with the album listing, and there
do seem to be a lot of ways you can get into "Browse Songs" that shows
all tracks from an album (but no artwork) vs. a true "Browse Album" mode
that does show the artwork. My feeling was any time you click on an
album link, you should get to the "Browse Album" page.

>>4. I choose "Search Music" from the popup. This brings me to the "Live
>>Search" page, where whatever I enter is matched against artist, album,
>>track, etc. That's fine -- but why does the submit button read "Search
>>Songs"? Shouldn't it read "Search Music"?
>
>
> oddly, I got yelled at just a week or two ago for just the opposite. if you
> click the button, what you get is the manual search, a search for songs. if
> you simply type, you get the real live search that reacts to each key press.
> This probably needs a description...

Yow, I had no idea you got two different results based on whether you
clicked the button or not. There may be too many ways to search at this
point...

>>5. When viewing song info the artwork should be constrained, I think, as
>>it is when viewing an album. Some of my JPGs are pretty big/high res.
>
>
> another one I have been barked at about for having contrained (thus grainy).
> you can edit the skin to have your own, anyone can. no offense, but I just
> have to call and end to the ping pong at some point.

Perhaps a preference for those who don't want to edit skins? Constrain
artwork to X by X pixels; this just gets spit out as the HEIGHT and
WIDTH tags when displaying artwork in any situation.

But yes, I can certainly edit the song info skin myself.

> many thanks for all the feedback...keep it up :)

Sure. Just trying to help make the best Slimserver skin even better.

By the way, I took a break from fooling with Fishbone to try some music
searches and browsing on the player last night -- it's fantastic now!
Extremely responsive even for song searches, even while streaming
uncompressed over wireless. Again, this is such a huge improvement over
5.4 -- nice work everyone!

SBB





Visit our website at http://www.ubs.com

This message contains confidential information and is intended only
for the individual named. If you are not the named addressee you
should not disseminate, distribute or copy this e-mail. Please
notify the sender immediately by e-mail if you have received this
e-mail by mistake and delete this e-mail from your system.

E-mail transmission cannot be guaranteed to be secure or error-free
as information could be intercepted, corrupted, lost, destroyed,
arrive late or incomplete, or contain viruses. The sender therefore
does not accept liability for any errors or omissions in the contents
of this message which arise as a result of e-mail transmission. If
verification is required please request a hard-copy version. This
message is provided for informational purposes and should not be
construed as a solicitation or offer to buy or sell any securities or
related financial instruments.

kdf
2005-03-18, 11:00
Quoting Steve Baumgarten <sbb (AT) panix (DOT) com>:

>
> Let's say you type in a song title, as above. It matches perfectly, that
> one song. What you see in the results looks exactly like this:
>
> SongTitle from AlbumName
>
> I'd expect it to look like this:
>
> SongTitle from AlbumName (Artist)

this would be because your titleformat is set to TITLE from ALBUM (ARTIST) ?

>
> In all other cases you get the artist name in parentheses after the
> album name, but not when you do a Song Search from the popup or an
> Advanced Search.
>
> If you type "SongTitle" into Live Search vs. the Advanced Search, you'll
> see the difference in output.

aside from colour and some slight layout differences due to the hardcoded nature
of livesearch, I actually dont. A screenshot will help. Perhaps this song you
are using for your example is missing its artist tag? I'll have to try the
different titleformat to see maybe. I always use TITLE, so that I get the
artist and album links provided by the skin.

> For me, not seeing the artist makes it harder to figure out if I got the
> right match or not.

agreed.

> >>3. If I click on an album name from search results, I see all the tracks
> >>in the album (and the artist name, which may not have been presented to
> >>me up until that point). But no artwork. Basically, although I'm in a
> >>logical "album view" at that point, the look is different than if I did
> >>a "browse albums" and then selected that album. (I think this is because
> >>I'm actually in "Browse Songs" mode rather than "Browse Album" mode.)
> >
> > possibly a bad link served up from pages then. I'll check on it.
>
> Thanks. That's been the biggest annoyance (of all these minor
> annoyances). I love seeing hte artwork with the album listing, and there
> do seem to be a lot of ways you can get into "Browse Songs" that shows
> all tracks from an album (but no artwork) vs. a true "Browse Album" mode
> that does show the artwork. My feeling was any time you click on an
> album link, you should get to the "Browse Album" page.

this should be fixed in today's nightly, at least for fishbone, default and EN.
Handheld was recently updated, so that will appear in tomorrow's build


> > many thanks for all the feedback...keep it up :)
>
> Sure. Just trying to help make the best Slimserver skin even better.

that's the idea :)

Steve Baumgarten
2005-03-18, 13:11
>>Let's say you type in a song title, as above. It matches perfectly, that
>>one song. What you see in the results looks exactly like this:
>>
>>SongTitle from AlbumName
>>
>>I'd expect it to look like this:
>>
>>SongTitle from AlbumName (Artist)
>
> this would be because your titleformat is set to TITLE from ALBUM (ARTIST) ?

It's set to "TITLE (ARTIST)". Which is why I was surprised to not see an
artist as part of the search results for that particular search.

> aside from colour and some slight layout differences due to the hardcoded nature
> of livesearch, I actually dont. A screenshot will help. Perhaps this song you
> are using for your example is missing its artist tag? I'll have to try the
> different titleformat to see maybe. I always use TITLE, so that I get the
> artist and album links provided by the skin.

The track is tagged correctly; I can include a screenshot tonight if you
haven't been able to duplicate it by then. I'm pretty sure it's because
you're using "TITLE" and I'm using "TITLE (ARTIST)". If you change title
formats and still don't see what I'm seeing, I'll send a screenshot.

>>My feeling was any time you click on an
>>album link, you should get to the "Browse Album" page.
>
>
> this should be fixed in today's nightly, at least for fishbone, default and EN.
> Handheld was recently updated, so that will appear in tomorrow's build

Excellent.

BTW, with the 3/17 build I don't see the version number on the server
settings page, as I did with a prior nightly. Now I just see "6.0b1".

(This is after a complete reinstall, wiping out the entire directory
except for the preferences file, which I saved.)

SBB


Visit our website at http://www.ubs.com

This message contains confidential information and is intended only
for the individual named. If you are not the named addressee you
should not disseminate, distribute or copy this e-mail. Please
notify the sender immediately by e-mail if you have received this
e-mail by mistake and delete this e-mail from your system.

E-mail transmission cannot be guaranteed to be secure or error-free
as information could be intercepted, corrupted, lost, destroyed,
arrive late or incomplete, or contain viruses. The sender therefore
does not accept liability for any errors or omissions in the contents
of this message which arise as a result of e-mail transmission. If
verification is required please request a hard-copy version. This
message is provided for informational purposes and should not be
construed as a solicitation or offer to buy or sell any securities or
related financial instruments.

kdf
2005-03-18, 13:16
Quoting Steve Baumgarten <sbb (AT) panix (DOT) com>:

> >>Let's say you type in a song title, as above. It matches perfectly, that
> >>one song. What you see in the results looks exactly like this:
> >>
> >>SongTitle from AlbumName
> >>
> >>I'd expect it to look like this:
> >>
> >>SongTitle from AlbumName (Artist)
> >
> > this would be because your titleformat is set to TITLE from ALBUM (ARTIST)
> ?
>
> It's set to "TITLE (ARTIST)". Which is why I was surprised to not see an
> artist as part of the search results for that particular search.

This is a bug that didn't show itself until titleformat was not just TITLE.
should be fixed for tomorrow.


>
> BTW, with the 3/17 build I don't see the version number on the server
> settings page, as I did with a prior nightly. Now I just see "6.0b1".

the version number wasn't working right, so its gone.
-kdf

Steve Baumgarten
2005-03-18, 13:38
> This is a bug that didn't show itself until titleformat was not just TITLE.
> should be fixed for tomorrow.

Cool. I'll hold off on more testing until the weekend. (The other day I
saw a rescan triggered from the web interface miss new albums, but I
wanted to get a reproducible case before reporting it. In that case I
did a "wipe cache" and after that completed the tracks were picked up;
in any event I'll do some more focused testing over the weekend with the
latest nightly.)

SBB




Visit our website at http://www.ubs.com

This message contains confidential information and is intended only
for the individual named. If you are not the named addressee you
should not disseminate, distribute or copy this e-mail. Please
notify the sender immediately by e-mail if you have received this
e-mail by mistake and delete this e-mail from your system.

E-mail transmission cannot be guaranteed to be secure or error-free
as information could be intercepted, corrupted, lost, destroyed,
arrive late or incomplete, or contain viruses. The sender therefore
does not accept liability for any errors or omissions in the contents
of this message which arise as a result of e-mail transmission. If
verification is required please request a hard-copy version. This
message is provided for informational purposes and should not be
construed as a solicitation or offer to buy or sell any securities or
related financial instruments.