PDA

View Full Version : Live Music Archive plugin on SS6.0



Bill Moseley
2005-03-14, 11:19
I'm missing how to use the Internet Archive plugin. I added
Archive.pm to my Plugins directory and I can see it checked in the
plugin server config setup, so the server has loaded it (I assume).

But, I don't see how I'm suppose to use it. Is it a problem with
using it with 6.0? Or a problem with my understanding of how it's
suppose to work?

I also installed the Biography plugin and can see that in the Plugins
menu on the squeezebox and it works fine, but don't see the Archive plugin
listed.

Thanks,


--
Bill Moseley
moseley (AT) hank (DOT) org

Peter J. Pouliot
2005-04-11, 14:06
Bill, did you ever get a response back to this?

On Mon, 2005-03-14 at 10:19 -0800, Bill Moseley wrote:
> I'm missing how to use the Internet Archive plugin. I added
> Archive.pm to my Plugins directory and I can see it checked in the
> plugin server config setup, so the server has loaded it (I assume).
>
> But, I don't see how I'm suppose to use it. Is it a problem with
> using it with 6.0? Or a problem with my understanding of how it's
> suppose to work?
>
> I also installed the Biography plugin and can see that in the Plugins
> menu on the squeezebox and it works fine, but don't see the Archive plugin
> listed.
>
> Thanks,
>
>

mherger
2005-04-11, 14:19
On Mon, 11 Apr 2005 23:06:55 +0200, Peter J. Pouliot <peter (AT) pouliot (DOT) net>
wrote:

> Bill, did you ever get a response back to this?

I guess the plugin's author would know the best. His address is in the
script code.

> On Mon, 2005-03-14 at 10:19 -0800, Bill Moseley wrote:
>> I'm missing how to use the Internet Archive plugin. I added
>> Archive.pm to my Plugins directory and I can see it checked in the
>> plugin server config setup, so the server has loaded it (I assume).
>>
>> But, I don't see how I'm suppose to use it. Is it a problem with
>> using it with 6.0? Or a problem with my understanding of how it's
>> suppose to work?
>>
>> I also installed the Biography plugin and can see that in the Plugins
>> menu on the squeezebox and it works fine, but don't see the Archive
>> plugin
>> listed.
>>
>> Thanks,
>>
>>
>
>

kdf
2005-04-11, 14:32
Quoting Michael Herger <slim (AT) herger (DOT) net>:

> On Mon, 11 Apr 2005 23:06:55 +0200, Peter J. Pouliot <peter (AT) pouliot (DOT) net>
> wrote:
>
> > Bill, did you ever get a response back to this?
>
> I guess the plugin's author would know the best. His address is in the
> script code.

I believe that the Archive plugin is currently not 6.0+ compatible. I think 6.0
still allowed incompatible plugins to still be listed in the server settings,
depite being useless. 6.0.1 should not list plugins that don't pass the tests.

it is always a good idea to run the server command line, with --d_plugins so
that you can see the error output as the plugin is loaded.

-kdf

Dave Cohen
2005-04-11, 15:51
Bill et al,

Please try the attached plugin for SlimServer 6. Let me know if it
does not work.

-Dave

tvoil
2005-04-13, 11:33
This patch fixed the problem. Thank you. Is there anyway this update will be posted on the main plugin download page of the slimdevices site?

Dave Cohen
2005-04-18, 12:59
This patch fixed the problem. Thank you. Is there anyway this update will be posted on the main plugin download page of the slimdevices site?

Yes, I believe Dean just took care of that. Thanks for the feedback.

rupped
2005-04-21, 12:33
NEVERMIND most problems solved - see edit: below

I can not find an updated plugin for the Internet Archive. Would someone point me in the correct direction, please.

If someone could spend a minute and tell me how one does this "plugin thing", that too would be appreciated.

I am new to the SB thing, but am enjoying the journey....

Thanks,

David Ruppe

Edit: The plugin for Internet Archive that is dated 4/20/04 has apparetnly been updated. Downloaded it into plugin directory and all seemed good. I'm trying to listen to my first dead show (7/74), but I hear the stage announcements over and over again.