PDA

View Full Version : Wow



Healy
2005-03-14, 10:32
Just wanted to say thanks to all the developers of the 6.0 branch. Now
that I've got it working on my setup, I can't believe how much of a
lighter load is on my system. The 5.4.x branch was putting a heavy
load on my memory with over 25,000 songs. 6.0b1 is only using a
fraction. Thanks for the hard work!

-Healy

Steven Moore
2005-03-14, 11:12
Do you know if the 'blank tracks' problem has been solved yet?

Steven Moore
On 14 Mar 2005, at 5:32 pm, Healy wrote:

> Just wanted to say thanks to all the developers of the 6.0 branch.
> Now that I've got it working on my setup, I can't believe how much of
> a lighter load is on my system. The 5.4.x branch was putting a heavy
> load on my memory with over 25,000 songs. 6.0b1 is only using a
> fraction. Thanks for the hard work!
>
> -Healy
>
>

Healy
2005-03-14, 11:48
I don't know what you mean by blank tracks?


On Mar 14, 2005, at 10:12 AM, Steven Moore wrote:

> Do you know if the 'blank tracks' problem has been solved yet?
>
> Steven Moore
> On 14 Mar 2005, at 5:32 pm, Healy wrote:
>
>> Just wanted to say thanks to all the developers of the 6.0 branch.
>> Now that I've got it working on my setup, I can't believe how much of
>> a lighter load is on my system. The 5.4.x branch was putting a heavy
>> load on my memory with over 25,000 songs. 6.0b1 is only using a
>> fraction. Thanks for the hard work!
>>
>> -Healy
>>
>>

Steven Moore
2005-03-14, 13:02
Sorry you may have missed it but a few users including me have reported
6.0b1 showing blank lines instead of tracks when searching and
browsing.

Steven Moore
On 14 Mar 2005, at 6:48 pm, Healy wrote:

> I don't know what you mean by blank tracks?
>
>
> On Mar 14, 2005, at 10:12 AM, Steven Moore wrote:
>
>> Do you know if the 'blank tracks' problem has been solved yet?
>>
>> Steven Moore
>> On 14 Mar 2005, at 5:32 pm, Healy wrote:
>>
>>> Just wanted to say thanks to all the developers of the 6.0 branch.
>>> Now that I've got it working on my setup, I can't believe how much
>>> of a lighter load is on my system. The 5.4.x branch was putting a
>>> heavy load on my memory with over 25,000 songs. 6.0b1 is only using
>>> a fraction. Thanks for the hard work!
>>>
>>> -Healy
>>>
>>>

Dan Sully
2005-03-14, 14:16
* Steven Moore shaped the electrons to say...

>Sorry you may have missed it but a few users including me have reported
>6.0b1 showing blank lines instead of tracks when searching and browsing.

Steven - I'm interested if you can reproduce this in the latest nightly?

What steps? A screenshot of the broken lines would help.

Thanks.

-D
--
There was supposed to be a big kaboom.

Steven Moore
2005-03-14, 16:43
Sorry can't check this:

Deleted all slim stuff.
Downloaded 2005-3-14.
Installed, for when I log in, and preference pane available to all
users.
Pressed start server,
Pressed web access,
Server crashed just after web page loaded.
From log:

2005-03-14 22:08:13.8839 SlimServer OSDetect init...
2005-03-14 22:08:13.8842 SlimServer Strings init...
2005-03-14 22:08:14.6716 SlimServer OS Specific init...
2005-03-14 22:08:14.6733 SlimServer settings init...
2005-03-14 22:08:14.7432 SlimServer setting language...
2005-03-14 22:08:14.7436 SlimServer IR init...
2005-03-14 22:08:14.7611 SlimServer Buttons init...
2005-03-14 22:08:14.7646 SlimServer Graphics init...
2005-03-14 22:08:22.1234 SlimServer starting up...
2005-03-14 22:08:22.1240 SlimServer daemonizing...
2005-03-14 22:08:22.1721 Old SLIMP3 Protocol init...
2005-03-14 22:08:22.2229 Slimproto Init...
2005-03-14 22:08:22.2297 SlimServer HTTP init...
2005-03-14 22:08:22.2840 SlimServer saving pid file.
2005-03-14 22:08:22.2864 Got to the END.
2005-03-14 22:08:22.2870 Got sigint.
2005-03-14 22:08:22.2874 SlimServer cleaning up.
2005-03-14 22:08:22.5525 SlimServer CLI init...
2005-03-14 22:08:22.5962 Source conversion init..
2005-03-14 22:08:22.8077 SlimServer Info init...
2005-03-14 22:08:23.1552 SlimServer MusicFolderScan init...
2005-03-14 22:08:23.1568 SlimServer Plugins init...
2005-03-14 22:08:24.0640 Your data source needs to be configured.
Please open your web browser,
2005-03-14 22:08:24.0643 go to the following URL, and click on the
"Server Settings" link.

2005-03-14 22:08:24.0649 The URL to access SlimServer is now:
http://imac-G4-LCD.local:9000/
2005-03-14 22:08:24.0652 SlimServer persist playlists...
2005-03-14 22:08:24.0657 SlimServer done start...
Can't locate object method "new" via package "Class::DBI::Iterator"
(perhaps you forgot to load "Class::DBI::Iterator"?) at
/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
DataStores/DBI/Track.pm line 150.
2005-03-14 22:08:36.0368 Got to the END.
2005-03-14 22:08:36.0372 Got sigint.
2005-03-14 22:08:36.0374 SlimServer cleaning up.

But further working with it by starting the server with the web page up
and then clicking browsing music etc, i could then get into server
settings.

Then I wiped the cache, and did a rescan, I had to click the use itunes
radio button to get it to see my music.
Rescan is still running 1 hr later, at least a perl process is at
around 70% cpu. Perhaps something wrong with the rescan process?
I Stopped server.


Steven Moore


On 14 Mar 2005, at 9:16 pm, Dan Sully wrote:

> * Steven Moore shaped the electrons to say...
>
>> Sorry you may have missed it but a few users including me have
>> reported 6.0b1 showing blank lines instead of tracks when searching
>> and browsing.
>
> Steven - I'm interested if you can reproduce this in the latest
> nightly?
>
> What steps? A screenshot of the broken lines would help.
>
> Thanks.
>
> -D
> --
> There was supposed to be a big kaboom.
>

Dan Sully
2005-03-14, 16:47
* Steven Moore shaped the electrons to say...

>2005-03-14 22:08:24.0652 SlimServer persist playlists...
>2005-03-14 22:08:24.0657 SlimServer done start...
>Can't locate object method "new" via package "Class::DBI::Iterator"
>(perhaps you forgot to load "Class::DBI::Iterator"?) at
>/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
>DataStores/DBI/Track.pm line 150.

I just fixed this.

>Then I wiped the cache, and did a rescan, I had to click the use itunes
>radio button to get it to see my music.
>Rescan is still running 1 hr later, at least a perl process is at
>around 70% cpu. Perhaps something wrong with the rescan process?
>I Stopped server.

How large is your music collection?

-D
--
"History, I believe, furnishes no example of a priest-ridden people "maintaining a free civil government.
This marks the lowest grade of ignorance of which their civil as well as religious leaders will always
avail themselves for their own purposes." --Thomas Jefferson to Alexander von Humboldt, 1813.

Michael Peters
2005-03-14, 17:03
On Mon, 14 Mar 2005 18:12:14 +0000, Steven Moore
<steven (AT) mooreni (DOT) freeserve.co.uk> wrote:
> Do you know if the 'blank tracks' problem has been solved yet?


I don't know about that - but I do know that I have some probably
improperly encoded mp3's that 5.4.0 could not see (neither could
Rhythmbox - but iPod and sox could play them) that DO work with 6.0b -
so since this is a WoW thread, thumbs up :)

So whatever caused 5.4 to not be able to see them, 6.0b fixed it :)

// No - it's not a tagging issue - I read all the tags into variables,
and had id3v2 delete the tags and then create them fresh - I think
they are just poorly encoded mp3's - they all cut off the end too, but
I need them (voice, for a class, not music) - now they work with slim
:)

--
http://mpeters.us/

Steven Moore
2005-03-15, 01:35
9662 tracks.

On 14 Mar 2005, at 11:47 pm, Dan Sully wrote:

> * Steven Moore shaped the electrons to say...
>
>> 2005-03-14 22:08:24.0652 SlimServer persist playlists...
>> 2005-03-14 22:08:24.0657 SlimServer done start...
>> Can't locate object method "new" via package "Class::DBI::Iterator"
>> (perhaps you forgot to load "Class::DBI::Iterator"?) at
>> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
>> DataStores/DBI/Track.pm line 150.
>
> I just fixed this.
>
>> Then I wiped the cache, and did a rescan, I had to click the use
>> itunes radio button to get it to see my music.
>> Rescan is still running 1 hr later, at least a perl process is at
>> around 70% cpu. Perhaps something wrong with the rescan process?
>> I Stopped server.
>
> How large is your music collection?
>
> -D
> --
> "History, I believe, furnishes no example of a priest-ridden people
> "maintaining a free civil government.
> This marks the lowest grade of ignorance of which their civil as well
> as religious leaders will always
> avail themselves for their own purposes." --Thomas Jefferson to
> Alexander von Humboldt, 1813.
>

Steven Moore
2005-03-15, 02:11
Started the server this morning and did a search, Cpu went to to 70%
again without stopping, log

2005-03-15 08:18:16.3086 SlimServer done start...
getpeername() on closed socket GEN6 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.
getpeername() on closed socket GEN22 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.
syswrite() on closed filehandle GEN23 at
/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
Networking/Select.pm line 164.
getpeername() on closed socket GEN23 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.
getpeername() on closed socket GEN42 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.
getpeername() on closed socket GEN47 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.
getpeername() on closed socket GEN49 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.
getpeername() on closed socket GEN68 at
/System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Socket.pm line
206.

Hope this helps.

Steven Moore
On 15 Mar 2005, at 8:35 am, Steven Moore wrote:

> 9662 tracks.
>
> On 14 Mar 2005, at 11:47 pm, Dan Sully wrote:
>
>> * Steven Moore shaped the electrons to say...
>>
>>> 2005-03-14 22:08:24.0652 SlimServer persist playlists...
>>> 2005-03-14 22:08:24.0657 SlimServer done start...
>>> Can't locate object method "new" via package "Class::DBI::Iterator"
>>> (perhaps you forgot to load "Class::DBI::Iterator"?) at
>>> /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
>>> DataStores/DBI/Track.pm line 150.
>>
>> I just fixed this.
>>
>>> Then I wiped the cache, and did a rescan, I had to click the use
>>> itunes radio button to get it to see my music.
>>> Rescan is still running 1 hr later, at least a perl process is at
>>> around 70% cpu. Perhaps something wrong with the rescan process?
>>> I Stopped server.
>>
>> How large is your music collection?
>>
>> -D
>> --
>> "History, I believe, furnishes no example of a priest-ridden people
>> "maintaining a free civil government.
>> This marks the lowest grade of ignorance of which their civil as well
>> as religious leaders will always
>> avail themselves for their own purposes." --Thomas Jefferson to
>> Alexander von Humboldt, 1813.
>>