View Full Version : official 5.4.1 scan issue

Allan Hise
2005-03-14, 10:26
I installed the recently-made-oficial 5.4.1 (yes, I know, I'm behind the
times) slimserver over the weekend, and 2 probably related oddities have
popped up.

I initiated a rescan after instal, and it never seemed to end. So I wiped
the cache (deleted the slimserver.db file) and tried again, letting it run
overnight. No dice. Still running in the morning. I ran it again, this tim
efrom the command line with --d_scan, and it seems like it went through
the entire library without errors (though there is no indication in the
log whether it finished...)

Todaym after work (trying yet again), it still hadn't finished and the CPU
was pegged by perl. I quit the server and restarted it, and the web
interface shows a number of tracks that looks right (and it isn't trying
to scan!)

Everything seems in order, music is playing (though some of the special
German characters didn't get recorded properly while others --even with
the same character-- did), except that one of my iTunes playlist s are
showing up.

Since I started writing this, the server has started to rescan, and the
CPU is once again pegged. It seems to be an issue with iTunes playlists...

Now for the nitty gritty...
OS X 10.3.8, 1.35 GHz G4, 1.128 GB RAM, Using iTunes
Itunes Library is a network drive, NFS mounted from a Linux server.
Didn't have problems of this sort with a pervious 5.4.x

Anyway... Hopefully the attention isn't so focused on 6.0b1 to help me
with this. Any ideas? Debug flags that could help??