PDA

View Full Version : First Impressions 6.0B1-1



Richard
2005-03-13, 12:36
Dan, some answers to you questions ...

-------Original Message-------
> From: "Dan Sully" <dan (AT) slimdevices (DOT) com>
> Subject: [slim] First Impressions 6.0B1-1
> Sent: 13 Mar 2005 17:51:19
>
> * Richard shaped the electrons to say...
>
> >I made the move to 6.0 B1-1 last evening, with mixed results. Here are my findings:
>
> Richard - thanks for the feedback. Most of these have been fixed in the
> latest nightly builds, and will be in the next beta release.
>
> > 1) FLAC. I have been running 5.4 since it was releases with never a skip
> > on FLAC files. Every FLAC file I play on 6.0 B1-1 results in playback
> > skips. Any suggestions for improving throughput? I am using a wired
> > Ethernet Network with 3 Wired Squeezeboxes. (I did reboot my server and the
> > problem seems to have cleared up somewhat – I still get drops when doing
> > HTML web interface commands while music is playing)
>
> Has the server finished scanning all your files? Did you have a large
> playlist loaded while viewing the web UI?

Yes, server completed scan. About 20 songs in playlist while browsing other selections (not searching). I think CPU on this box is an Intel 1.6Mhz, and 512MB RAM if my memory serves me right.
>
> > 2) The overall speed of the Web Interface is slower. Sometimes
> > considerably slower. I have never had any sort of performance issues with
> > the web interface under 5.4 and below, and have started experiencing some
> > frustrating delays when using the server html.
>
> What browser are you using? Fishbone skin it looks like?

Fishbone.
>
> Are there specific operations that you find are slower?

No, browsinsg from Artist to Album, or Album to Song is enough.
>
> > 3) Searching. Simply put, a frustrating step backward. When using the
> > Fishbone interface, I could search for an artist out of my 17,000 simply
> > from the browse pages, now I have to go to advanced search. When I try the
> > Search Music screen, all I get is the names of songs returned not artists.
> > This is not at all accommodating for the way I look for music.
>
> This has been fixed - search now displays Artist, Album and Tracks. It sounds
> like you hit the fallback search, instead of the "Live Search"
>

Great, can't wait.

> > 4) The Advanced Search is a good step forward as a search improvement, NOT a replacement.
>
> Agreed.
>
> > 5) I thought cataloging music into the DB would be faster based on claims.
> > I found it to take about the same amount of time as 5.4.
>
> Things like MP3 scanning have been speed up, but we're also doing a lot more
> at the database level. I've personally heard varying degrees of improvment,
> but most have been improved.
>
> Know what type of system you're running, and specifics of your library would help.

Library: 1254 albums with 17179 songs by 1215 artists - mostly MP3 (192kb and higher) - some FLAC and OGG

Running Redhat 9
>
> > 6) Fishbone Skin does not always display correctly. My personal choice of
> > skin ends up losing its navigation on the left frame after some actions (I
> > think after being in Server Settings and hitting Home link).
>
> I'll let kdf answer this, as he maintains this skin.

Great.

>
> > 7) Even after new install, had to select Wipe Cache to begin proper song
> > cataloguing. Not obvious for the new user.
>
> Did you install any of the 6.0 alpha releases?

No, cleaned out 5.4 and did RPM -i slim*
>
> > 8) Ogg files worked straight out of the box where I had to do some tweaking under 5.4.
>
> Great.
>
> -D
> --
> They're techno trousers, ex-NASA, fantastic for walkies!
>