PDA

View Full Version : Problem starting 6.0b1on FC3 (was Problem starting 5.4.0on FC3)



Patrick Dixon
2005-03-13, 12:21
OK, can't get 5.4.0 to start properly, so I've moved on to 6.0!

Slimserver now fails to start at all!

Using "perl -w ./slimserver.pl" from "/usr/local/slimserver" I get the
following error output:

Can't locate auto/DBI/connect_cac.al in @INC (@INC contains:
/usr/local/slimserver/Plugins /usr/local/slimserver
/usr/local/slimserver/CPAN
/usr/local/slimserver/CPAN/arch/5.8.6/i686-linux-thread-multi
/usr/local/slimserver/CPAN/arch/5.8.6/i686-linux-thread-multi/auto
/usr/local/slimserver/CPAN/arch/5.8/i686-linux-thread-multi
/usr/local/slimserver/CPAN/arch/5.8/i686-linux-thread-multi/auto
/usr/local/slimserver/CPAN/arch/i686-linux-thread-multi
/usr/local/ActivePerl-5.8/lib/5.8.6/i686-linux-thread-multi
/usr/local/ActivePerl-5.8/lib/5.8.6
/usr/local/ActivePerl-5.8/lib/site_perl/5.8.6/i686-linux-thread-multi
/usr/local/ActivePerl-5.8/lib/site_perl/5.8.6
/usr/local/ActivePerl-5.8/lib/site_perl .) at
/usr/local/slimserver/Slim/DataStores/DBI/DataModel.pm line 106

Any ideas?

Thanks,
Patrick

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of Patrick Dixon
Sent: 13 March 2005 11:03
To: Slim Devices Discussion
Subject: [slim] Problem starting 5.4.0 on FC3


Anyone got any ideas on this please?

Surely someone most know how to get 5.4 working properly on FC3?

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of Patrick Dixon
Sent: 12 March 2005 11:01
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] Problem starting 5.4.0 on FC3


I'm trying to get slimserver V5.4.0 running on an FC3 machine, prior to
moving up to V6 when my SB2 arrives.

I can start slimserver from the command line once I'm logged in, but it
doesn't seem to want to start up from the init scripts on boot.

The slimserver.log contains the messages:

mkdir /root//usr: Permission denied at
/usr/local/slimserver/CPAN/Template/Provider.pm line 377
mkdir /root//usr: Permission denied at
/usr/local/slimserver/CPAN/Template/Provider.pm line 377
mkdir /root//usr: Permission denied at
/usr/local/slimserver/CPAN/Template/Provider.pm line 377
mkdir /root//usr: Permission denied at
/usr/local/slimserver/CPAN/Template/Provider.pm line 377
mkdir /root//usr: Permission denied at
/usr/local/slimserver/CPAN/Template/Provider.pm line 377
mkdir /root//usr: Permission denied at
/usr/local/slimserver/CPAN/Template/Provider.pm line 377

Obviously /root//usr doesn't look like a valid directory, but how and where
is the string being generated?

Can anyone help?

Thanks
Patrick