PDA

View Full Version : Re: Re: 6.0b1 - Web interface hogging CPU



James Dunn
2005-03-12, 16:11
Dan,

Bug 1059 assigned.

Cheers,

James

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of Dan Sully
Sent: Saturday, March 12, 2005 10:53 PM
To: Slim Devices Discussion
Subject: [slim] Re: Re: 6.0b1 - Web interface hogging CPU

* JJ shaped the electrons to say...

>I just installed 6.0b1 and I'm finding the same thing. On my
>hyperthreaded P4 3.0GHz it pegs one of the virtual CPUs. Using latest
>version of IE with the default SlimServer skin. Both the server and
>client running on the same XP Pro machine.
>
>What I'm seeing is that during playback of either mp3 or flac files CPU
>utilization always starts out normal, then when the right-hand frame
>auto-refreshes, the browser will often display a message in the browser's
>status bar like:
>
>Downloading picture http://localhost:9000/html/images/b_delete_white.gif
>
>And it just hangs there with that status message and an hourglass icon.
>I've seen it hang downloading other gifs beside this one (nav_all_sel.gif,
>nav_albums.gif, etc) . CPU utilization of slim.exe goes to 50% - one of
>the two virtual processors. If I Stop, Pause, or manually refresh the
>frame then CPU usage goes back to normal. If I just clse the browser, it
>does not.
>
>SlimServer doesn't always hang up after an auto-refresh while serving
>these images, but I notice that if it does then the browser will no longer
>auto-refresh the frame and the server sits in this state indefinitely.

We'll track this down. Could you file a bug?

Thanks.

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?