PDA

View Full Version : show artist next to album



Peter Grashoff
2005-03-12, 12:40
I really like the NEW MUSIC option in the new slimserver 6.0b1. But it would be even nicer to my opinion to also include the artist next to the album name, or the other way around (configurable order!). I am not very good with album names, so I hardly recognise them. Showing it together with the artist will be much more functional. The same can be said for the browse by album option.

Dan Sully
2005-03-12, 13:36
* James Dunn shaped the electrons to say...

>I don’t normally use the web interface at all so I’m not sure if this is a
>consistent problem….
>
>My server service has been running for about 5 hours and, whilst the web
>interface was OK to start with, it now hogs 100% bandwidth, killing the
>music. The initial draw and updates run v-e-r-y slowly and I’ve never been
>patient enough to let them complete (more than 20 secs). Kill the browser
>and the CPU runs at about 80-90% for about 10 seconds afterwards before
>recovering and operating normally (about 17-20%) with music OK again.

James - what version of the server are you using? And which browser too?

Thanks.

-D
--
On second thought, let's not go to Camelot. It is a silly place.

Dan Sully
2005-03-12, 13:42
* James Dunn shaped the electrons to say...

>Dan,
>
>Sorry - 6.0b1 and IE 6.0

Ok - and what was the server doing whilst the cpu hog was happening? Playing
music? Paused? Nothing at all?

Are you running XP or 2000?

Thanks.

-D
--
This knob controls the thing that changes when you turn it. - noah

Dan Sully
2005-03-12, 13:53
* James Dunn shaped the electrons to say...

>Server info:
>RH 7.1
>Celeron 1.1
>512Mb memory.
>About 5500 tracks.
>6 x Slimp3s
>1 x Squeezebox

Ah, sorry - I missed that before. :)

>Playing music in one room only (I think - unless my wife was doing something). The server is dedicated to Slimserver and the process is niced to prioritise over everything else. No other apps or UI interaction.
>
>I've just re-started the server service and I have the same problem (even after leaving for about 20 mins).

Could you run the server with --d_http debugging turned on? It will produce a decent amount of output.

-D
--
This knob controls the thing that changes when you turn it. - noah

JJ
2005-03-12, 15:50
I just installed 6.0b1 and I'm finding the same thing. On my
hyperthreaded P4 3.0GHz it pegs one of the virtual CPUs. Using latest
version of IE with the default SlimServer skin. Both the server and
client running on the same XP Pro machine.

What I'm seeing is that during playback of either mp3 or flac files CPU
utilization always starts out normal, then when the right-hand frame
auto-refreshes, the browser will often display a message in the browser's
status bar like:

Downloading picture http://localhost:9000/html/images/b_delete_white.gif

And it just hangs there with that status message and an hourglass icon.
I've seen it hang downloading other gifs beside this one (nav_all_sel.gif,
nav_albums.gif, etc) . CPU utilization of slim.exe goes to 50% - one of
the two virtual processors. If I Stop, Pause, or manually refresh the
frame then CPU usage goes back to normal. If I just clse the browser, it
does not.

SlimServer doesn't always hang up after an auto-refresh while serving
these images, but I notice that if it does then the browser will no longer
auto-refresh the frame and the server sits in this state indefinitely.


----- Original Message -----
From: "Dan Sully" <dan (AT) slimdevices (DOT) com>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Saturday, March 12, 2005 1:53 PM
Subject: [slim] Re: 6.0b1 - Web interface hogging CPU


>* James Dunn shaped the electrons to say...
>
>>Server info:
>>RH 7.1
>>Celeron 1.1
>>512Mb memory.
>>About 5500 tracks.
>>6 x Slimp3s
>>1 x Squeezebox
>
> Ah, sorry - I missed that before. :)
>
>>Playing music in one room only (I think - unless my wife was doing
>>something). The server is dedicated to Slimserver and the process is
>>niced to prioritise over everything else. No other apps or UI
>>interaction.
>>
>>I've just re-started the server service and I have the same problem
>>(even after leaving for about 20 mins).
>
> Could you run the server with --d_http debugging turned on? It will
> produce a decent amount of output.
>
> -D
> --
> This knob controls the thing that changes when you turn it. - noah
>

Dan Sully
2005-03-12, 15:52
* JJ shaped the electrons to say...

>I just installed 6.0b1 and I'm finding the same thing. On my
>hyperthreaded P4 3.0GHz it pegs one of the virtual CPUs. Using latest
>version of IE with the default SlimServer skin. Both the server and
>client running on the same XP Pro machine.
>
>What I'm seeing is that during playback of either mp3 or flac files CPU
>utilization always starts out normal, then when the right-hand frame
>auto-refreshes, the browser will often display a message in the browser's
>status bar like:
>
>Downloading picture http://localhost:9000/html/images/b_delete_white.gif
>
>And it just hangs there with that status message and an hourglass icon.
>I've seen it hang downloading other gifs beside this one (nav_all_sel.gif,
>nav_albums.gif, etc) . CPU utilization of slim.exe goes to 50% - one of
>the two virtual processors. If I Stop, Pause, or manually refresh the
>frame then CPU usage goes back to normal. If I just clse the browser, it
>does not.
>
>SlimServer doesn't always hang up after an auto-refresh while serving
>these images, but I notice that if it does then the browser will no longer
>auto-refresh the frame and the server sits in this state indefinitely.

We'll track this down. Could you file a bug?

Thanks.

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?