PDA

View Full Version : Suddenly can't start SlimServer on Linux



Steve Bernard, Jr
2005-03-11, 10:24
I updated my SlimServer installation to the newest svn version this
morning, and now every time I try to start it I get a message that
says,

Can't listen on port 3483 for Slim protocol: Address already in use at
/opt/slimserver/Slim/Networking/Slimproto.pm line 53.

I thought maybe something was up with the current version, so I've
downloaded a couple nightlies and tried them, but I get the same
result, even after rebooting.

This is Ubuntu Linux 4.10 with perl 5.8.4

Anyone have a suggestion? I don't really know much of what I'm doing on Linux.

-Steve

Jack Coates
2005-03-11, 10:58
Steve Bernard, Jr wrote:
> I updated my SlimServer installation to the newest svn version this
> morning, and now every time I try to start it I get a message that
> says,
>
> Can't listen on port 3483 for Slim protocol: Address already in use at
> /opt/slimserver/Slim/Networking/Slimproto.pm line 53.
>

Either slimserver is already running, or something else is using its
network port. As root, ps aux | grep slimserver.

> I thought maybe something was up with the current version, so I've
> downloaded a couple nightlies and tried them, but I get the same
> result, even after rebooting.
>
> This is Ubuntu Linux 4.10 with perl 5.8.4
>
> Anyone have a suggestion? I don't really know much of what I'm doing on Linux.
>
> -Steve
>

Steve Bernard, Jr
2005-03-11, 11:22
On Fri, 11 Mar 2005 09:58:04 -0800, Jack Coates wrote:
> Steve Bernard, Jr wrote:
> > I updated my SlimServer installation to the newest svn version this
> > morning, and now every time I try to start it I get a message that
> > says,
> >
> > Can't listen on port 3483 for Slim protocol: Address already in use at
> > /opt/slimserver/Slim/Networking/Slimproto.pm line 53.
> >
>
> Either slimserver is already running, or something else is using its
> network port. As root, ps aux | grep slimserver.

sudo ps aux | grep slimserver

gives me:

steve 4014 0.0 0.1 1816 560 pts/0 S+ 13:07 0:00 grep slimserver

So that's not it.


Aha, I had given up on using PuTTY for port forwarding, but it still
seemed to be trying to make a connection on 3483 and 9000. I wiped
all the settings and now it's cool.

Thanks much,

-Steve

Phil Karn
2005-03-11, 23:25
Jack Coates wrote:

> Either slimserver is already running, or something else is using its
> network port. As root, ps aux | grep slimserver.

That won't show if another process is listening to that port.

If you have the "lsof" (list open files) command, that's a better way to
get the information you need. E.g., if I do

sudo lsof | grep TCP

on the Linux machine that runs my slimserver, I'll get (heavily edited):


slimserve 32635 slimserver 8u IPv4 5470505 TCP
*:3483 (LISTEN)
slimserve 32635 slimserver 9u IPv4 5470506 TCP
*:9000 (LISTEN)
slimserve 32635 slimserver 10u IPv4 5470507 TCP
*:9090 (LISTEN)
slimserve 32635 slimserver 11u IPv4 5709439 TCP
homer.local.ka9q.net:3483->192.168.1.31:35348 (ESTABLISHED)
slimserve 32635 slimserver 12u IPv4 5709440 TCP
homer.local.ka9q.net:3483->otto.local.ka9q.net:33030 (ESTABLISHED)
slimserve 32635 slimserver 13u IPv4 5520472 TCP
homer.local.ka9q.net:9000->milhouse.wi.local.ka9q.net:51407 (ESTABLISHED)
slimserve 32635 slimserver 32u IPv4 5718345 TCP
homer.local.ka9q.net:9000->otto.local.ka9q.net:33036 (ESTABLISHED)


This shows that process ID 32635, named slimserve(r), is listening on
TCP ports 3483, 9000 and 9090. Chances are you'll find some old
slimserver process still bound to one of the needed ports, and that's
keeping you from starting a new one. Kill the old ones and try again.

--Phil