PDA

View Full Version : Perl version for Slimserver 6?



Richard Elen
2005-03-11, 10:19
> From: Dan Sully <dan (AT) slimdevices (DOT) com>

* Richard Elen shaped the electrons to say...
>> ...finding things in the list archives is a full-time
>> occupation if it's a common term.
>
> Indeed. Have you tried searching here: http://forums.slimdevices.com/ ?
That was rather what I meant; ie 'yes' :)

> The minimum is perl 5.6.0. But if you can avoid that, I'll be a lot happier. :)
> The recommended version is 5.8.3 and above.

Thanks! Exactly what I needed to know.

> What type of system are you running on?
It's a NetMax 4.x system, which is RedHat with 2.4 kernel. To provide a
rather friendly web admin front-end, it runs a vast set of scripts which
use an earlier Perl version. However the version that the rest of the
machine sees is 5.6.1, as evidenced by the fact that SS 5.4.0 works
pretty well on it (with some minor hiccups mentioned elsewhere). Thus if
I want to upgrade the Perl version I need to make sure I update the
right one and /only/ the right one.

--Richard E