PDA

View Full Version : 6.0 Nightly on a Freebsd box



tj
2005-03-08, 12:58
Thanks Dan. I have moved it farther along but now find this error:

Had to create DBI::_dbistate unexpectedly at
/usr/local/lib/perl5/5.8.6/mach/DynaLoader.pm line 253.
Use of uninitialized value in subroutine entry at
/usr/local/lib/perl5/5.8.6/mach/DynaLoader.pm line 253.

I see this was discussed awhile back on the developers list. My DBI version
is 1.47. Do I need to roll it back? And if so, do you know how?

Thanks again!!

* Maik Musall shaped the electrons to say...

>> It sounds like DBI isn't fully installed. If you do: perl -MDBI -e 'print

>> $DBI::VERSION."\n"'
>> what does it print out?
>
>$ perl -MDBI -e 'print $DBI::VERSION."\n"' 1.38

You need to be on DBI version 1.46

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Dan Sully
Sent: Tuesday, March 08, 2005 3:11 AM
To: Slim Devices Discussion
Subject: [slim] 6.0 Nightly on a Freebsd box

* Thomas J. Angstman shaped the electrons to say...

>I installed 6.0 by extracting the files to /usr/local/slimserver.
>
>Copied my old slimserver.sh into /usr/local/etc/rc.d - this simply runs
>slimserver.pl with the -daemon switch.
>
>Running the slimserver.sh script returns the following:

Hi TJ - we're not currently shipping with FreeBSD specific compiled modules
-
as no one has been keeping them up to date. I believe someone on the list
was
working on a port however. The quick fix is to install Compress::Zlib via
ports, or manually. In addition, DBI and DBD::SQLite are minimally required.

-D
--
<nil> It sucks to discover that you are the foremost authority on some set
of things when you've got a problem.

Jason Holtzapple
2005-03-08, 13:00
tj wrote:
> Thanks Dan. I have moved it farther along but now find this error:
>
> Had to create DBI::_dbistate unexpectedly at
> /usr/local/lib/perl5/5.8.6/mach/DynaLoader.pm line 253.
> Use of uninitialized value in subroutine entry at
> /usr/local/lib/perl5/5.8.6/mach/DynaLoader.pm line 253.
>
> I see this was discussed awhile back on the developers list. My DBI version
> is 1.47. Do I need to roll it back? And if so, do you know how?

Download 1.46 from www.cpan.org. Unpack the archive and do a standard
# perl Makefile.PL
# make
# make test
# make install

Dan Sully
2005-03-08, 13:02
* tj shaped the electrons to say...

>I see this was discussed awhile back on the developers list. My DBI version
>is 1.47. Do I need to roll it back? And if so, do you know how?

You can grab it from:

http://mirrors.kernel.org/CPAN/authors/id/T/TI/TIMB/DBI-1.46.tar.gz

-D
--
This knob controls the thing that changes when you turn it. - noah