PDA

View Full Version : Slimbox-Newbie with questions



Christian Pernegger
2005-02-25, 12:38
Hi all!

I just received my Squeezebox yesterday, and so far I love it!

First of all a bit about my configuration:

SlimServer 6.0a 2005-02-25, generic tarball
server machine: Dual 1.6 GHz Athlon MP, 1 GB RAM
The Squeezebox is bridged into my WLAN via an AirPort Express :)

Music playback works flawlessly and the quality is well above my
expectations even over analog, however I've run into a few useability
glitches:

1) The daytime screensaver does not work all that well. The seconds get
updated in irregular intervals of 2-4 seconds only, sometimes it goes a
second backwards even.

2a) The way the text input for the search (via remote) works seems a little
strange to me.
Sometimes I press (example) the ABC key once, and before I can press it a
second time the A gets accepted, it moves to the next char and my second
press (which should have made the A into a B) spawns a B or two after the A.
I tried changing the Text Entry Timing - it did not affect that problem.
Essentially the system behaves as if the timeout was zero in these cases.
Tends to happen from third letter onwards - maybe the timeout counts total
entry time instead of entry time for current letter by mistake?

2b) When the jump-to-next-letter timeout kicks in the cursor will move one
position to the right and display "=>'. If I now press the same letter key
on the remote again it is overwritten, as it should be. (i. e. M - timeout -
O - timeout - N gives [MON]) When the key I press is not identical to the
one pressed before the timeout the arrow stays intact and the letter will be
put after it. (M - timeout - A gives [M=>D], thus putting an arrow in the
middle of the search string. Pressing M - A works of course if there is no
timeout, but the SlimServer seems to throw these in at random. These two
issues combined make sure I can't type 5 letters without doubling back, much
less "blind". I use this kind of text input a lot on my cell - would be
great if it worked.

3) When I press and hold one of the volume keys on the remote the display
will flicker back and forth between the volume bar and whatever was there
before (e. g. now playing)

Seems to me some kind of timing is royally screwed up here. Just for testing
I tried the Windows server on my workstation - no problems in 6.x or 5.4.
Then I downgraded to 5.4 on linux - problems persist. So it's either
something on the linux machine (too fast, too slow, bug in my perl version)
or in the linux version of SlimServer.

4) On an unrelated note: I have a lot of Japanese tracks tagged in Japanese.
(in whatever flavour of unicode foobar2000 uses for ID3v2) The tags display
on the 6.0 server (nice!) but not on the Squeezebox, which was to be
expected. Are there any Japanese font hacks? Failing that any hack that
would allow the Squeezebox to use something in the vein of
ALBUM_TRANSCRIBED, TITLE_TRANSCRIBED if the original tags can't be rendered?
I need the romanized version anyway, for generating file and folder names.

Sorry this post got so long, I hope you're still with me. I'll go poke the
source for a bit now, but I don't know much perl :) Any comments, tips and
pointers appreciated.

C.