PDA

View Full Version : 6.0a1 Installation



Chris O'Shannassy
2005-02-25, 04:23
Hi;

Hopefully this can just be chalked up to my extremely limited
knowledge of perl & slimserver, but the "alpha" version of six isn't
working for me. I've currently just extracted the files under my home
account (don't want to mess with my functioning version) and am getting
the following message when trying to start the server:

./slimserver.pl --daemon
Can't locate auto/Compress/Zlib/autosplit.ix in @INC (@INC contains:
/home/gzisper/SlimServer_v2005-02-23
/home/gzisper/SlimServer_v2005-02-23/CPAN
/home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8.5/i686-linux
/home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8.5/i686-linux/auto
/home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8/i686-linux
/home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8/i686-linux/auto
/home/gzisper/SlimServer_v2005-02-23/CPAN/arch/i686-linux /etc/perl
/usr/lib/perl5/site_perl/5.8.5/i686-linux /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i686-linux
/usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i686-linux
/usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i686-linux
/usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i686-linux
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.5/i686-linux /usr/lib/perl5/5.8.5
/usr/local/lib/site_perl /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i686-linux /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.4/i686-linux .) at
/usr/lib/perl5/5.8.5/AutoLoader.pm line 160.
at /home/gzisper/SlimServer_v2005-02-23/CPAN/Compress/Zlib.pm line 16


Is there something blatant that I'm missing or is this a "bug"? Or at
least a requirement for more info in the installation.txt file?

Chris

Jason Holtzapple
2005-02-25, 07:19
Chris O'Shannassy wrote:
> Hi;
>
> Hopefully this can just be chalked up to my extremely limited
> knowledge of perl & slimserver, but the "alpha" version of six isn't
> working for me. I've currently just extracted the files under my home
> account (don't want to mess with my functioning version) and am getting
> the following message when trying to start the server:

It sounds like you need to install Compress::Zlib from CPAN ...

> ./slimserver.pl --daemon
> Can't locate auto/Compress/Zlib/autosplit.ix in @INC

kdf
2005-02-25, 10:40
Quoting Chris O'Shannassy <zipser (AT) optusnet (DOT) com.au>:

> Hi;
>
> Hopefully this can just be chalked up to my extremely limited
> knowledge of perl & slimserver, but the "alpha" version of six isn't
> working for me. I've currently just extracted the files under my home
> account (don't want to mess with my functioning version) and am getting
> the following message when trying to start the server:
>
> ./slimserver.pl --daemon
> Can't locate auto/Compress/Zlib/autosplit.ix in @INC (@INC contains:
> /home/gzisper/SlimServer_v2005-02-23
> /home/gzisper/SlimServer_v2005-02-23/CPAN
> /home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8.5/i686-linux
> /home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8.5/i686-linux/auto
> /home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8/i686-linux
> /home/gzisper/SlimServer_v2005-02-23/CPAN/arch/5.8/i686-linux/auto
> /home/gzisper/SlimServer_v2005-02-23/CPAN/arch/i686-linux /etc/perl
> /usr/lib/perl5/site_perl/5.8.5/i686-linux /usr/lib/perl5/site_perl/5.8.5
> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i686-linux
> /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i686-linux
> /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i686-linux
> /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i686-linux
> /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl
> /usr/lib/perl5/5.8.5/i686-linux /usr/lib/perl5/5.8.5
> /usr/local/lib/site_perl /usr/lib/perl5/site_perl/5.8.0
> /usr/lib/perl5/site_perl/5.8.0/i686-linux /usr/lib/perl5/site_perl/5.8.2
> /usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.4
> /usr/lib/perl5/site_perl/5.8.4/i686-linux .) at
> /usr/lib/perl5/5.8.5/AutoLoader.pm line 160.
> at /home/gzisper/SlimServer_v2005-02-23/CPAN/Compress/Zlib.pm line 16
>
>
> Is there something blatant that I'm missing or is this a "bug"? Or at
> least a requirement for more info in the installation.txt file?

what system are you running on? Does having 4 different versions of Perl
installed not cause you other problems elsewhere?

-kdf

Chris O'Shannassy
2005-02-25, 14:07
Hi;

Your comments are true enough, and I've now installed this extra
module, and am up and running. Hey, at least I know a _little_ more
about perl now.... A couple of comments on the installation though:

I was already running perl 5.8.5, the installation requirements for
slimserver were only asking for >= 5.6 so I figured I was good.
Maybe any extra Perl modules which aren't part of a basic perl
install should be included in the slimserver archive?
Mmm, okay I just looked and they already are, just not for my
version of perl..... Okay not sure on the solution to that one.

And kdf: I'm running gentoo linux, and no it's never caused
problems before, but.... I only really have one version of Perl
(5.8.5), it was just some sloppy housekeeping on my part (directories
for the older versions still there but without full versions of perl
inside them).

Thanks

Chris

Jason Holtzapple wrote:

> Chris O'Shannassy wrote:
>
>> Hi;
>>
>> Hopefully this can just be chalked up to my extremely limited
>> knowledge of perl & slimserver, but the "alpha" version of six isn't
>> working for me. I've currently just extracted the files under my
>> home account (don't want to mess with my functioning version) and am
>> getting the following message when trying to start the server:
>
>
> It sounds like you need to install Compress::Zlib from CPAN ...
>
>> ./slimserver.pl --daemon
>> Can't locate auto/Compress/Zlib/autosplit.ix in @INC
>
>

Chris O'Shannassy
2005-02-25, 15:17
Okay and if anybody is interested, I also had similar problems with
the DBI module, (and then the 1.38 version of the DBI module which I
installed was too old, it needed the 1.46 version)
Anyway, it's all working now. (Hopefully, just need to wander over
the squeezebox and check....)

Chris


Chris O'Shannassy wrote:

> Hi;
>
> Your comments are true enough, and I've now installed this extra
> module, and am up and running. Hey, at least I know a _little_ more
> about perl now.... A couple of comments on the installation though:
>
> I was already running perl 5.8.5, the installation requirements for
> slimserver were only asking for >= 5.6 so I figured I was good.
> Maybe any extra Perl modules which aren't part of a basic perl
> install should be included in the slimserver archive?
> Mmm, okay I just looked and they already are, just not for my
> version of perl..... Okay not sure on the solution to that one.
>
> And kdf: I'm running gentoo linux, and no it's never caused
> problems before, but.... I only really have one version of Perl
> (5.8.5), it was just some sloppy housekeeping on my part (directories
> for the older versions still there but without full versions of perl
> inside them).
>
> Thanks
>
> Chris
>
> Jason Holtzapple wrote:
>
>> Chris O'Shannassy wrote:
>>
>>> Hi;
>>>
>>> Hopefully this can just be chalked up to my extremely limited
>>> knowledge of perl & slimserver, but the "alpha" version of six isn't
>>> working for me. I've currently just extracted the files under my
>>> home account (don't want to mess with my functioning version) and am
>>> getting the following message when trying to start the server:
>>
>>
>>
>> It sounds like you need to install Compress::Zlib from CPAN ...
>>
>>> ./slimserver.pl --daemon
>>> Can't locate auto/Compress/Zlib/autosplit.ix in @INC
>>
>>
>>

Dan Sully
2005-02-25, 16:10
* Chris O'Shannassy shaped the electrons to say...

> Okay and if anybody is interested, I also had similar problems with
>the DBI module, (and then the 1.38 version of the DBI module which I
>installed was too old, it needed the 1.46 version)
> Anyway, it's all working now. (Hopefully, just need to wander over
>the squeezebox and check....)

Chris - we try and include binary modules for the popular operating systems,
including Windows, OSX 10.2 and 10.3, RedHat, Debian and a more recent SuSE.

Unfortunately Gentoo is more of a moving target, moreso because the user can
(has to?) compile perl themselves, so although the major number (5.8) will be
the same, the architecture specific part: i686-linux, i686-linux-multi,
i686-linux-thread, etc can change with many variations.

-D
--
You know, for kids.

Chris O'Shannassy
2005-02-26, 01:07
Dan Sully wrote:

> * Chris O'Shannassy shaped the electrons to say...
>
>> Okay and if anybody is interested, I also had similar problems
>> with the DBI module, (and then the 1.38 version of the DBI module
>> which I installed was too old, it needed the 1.46 version)
>> Anyway, it's all working now. (Hopefully, just need to wander
>> over the squeezebox and check....)
>
>
> Chris - we try and include binary modules for the popular operating
> systems,
> including Windows, OSX 10.2 and 10.3, RedHat, Debian and a more recent
> SuSE.
>
> Unfortunately Gentoo is more of a moving target, moreso because the
> user can
> (has to?) compile perl themselves, so although the major number (5.8)
> will be
> the same, the architecture specific part: i686-linux, i686-linux-multi,
> i686-linux-thread, etc can change with many variations.
>
> -D

That's alright. When I realised what the problem was I understood
the size of the issue.... You can't provide all the perl modules for
_every_ version of Perl in the download, that'd be silly. Maybe listing
somewhere in the installation.txt file that it needs modules X and XX as
well as Perl would be nice though?
Anyways, it's all working fine now, so I'm happy. (grin)

Chris