PDA

View Full Version : Weird wireless problem



Florent DANIEL
2005-02-23, 15:22
Hello,

I'm seeing strange things since I've changed my wireless router. I've recently
bought a Linksys WRT54GS to replace my Trust Speedshare Turbo Pro (which had
poor performance and configurability for broadband access). My Squeezebox is
a wired one, plugged to an Asus WL-330G in adaptor mode. I hadn't bought the
Squeezebox wireless because I wanted 802.11g and WAP on my network.

Anyway, with my previous router the playback of flac files was fine, but
tonight I've tried it with the Linksys, and the result is :

- some files plays, but with micro-dropouts
- some files don't event output anything, although the meta-informations
(title, album, artist...) are displayed correctly on the Squeezebox's screen

When I take a look at the traffic on my server (a Gentoo Linux) with jnettop,
I see very few bytes transmitted during the playing of the second type of
file (around 200 Bps ~ 1600 bps ~ 1,6 kbps), and after 10-20 seconds there's
even nothing transmitted on the port 9000. The first type seems to transmit a
full stream (one typical output is around 180 kBps ~ 1440 kbps). I don't
understand why there's no output from files which were playing correctly
before. I've tried to plug the Squeezebox with a RJ45 cable, the problem
disappeared instantly.

So I'm looking for information from other owners of WRT54G or WRT54GS
routers : have you already seen this kind of problem ? What did you do to
solve it ? What could I try, knowing that I've already done the following
with no success :

- change channel
- use 802.11b
- update to latest firmware (v3.37.6 from Linksys, I've also tried HyperWRT)

My main PC seems to be fine, although I hadn't tried to stream to it (copying
of files over NFS goes at speed between 1 and 2 MBps, which should translate
to something between 8 and 16 Mbps).

Thanks in advance for the suggestions,

Florent

Florent DANIEL
2005-02-24, 06:22
Florent DANIEL <fdaniel@...> writes:

> My main PC seems to be fine, although I hadn't tried to stream to it
>(copying of files over NFS goes at speed between 1 and 2 MBps, which
> should translate to something between 8 and 16 Mbps).

Update : Tested Softsqueeze on my main PC, it runs in the same exact problem
(no output on some files, scratchy playing on others...). MP3 streams plays
fine. The adaptors are the same type on Squeezebox and PC (Asus WL-330g).

Florent

bejammin075
2005-05-07, 11:12
Your problem sounds similar to mine. I don't know what is causing your problem, but maybe if you look at my problem that will give you some clues.

I have a WRT54GS router too. Before that I had the WR*K*54G (That's NOT the same as the WR*T*54G), which was terrible. The WRK54G was a piece of crap. The WRT54GS seems to be better. After quite a while of very irritating playback problems, I just figured out that the problem goes away if I'm wired by ethernet cable to the router.

My squeezebox and an external drive (with mp3s) are both attached to the wireless router. Ideally, I want to have the wireless connection from ly laptop to the router. The laptop (W2K) running slimserver has a WPC54GS Notebook adapter also from Linksys. The problem was present over a range of slimserver updates.

I described my problem in a lot of detail here:
http://forums.slimdevices.com/showthread.php?t=13451&highlight=wireless+album

My problem files always display correct ID info on the squeezebox too. But the problem is very consistent: it plays the first 10 seconds, then jumps to the next song. The problem always effects a whole album, every time I have checked. I'm curious if your problem affects whole albums. Actually, rereading your original post, I think you could be having my problem plus an additional problem. For me, I think this issue is my last problem with the squeezebox before I can say I'm in musical nirvana. I've been tinkering for months to get it to work, and most of the time battleing multiple problems that have bizarre properties as I upgrade the components and the configuration of my home network. I was surprised that a problem like mine seemed to be resolved by connecting by ethernet to the router. So I've only just realized that it's a wireless problem. I don't have any ideas yet. In my case, it doesn't make sense that only whole albums would skip. I can't find any rhyme or reason to the albums that are affected. Often, it's about 1/2 of an artists ablums, so it's really annoying.

So some questions for you:
Does the problem go away if your computer is wired to your router?
When you have a track that won't play, have you ever observed the whole album to have the same problem?

bejammin075
2005-05-07, 11:14
I posted the wrong link above in my post. I'm not sure how to link to a different post, but here's the title:
Some albums: each track plays 1st 10 seconds,then jumps to next track