PDA

View Full Version : Problems after Upgrade from 6 nightly 1/26 to 6 nighly 2/19



Peter J. Pouliot
2005-02-19, 09:38
Hi all,

Every so often I upgrade to the nightly. Upgraded today, and now I'm
experiencing a couple of issues.

Here's some background.


Slimserver Running on dual proc g4 w/ 768mb ram running 10.3.8

Box is only used as a slimserver (except for today, I forgot my
powerbook power adapter at work)


So here's what's happening.


1. None of the extra pluggins I had installed work any longer. They
appear in the webui as a blank w/ a checkbox.

I'm getting the following in the log when I enabled pluggin debugging.


2005-02-19 10:34:00.3977 Undefined string: STOCK QUOTES

requested language: EN

failsafe language: EN

2005-02-19 10:34:00.3982 Undefined string: LIVE MUSIC ARCHIVE


2. The performance has degraded. Even while typing this email. The
songs will start skipping during use of other applications. And even
when starting a new track I get multiple pops and clicks before the
song actually starts. (This if from my slimp3, I haven't tried my
squeezebox yet to see if it's the same.)


Previously I was running a 6.0 nightly from 1/26. I tried to revert
back however the slimserver won't start

Peter J.Pouliot
2005-02-19, 10:17
One other thing i've found. It seems that the remote key mapping is
wrong for the 5 key.

p


On Feb 19, 2005, at 11:38 AM, Peter J. Pouliot wrote:

> Hi all,
>
> Every so often I upgrade to the nightly. Upgraded today, and now I'm
> experiencing a couple of issues.
>
> Here's some background.
>
>
> Slimserver Running on dual proc g4 w/ 768mb ram running 10.3.8
>
> Box is only used as a slimserver (except for today, I forgot my
> powerbook power adapter at work)
>
>
> So here's what's happening.
>
>
> 1. None of the extra pluggins I had installed work any longer. They
> appear in the webui as a blank w/ a checkbox.
>
> I'm getting the following in the log when I enabled pluggin debugging.
>
>
> 2005-02-19 10:34:00.3977 Undefined string: STOCK QUOTES
>
> requested language: EN
>
> failsafe language: EN
>
> 2005-02-19 10:34:00.3982 Undefined string: LIVE MUSIC ARCHIVE
>
>
> 2. The performance has degraded. Even while typing this email. The
> songs will start skipping during use of other applications. And even
> when starting a new track I get multiple pops and clicks before the
> song actually starts. (This if from my slimp3, I haven't tried my
> squeezebox yet to see if it's the same.)
>
>
> Previously I was running a 6.0 nightly from 1/26. I tried to revert
> back however the slimserver won't start
>
>

Peter Pouliot
2005-02-22, 10:43
Didn't get a response to this the other day so I'll try again. I've
updated to one of the newer nightly's and now a bunch of my pluggins are
not showing up in the web interface properly. They show up as a blank
line w/ a check next to it. Any idea's on how to fix this.

Here's what I get in the log when I set the debugging info for pluggins.

2005-02-22 12:37:57.4719 Undefined string: SCAN TIMER
requested language: EN
failsafe language: EN
2005-02-22 12:37:57.4726 Undefined string: NOSETUP - ENABLE/DISABLE ACCESS TO SERVER SETTINGS
requested language: EN
failsafe language: EN
2005-02-22 12:37:57.4732 Undefined string: LYRICS
requested language: EN

Any help is greatly appreciated.
p



On Sat, 2005-02-19 at 12:17 -0500, Peter J.Pouliot wrote:
> One other thing i've found. It seems that the remote key mapping is
> wrong for the 5 key.
>
> p
>
>
> On Feb 19, 2005, at 11:38 AM, Peter J. Pouliot wrote:
>
> > Hi all,
> >
> > Every so often I upgrade to the nightly. Upgraded today, and now I'm
> > experiencing a couple of issues.
> >
> > Here's some background.
> >
> >
> > Slimserver Running on dual proc g4 w/ 768mb ram running 10.3.8
> >
> > Box is only used as a slimserver (except for today, I forgot my
> > powerbook power adapter at work)
> >
> >
> > So here's what's happening.
> >
> >
> > 1. None of the extra pluggins I had installed work any longer. They
> > appear in the webui as a blank w/ a checkbox.
> >
> > I'm getting the following in the log when I enabled pluggin debugging.
> >
> >
> > 2005-02-19 10:34:00.3977 Undefined string: STOCK QUOTES
> >
> > requested language: EN
> >
> > failsafe language: EN
> >
> > 2005-02-19 10:34:00.3982 Undefined string: LIVE MUSIC ARCHIVE
> >
> >
> > 2. The performance has degraded. Even while typing this email. The
> > songs will start skipping during use of other applications. And even
> > when starting a new track I get multiple pops and clicks before the
> > song actually starts. (This if from my slimp3, I haven't tried my
> > squeezebox yet to see if it's the same.)
> >
> >
> > Previously I was running a 6.0 nightly from 1/26. I tried to revert
> > back however the slimserver won't start
> >
> >

Dan Sully
2005-02-22, 11:16
* Peter Pouliot shaped the electrons to say...

>Didn't get a response to this the other day so I'll try again. I've
>updated to one of the newer nightly's and now a bunch of my pluggins are
>not showing up in the web interface properly. They show up as a blank
>line w/ a check next to it. Any idea's on how to fix this.
>
>Here's what I get in the log when I set the debugging info for pluggins.
>
>2005-02-22 12:37:57.4719 Undefined string: SCAN TIMER
>requested language: EN
>failsafe language: EN
>2005-02-22 12:37:57.4726 Undefined string: NOSETUP - ENABLE/DISABLE ACCESS TO SERVER SETTINGS
>requested language: EN
>failsafe language: EN
>2005-02-22 12:37:57.4732 Undefined string: LYRICS
>requested language: EN

Peter - the Plugin API for 6.0 has changed a bit, so the plugins themselves
will need to be updated. Which plugins in particular are causing trouble?

-D
--
<noah> I used to be indecisive, but now I'm not sure.

kdf
2005-02-22, 12:00
Quoting Peter Pouliot <peter (AT) pouliot (DOT) net>:

> Didn't get a response to this the other day so I'll try again. I've
> updated to one of the newer nightly's and now a bunch of my pluggins are
> not showing up in the web interface properly. They show up as a blank
> line w/ a check next to it. Any idea's on how to fix this.
>
> Here's what I get in the log when I set the debugging info for pluggins.
>
> 2005-02-22 12:37:57.4719 Undefined string: SCAN TIMER
> requested language: EN
> failsafe language: EN
> 2005-02-22 12:37:57.4726 Undefined string: NOSETUP - ENABLE/DISABLE ACCESS TO
> SERVER SETTINGS
> requested language: EN
> failsafe language: EN
> 2005-02-22 12:37:57.4732 Undefined string: LYRICS
> requested language: EN

This depends on what you upgraded from... I'm guessing it must have been 5.4.x
or a very early 6.0

The scan timer plugin is obsolete, given that the included rescan plugin now has
this functionality. Lyrics is an old, and from all signs, not supported any
more. I expect you probably also have a version of the nosetup plugin that
arent' designed for 6.0. The friendly name of plugins needs to change for 6.0.
This output is a symptom of that, so it is your most likely cause.

In future, if you want to debug plugins, run from the command line:
c:\program files\slimserver\server\slim.exe --d_plugins
and watch the messages as your server starts. d_plugins after startup is often
not much use.

-kdf

mherger
2005-02-22, 13:17
>> Didn't get a response to this the other day so I'll try again. I've
>> updated to one of the newer nightly's and now a bunch of my pluggins are
>> not showing up in the web interface properly. They show up as a blank
>> line w/ a check next to it. Any idea's on how to fix this.
>>
>> Here's what I get in the log when I set the debugging info for pluggins.
>>
>> 2005-02-22 12:37:57.4719 Undefined string: SCAN TIMER
>> requested language: EN
>> failsafe language: EN
>> 2005-02-22 12:37:57.4726 Undefined string: NOSETUP - ENABLE/DISABLE
[..]
> more. I expect you probably also have a version of the nosetup plugin
> that
> arent' designed for 6.0. The friendly name of plugins needs to change

Yep, I did not publish a 6.0 compatible release yet (NoSetup & co.). I'll
do this soon.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

Peter Pouliot
2005-02-22, 21:32
Hmm, it said i was running 6.0 but i guess i could have been wrong.
Yeah that was just a snippet from the log, actually all my older
pluggins are not working. Was wondering if there was a quick fix.
p

On Tue, 2005-02-22 at 19:00, kdf wrote:

> Quoting Peter Pouliot <peter (AT) pouliot (DOT) net>:
>
> > Didn't get a response to this the other day so I'll try again. I've
> > updated to one of the newer nightly's and now a bunch of my pluggins are
> > not showing up in the web interface properly. They show up as a blank
> > line w/ a check next to it. Any idea's on how to fix this.
> >
> > Here's what I get in the log when I set the debugging info for pluggins.
> >
> > 2005-02-22 12:37:57.4719 Undefined string: SCAN TIMER
> > requested language: EN
> > failsafe language: EN
> > 2005-02-22 12:37:57.4726 Undefined string: NOSETUP - ENABLE/DISABLE ACCESS TO
> > SERVER SETTINGS
> > requested language: EN
> > failsafe language: EN
> > 2005-02-22 12:37:57.4732 Undefined string: LYRICS
> > requested language: EN
>
> This depends on what you upgraded from... I'm guessing it must have been 5.4.x
> or a very early 6.0
>
> The scan timer plugin is obsolete, given that the included rescan plugin now has
> this functionality. Lyrics is an old, and from all signs, not supported any
> more. I expect you probably also have a version of the nosetup plugin that
> arent' designed for 6.0. The friendly name of plugins needs to change for 6.0.
> This output is a symptom of that, so it is your most likely cause.
>
> In future, if you want to debug plugins, run from the command line:
> c:\program files\slimserver\server\slim.exe --d_plugins
> and watch the messages as your server starts. d_plugins after startup is often
> not much use.
>
> -kdf
>

kdf
2005-02-22, 21:37
Quoting Peter Pouliot <peter (AT) pouliot (DOT) net>:

> Hmm, it said i was running 6.0 but i guess i could have been wrong.
> Yeah that was just a snippet from the log, actually all my older
> pluggins are not working. Was wondering if there was a quick fix.
> p

there is, if you are up for it.

in any given plugin, find sub getDisplayName.

change:
return string('...');

to:
return '...';

that will cover most cases.

of course, if waiting is what you consider simple, many authors will eventually
update any plugins they are continuing to support.

-kdf

lsmithso
2005-04-22, 08:36
Lyrics is an old, and from all signs, not supported any
more. -kdf


Oh yes it is - but on very long timescales!

I've just uploaded version 0.4 Lyrics.pm that should fix the SlimServer 6 compatibility problems. Download it from http://slimlyrics.sourceforge.net and let me know if there are still problems with it.