PDA

View Full Version : can't get AAC support working in slimserver/Linux



David Feldman
2005-02-17, 07:39
I'm trying to get AAC support working in slimserver on SUSE Linux,
following the instructions in the FAQ. I've gotten faad2 working now.
(For anyone having trouble with this, I had to symlink a bunch of stuff
in /usr/local/lib to /usr/lib.) The AAC box is checked in the File
Types tab of slimserver configuration. But when I attempt to play an
AAC file, the player just stops and won't play, as it does for any file
it can't understand. What am I missing?

Dave

Michael Peters
2005-02-17, 18:40
On Thu, 17 Feb 2005 09:39:33 -0500, David Feldman
<mailing-lists (AT) interfacethis (DOT) com> wrote:
> I'm trying to get AAC support working in slimserver on SUSE Linux,
> following the instructions in the FAQ. I've gotten faad2 working now.
> (For anyone having trouble with this, I had to symlink a bunch of stuff
> in /usr/local/lib to /usr/lib.)

I'm not a SuSE person myself - but you shouldn't need to symlink anything.
edit /etc/ld.so.conf and add /usr/local/lib to it.

Then run /sbin/ldconfig

Then your shared libraries in /usr/local/lib will be picked up without
needing to make a bunch of symlinks.

> The AAC box is checked in the File
> Types tab of slimserver configuration. But when I attempt to play an
> AAC file, the player just stops and won't play, as it does for any file
> it can't understand. What am I missing?

Try doing the above (adding /usr/local/lib to ld.so.conf) and see if
that helps - I'm guessing that's not it (or you'd get a shared library
error) but maybe.

--
http://mpeters.us/

David Feldman
2005-02-17, 19:49
> I'm not a SuSE person myself - but you shouldn't need to symlink
> anything.
> edit /etc/ld.so.conf and add /usr/local/lib to it.
>
> Then run /sbin/ldconfig

That worked for the library problem, but as you predicted didn't solve
the main problem.

In case it's relevant: Under Server Settings > File Types, the AAC to
WAV box is checked but not the AAC to mp3. Since the slimserver stream
is mp3, is that relevant? I tried checking the AAC to mp3 box but get
this error:

Required binary was not found: [mov123] $FILE$ | [lame] --resample
44100 --silent -q $QUALITY$ -b $BITRATE$ -r - -

Lower down the list, the WAV to MP3 box _is_ checked, so it seems like
the server ought to have all the pieces...

--Dave

Aaron Zinck
2005-02-17, 20:05
"David Feldman" wrote
> > I'm not a SuSE person myself - but you shouldn't need to symlink
> > anything.
> > edit /etc/ld.so.conf and add /usr/local/lib to it.
> >
> > Then run /sbin/ldconfig
>
> That worked for the library problem, but as you predicted didn't solve
> the main problem.
>
> In case it's relevant: Under Server Settings > File Types, the AAC to
> WAV box is checked but not the AAC to mp3. Since the slimserver stream
> is mp3, is that relevant? I tried checking the AAC to mp3 box but get
> this error:
>
> Required binary was not found: [mov123] $FILE$ | [lame] --resample
> 44100 --silent -q $QUALITY$ -b $BITRATE$ -r - -
>
> Lower down the list, the WAV to MP3 box _is_ checked, so it seems like
> the server ought to have all the pieces...
>
> --Dave

Do you have bitrate limiting on? You appear not to have lame in the
slimserver bin directory (lame's not included in the distribution due to
licensing issues) and if bitrate limiting's on then any non-mp3 format will
need lame in order to be converted to mp3 format for streaming to the
squeezebox. You can either turn off bitrate limiting so that your aac is
converted to wav and then streamed to the squeezebox, or you could stick
lame in the bin directory. Or...maybe I'm way off the mark here and it's
some obscure linux problem.

kdf
2005-02-17, 20:19
Quoting Aaron Zinck <azinck3 (AT) ufl (DOT) edu>:

> "David Feldman" wrote
> > > I'm not a SuSE person myself - but you shouldn't need to symlink
> > > anything.
> > > edit /etc/ld.so.conf and add /usr/local/lib to it.
> > >
> > > Then run /sbin/ldconfig
> >
> > That worked for the library problem, but as you predicted didn't solve
> > the main problem.
> >
> > In case it's relevant: Under Server Settings > File Types, the AAC to
> > WAV box is checked but not the AAC to mp3. Since the slimserver stream
> > is mp3, is that relevant? I tried checking the AAC to mp3 box but get
> > this error:
> >
> > Required binary was not found: [mov123] $FILE$ | [lame] --resample
> > 44100 --silent -q $QUALITY$ -b $BITRATE$ -r - -
> >
> > Lower down the list, the WAV to MP3 box _is_ checked, so it seems like
> > the server ought to have all the pieces...
> >
> > --Dave
>
> Do you have bitrate limiting on? You appear not to have lame in the
> slimserver bin directory (lame's not included in the distribution due to
> licensing issues) and if bitrate limiting's on then any non-mp3 format will
> need lame in order to be converted to mp3 format for streaming to the
> squeezebox. You can either turn off bitrate limiting so that your aac is
> converted to wav and then streamed to the squeezebox, or you could stick
> lame in the bin directory. Or...maybe I'm way off the mark here and it's
> some obscure linux problem.

It IS a linux problem. mov123 doesn't exist for linux. its not lame that is
missing in this case. for linux, you need to look at FAAD. The FAQ entry for
AAC on linux is here:
http://www.slimdevices.com/su_faq.html#formats

you will need the cvs version of faad, instad of the current stable release.

-kdf

David Feldman
2005-02-18, 07:08
Thanks. I symlinked /usr/local/bin/lame and, just to be safe,
/usr/local/bin/faad into the SlimServer's Bin/i386-linux-thread-multi
directory, but it didn't change anything.

Under Player Settings > Audio, bitrate limiting is indeed on, but (a) I
don't see a way to turn it off and (b) it recognizes lame as installed.

--Dave

On Feb 17, 2005, at 22:05, Aaron Zinck wrote:

> Do you have bitrate limiting on? You appear not to have lame in the
> slimserver bin directory (lame's not included in the distribution due
> to
> licensing issues) and if bitrate limiting's on then any non-mp3 format
> will
> need lame in order to be converted to mp3 format for streaming to the
> squeezebox. You can either turn off bitrate limiting so that your aac
> is
> converted to wav and then streamed to the squeezebox, or you could
> stick
> lame in the bin directory. Or...maybe I'm way off the mark here and
> it's
> some obscure linux problem.

David Feldman
2005-02-18, 08:38
> It IS a linux problem. mov123 doesn't exist for linux. its not lame
> that is
> missing in this case. for linux, you need to look at FAAD. The FAQ
> entry for
> AAC on linux is here:
> http://www.slimdevices.com/su_faq.html#formats
>
> you will need the cvs version of faad, instad of the current stable
> release.

Thanks, but no luck so far:

I removed /usr/local/bin/faad and /usr/local/lib/*faad*. Then I
downloaded the tarball for the 9/15 code snapshot of faad2, compiled,
and installed it. No change...same problem.

--Dave

kdf
2005-02-18, 11:14
Quoting David Feldman <mailing-lists (AT) interfacethis (DOT) com>:

> Thanks. I symlinked /usr/local/bin/lame and, just to be safe,
> /usr/local/bin/faad into the SlimServer's Bin/i386-linux-thread-multi
> directory, but it didn't change anything.
>
> Under Player Settings > Audio, bitrate limiting is indeed on, but (a) I
> don't see a way to turn it off and (b) it recognizes lame as installed.

if you have a squeezebox or use softsqueeze, there should be an option for 'no
limit'. Slimp3 only handles mp3, same with http client (winamp, xmms, itunes),
so there is always a bitrate limit of maximum 320kbps to force mp3 playback.

-kdf

kdf
2005-02-18, 11:18
Quoting David Feldman <mailing-lists (AT) interfacethis (DOT) com>:

> > It IS a linux problem. mov123 doesn't exist for linux. its not lame
> > that is
> > missing in this case. for linux, you need to look at FAAD. The FAQ
> > entry for
> > AAC on linux is here:
> > http://www.slimdevices.com/su_faq.html#formats
> >
> > you will need the cvs version of faad, instad of the current stable
> > release.
>
> Thanks, but no luck so far:
>
> I removed /usr/local/bin/faad and /usr/local/lib/*faad*. Then I
> downloaded the tarball for the 9/15 code snapshot of faad2, compiled,
> and installed it. No change...same problem.
>
did you change the lines to the convert.conf as mentioned?

you may have to change the -f parameter, or even remove it. recent versions of
faad have ben messing with the function of -f. you may want to check here:
http://forums.slimdevices.com/
and do a search on faad to find out a lot more detail on this.

if you are still bitrate limited, you need to alter the mov mp3 * * line in a
similar way, and restart the server. check the --d_source output to make sure
it uses the correct command line.


-kdf

David Feldman
2005-02-19, 10:46
> did you change the lines to the convert.conf as mentioned?
>
> you may have to change the -f parameter, or even remove it. recent
> versions of
> faad have ben messing with the function of -f. you may want to check
> here:
> http://forums.slimdevices.com/
> and do a search on faad to find out a lot more detail on this.
>
> if you are still bitrate limited, you need to alter the mov mp3 * *
> line in a
> similar way, and restart the server. check the --d_source output to
> make sure
> it uses the correct command line.

Aha!! The problem was in convert.conf. If I modify it as described in
the FAQ, it looks like the softsqueeze ignores it because it specifies
"squeezebox." If, instead, I use "softsqueeze" or *, it works. So:
mov wav * *
[faad] -w -f 2 $FILE$

Phew. Incidentally, is there any way to do this so an http client like
iTunes can play aac's as well?

Thanks for the help.

--Dave

kdf
2005-02-19, 14:25
Quoting David Feldman <mailing-lists (AT) interfacethis (DOT) com>:

> Phew. Incidentally, is there any way to do this so an http client like
> iTunes can play aac's as well?
mov mp3 * *
[faad] -w -f 2 $FILE$ | [lame] ...

and copy the full lame command from one of the others.

-kdf

David Feldman
2005-02-20, 08:37
>> Phew. Incidentally, is there any way to do this so an http client like
>> iTunes can play aac's as well?
> mov mp3 * *
> [faad] -w -f 2 $FILE$ | [lame] ...
>
> and copy the full lame command from one of the others.

I tried this with every version of the lame command I saw, but each
time the same thing happens: The server launches faad about 20 times
and lame once, and if I'm not running in daemon mode just keeps
printing faad information to the screen. The client stalls. Any ideas?
Here are the relevant lines:

mov mp3 * *
[faad] -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q
$QUALITY$ -b $BITRATE$ -r -x - -


--Dave