View Full Version : Problems with m4a playback on Wired Squeezebox

Ian Henry
2005-02-14, 16:58
I'm having some problems trying to get any m4a files to play, and I was
hoping some may be able to help?

Using SlimServer 5.4.0, OS: Win 2000

The song looks like it starts to play, but you just receive a "pop"
through the speakers and then it skips to the next track

The output below is from turning on the d_source debugging...

2005-02-14 23:47:26.8383 enabled
2005-02-14 23:47:26.8384 Found command: [mov123] $FILE$
2005-02-14 23:47:26.8402 Matched Format: aif Type: mov Command: [mov123]
2005-02-14 23:47:26.8404 openSong: this is an mov file:
2005-02-14 23:47:26.8406 file type: mov format: aif inrate:
130.901715987826 maxRate: 0
2005-02-14 23:47:26.8408 command: [mov123] $FILE$
2005-02-14 23:47:26.8421 Using command for conversion:
"C:\MP3\Dance\_Newest\Nite_Life 20\2-01 Petalpushing.m4a" |
2005-02-14 23:47:26.8448 Streaming with format: aif
2005-02-14 23:47:26.8562 00:04:20:05:5e:b6 New play mode: play
2005-02-14 23:47:26.8605 00:04:20:05:5e:b6: Current playmode: play
2005-02-14 23:47:27.7962 Read to end of file or pipe
2005-02-14 23:47:27.7968 end of file or error on socket, opening next
song, (song pos: 112(tell says: . 0 but true), totalbytes: 0)
2005-02-14 23:47:27.7970 opening next song...

I tried running the command above and it produces the following error

NativePathNameToFSSpec failed on source file
C:\MP3\Dance\_Newest\Nite_Life 20\2-01 Petalpushing.m4a with -2095

I also tried just firing up mov123 with no parameters and it just
crashes - is this normal?

Any help would be greatly appreciated.



2005-02-15, 01:17
I had similar problems lately and was able to fix them be
(re-)installing the latest Apple Quicktime 6.5.2 from
http://www.apple.com/quicktime/download/ - make sure to choose the
"recommended" install option, not the "minimal".

HTH Alexander

mailto:narya.de (AT) gmail (DOT) com