PDA

View Full Version : SlimServer 5.4



Jeff Seifer
2005-02-14, 08:12
So, I finally got around to figuring out what was wrong with my 5.4 install.

I gradually added in my music folders until it crashed, then found the
offending folder.
Sure enough, there was a shortcut in the folder to itself, so the server
must be recursing through itself over and over until it runs out of
memory... I removed the shortcut and voila, I'm up and running with 5.4.

Anyway, this did not happen with the older server and it should probably be
fixed in newer ones if it isn't already.

Jeff

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Jeff Seifer
Sent: Monday, December 20, 2004 11:17 PM
To: 'Slim Devices Discussion'
Subject: [slim] SlimServer 5.4

I uninstalled 5.4, reinstalled, cleared my event log and ran the service.
It chugs along (slowly) indexing my files (I have 10000 tracks).
About 2 hours into the process, the service stops and I check the event log:

"The description for Event ID ( 0 ) in Source ( Application ) cannot be
found. The local computer may not have the necessary registry information or
message DLL files to display messages from a remote computer. You may be
able to use the /AUXSOURCE= flag to retrieve this description; see Help and
Support for details. The following information is part of the event: Perl
interpreter failed."

So, I decided to uninstall and install 4.2.6 again.

First off, it's running much faster, It indexed all 10869 tracks in < 1
hour. I tried playing tracks while it was indexing - it worked perfectly.
Still working fine after indexing finished.

So, something is definitely messed up with 5.4 compared to the older server.


I'd really like to get the new server working.
Thanks,
Jeff


-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
Sent: Monday, December 20, 2004 6:50 PM
To: Slim Devices Discussion
Subject: [slim] SlimServer 5.4

Quoting Jeff Seifer <slimp3 (AT) seifer (DOT) net>:


> Anyone have any ideas as to what might be happening or how to debug
> the problem?

start with the event viewer to see if it has any messages as to why the
service stops. You can find that in control panel, administrative tools.

-kdf

kdf
2005-02-14, 10:43
Quoting Jeff Seifer <slimp3 (AT) seifer (DOT) net>:

> So, I finally got around to figuring out what was wrong with my 5.4 install.
>
> I gradually added in my music folders until it crashed, then found the
> offending folder.
> Sure enough, there was a shortcut in the folder to itself, so the server
> must be recursing through itself over and over until it runs out of
> memory... I removed the shortcut and voila, I'm up and running with 5.4.
>
> Anyway, this did not happen with the older server and it should probably be
> fixed in newer ones if it isn't already.

This is a known bug:

http://bugs.slimdevices.com/show_bug.cgi?id=576

Unfortunately, none of the solutions presented offered satisfactory final
results, as you can see from the comments.

-kdf