PDA

View Full Version : Too many MP3 files ?



PAUL WILLIAMSON
2005-02-11, 07:33
>>> mailing (AT) vincen (DOT) org 2/11/2005 9:26:08 AM >>>
> Hi,
> I'm running 5.4.1 nightly builds and I'd like to know
>if 705 albums with 9231 titles by 1275 artists is too much to
>manage or not by SlimServer ? as I encounter some strange
>issues since I added a lot of files to my sound library !
> Thanks in advance
>
>Vincèn

Nah, last I checked I was at 2,102 albums, 23,402 tracks
by 2,763 artists. Using 5.4.1 nightly from about a week
or so ago.

Paul

Vince
2005-02-11, 09:40
In fact I think I found the origin of the issue. I didn't rebuild the
database of slimserver when I moved it on my new linux box. I added
yesterday a bunch of mp3 files on it and asked SlimServer to reindex
the whole library. Now I notice that all albums with accents in name
get some strange characters instead such as é is replaced by ~A© What's
wrong ? something in perl modules ?

Thanks for your ideas

Vincèn

Le 11 févr. 05, à 15:33, PAUL WILLIAMSON a écrit :

>>>> mailing (AT) vincen (DOT) org 2/11/2005 9:26:08 AM >>>
>> Hi,
>> I'm running 5.4.1 nightly builds and I'd like to know
>> if 705 albums with 9231 titles by 1275 artists is too much to
>> manage or not by SlimServer ? as I encounter some strange
>> issues since I added a lot of files to my sound library !
>> Thanks in advance
>>
>> Vincèn
>
> Nah, last I checked I was at 2,102 albums, 23,402 tracks
> by 2,763 artists. Using 5.4.1 nightly from about a week
> or so ago.
>
> Paul
>
>
>

kdf
2005-02-11, 10:26
Quoting Vince <mailing (AT) vincen (DOT) org>:

> In fact I think I found the origin of the issue. I didn't rebuild the
> database of slimserver when I moved it on my new linux box. I added
> yesterday a bunch of mp3 files on it and asked SlimServer to reindex
> the whole library. Now I notice that all albums with accents in name
> get some strange characters instead such as é is replaced by ~A© What's
> wrong ? something in perl modules ?
>
> Thanks for your ideas

ah, this is an easy one :)

These characters fall into the extended character set and are not supported by
5.4.x of SlimServer. Version 6.0 is in Alpha and is available as a nightly
build for download. This does support Unicode/utf8 characters as well as a
database backend with SQL data-handling

-kdf

Vince
2005-02-11, 11:09
>> In fact I think I found the origin of the issue. I didn't rebuild the
>> database of slimserver when I moved it on my new linux box. I added
>> yesterday a bunch of mp3 files on it and asked SlimServer to reindex
>> the whole library. Now I notice that all albums with accents in name
>> get some strange characters instead such as é is replaced by ~A©
>> What's
>> wrong ? something in perl modules ?
>>
>> Thanks for your ideas
> These characters fall into the extended character set and are not
> supported by
> 5.4.x of SlimServer. Version 6.0 is in Alpha and is available as a
> nightly
> build for download. This does support Unicode/utf8 characters as well
> as a
> database backend with SQL data-handling

Sorry kdf but I'm pretty sure it displayed before the accents correctly
! I think I updated some perls modules in my linux system for something
else and that's what caused the problem ! Do you know what dependency
slimserver has when you install the RPM version ?

Thanks

Vincèn