PDA

View Full Version : WIN XP PRO SP2 Ad Hoc



Cafe Nervosa
2005-02-09, 21:59
Still not getting this to work.
It was working for a while, but only for about 15 minutes at a time then the
SB does not connect to the server.
I have completely reinstalled according to the stuff below.
Please help me see what I am missing.

Status:
On the SB Wireless signal strength is 48%.
I reinstalled the NetGear Driver WG311v2_v2_0_0_7.
The WiFi can connect to the neighbours unsecured Access Point.
On Net Stumbler I see four access points with signals of minimum 50%.

Thanks
Derek

Here’s my unsuccessful version of a How to set up slimserver and a Squeeze
Box (hereafter SB) for use with a desk top computer running XP Pro SP2, an
internal WiFi 802.11g PCI card (Netgear WG311 v2) over an Ad Hoc network.
I assume you looked for and are interested in the stuff I write here because
you are having trouble and didn’t find info in the user manual.

I had trouble setting the system up because there are lots of wireless
networks around my place. The automatic setup tried to connect to other
networks. So to avoid this I set the networking manually on the SB.

HOWEVER Where the manual says “ ensure your network setting are
correct” I was at a loss, so I hope this helps some other newbies get this
cool device working.

Using the NETGEAR configuration software I created a profile:
Profile: SqueezeBOX
Network Name (SSID): Squeeze
Then I saved the profile (I frequently forgot to save it)


In the WIN XP network connections I set the IP address of the wireless card
to:
IP Address; 10.0.10.10
Subnet Mask: 255.255.255.0
Defult Gateway – I left it blank.
To do this:
Open Windows “My Network Places”
View Network Connections
Right Click on the wireless card
In the General Tab select “Internet Protocol (TCP/IP)” and look at
Properties.
Enable the “Use the Follow IP address”
Enter IP Address 010.000.010.010
Enter Subnet Mask: 255.255.255.0

Firewalls
I believe the slimserver software opened the XP Firewall to allow the SB to
access the slimserver on the PC. I would advise keeping a firewall enabled
and use the exceptions function to allow the SB to operate.

For the WIN XP firewall go:
Open Windows “My Network Places”
View Network Connections
Right Click on the wireless card
Hit the Advanced tab
Hit Firewall Setting button
Check to ensure the ON radio button is on.
Hit the Exceptions tab
Verify that you see entries like this:
Port number: 3483 (TCP) - Name: SlimServer Control
Port number: 3483 (UDP) - Name: SlimDiscovery
Port Number: 9000 (TCP) - Name: SlimServer Web

If not, enter them manually with the add program function

Verify the IP address of your wireless card;
In the NETGEAR configuration ABOUT tab I verify and see the Device IP
address is: 10.0.10.10

On the Squeezebox I set it up using static IP address

+++++++++++++++++++++++
Ian Wrote
To configure the player using static IP addresses, choose "Enter everything
manually". This will take you to a series of four screens, where you can
enter the IP address of the player, your netmask, your router's address, and
the IP address of your server. To enter the addresses, use the left and
right buttons to select the digit to edit, and up/down to change that
digit. Press "ok" to go the next screen (the 'ok' button is just below and
to the right of the arrow buttons).
+++++++++++++++++++++++

View the setting and these are:
Wireless IP Address: 10.0.10.20
Wireless Subnet Mask: 255.255.255.0
Wireless Gateway: 10.0.10.10
Slimserver IP: 10.0.10.10
Wireless Network Name: Squeeze
Wireless Encryption: none
Wireless Signal Strength: 87%
Wireless MAC address: 00:04:20:05:8c:73
Sueezebox firmware vervion: 40
Obtain IP Address: Manually (static)



TROUBLESHOOTING

When trouble shooting there are a couple useful things to use.

If you are trying to set up a wireless system you might want eliminate the
software as the problem you can Uninstall and re-install the slimserver.
This costs nothing but a little time and lets you start fresh.

Try setting it up with the SB set on the desk beside the PC. This will
ensure that distance and stuff is not the problem,


Try setting the system up wired.
When the SB is connected directly to the PC Ethernet connection use a cross
over cable (also known as a Null cable).
http://www.linuxselfhelp.com/HOWTO/Ethernet-HOWTO-5.html says to make a null
cable:
If you are only connecting two machines, it is possible to avoid using a
hub, by swapping the Rx and Tx pairs (1-2 and 3-6).
If you hold the RJ-45 connector facing you (as if you were going to plug it
into your mouth) with the lock tab on the top, then the pins are numbered 1
to 8 from left to right. The pin usage is as follows:

Pin Number Assignment
---------- ----------
1 Output Data (+)
2 Output Data (-)
3 Input Data (+)
4 Reserved for Telephone use
5 Reserved for Telephone use
6 Input Data (-)
7 Reserved for Telephone use
8 Reserved for Telephone use

++++++++++++++++++++++++++
FROM THE SB USER MANUAL FAQ

Since Squeezebox Ethernet interface is 10 megabit Ethernet, you can use
either a CAT3 or CAT5 Ethernet cable. If you are connecting directly to a
computer you will need a crossover cable. If you are connecting to a
router, a regular straight cable will work just fine.
++++++++++++++++++++++++++


Use the ping command from the PC to determine if the SB will respond.
I got help from:
++++++++++++++++++++++++++
Mark Schlack wrote:
OK, so as I understand it, you have a PC at 10.0.10.10 that you want to
connect to a Squeezebox at 10.0.10.20. One way to tell if you have basic
connectivity is to launch the Command Prompt (Run CMD) and do ping
10.0.10.20 from the PC. You will either get a response telling you there's
no connection or one telling you the time it takes to make a round trip. No
connection means just that -- something's not working. Any connection means
there's something in the software on either side that's preventing the
Slimserver from connecting with the Squeezebox.
++++++++++++++++++++++++++
Also useful is route print command.
++++++++++++++++++++++++++
Ian wrote:
Get up a Windows command prompt and type "route print". Amongst the
information it prints will be a list of "Active Routes". What *should* be
happening is that everything on your 10.0.10.XXX subnet (as defined by the
combination of IP address and netmask you put on your Netgear card) should
be routing through the Netgear card. This will appear as a line like this:

Network Destination Netmask Gateway Interface
10.0.10.0 255.255.255.0 10.0.10.10 10.0.10.10

This essentially says that any traffic originating on your computer destined
for an address which matches 10.0.10.XXX (i.e. only paying attention to the
first three octets, because of the netmask) should go out through the
interface "10.0.10.10" which is your wireless card. So it will route
10.0.10.20 through the wireless card, because it matches that rule in the
first three octets (10.0.10.XXX).

If you don't have a line which matches what I've put above, then let us know
what "route print" *does* print out.
++++++++++++++++++++++++++




----Original Message Follows----
From: "Cafe Nervosa" <cafe_nervosa (AT) hotmail (DOT) com>
Reply-To: Slim Devices Discussion <discuss (AT) lists (DOT) slimdevices.com>
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] WIN XP PRO SP2 Ad Hoc
Date: Tue, 08 Feb 2005 17:23:04 +0000


Ian,
Thanks for your help setting the network parameters.
Correcting the wireless gateway IP setting on the SB allowed me to connect.

I find however, the connection doesn't work for very long. It runs for a
few/20 minutes than losses the connection. It then doesn't re-connect. I
have to unplug the SB and reboot the PC to get connected again. I will try
searching for troubleshooting tips on the issue of improving the connection
and using the blocking function, password and encryption.

Derek

----Original Message Follows----
From: "Cafe Nervosa" <cafe_nervosa (AT) hotmail (DOT) com>
Reply-To: Slim Devices Discussion <discuss (AT) lists (DOT) slimdevices.com>
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] WIN XP PRO SP2 Ad Hoc
Date: Mon, 07 Feb 2005 19:19:02 +0000


Ian,
Thanks Ian,
You are correct. One of the settings I made on the SB is:
>Wireless Gateway 0.0.0.0 (which you say is incorrect)

I didn't know that I should make this entry the IP of the WiFi card on the
PC.
When I work on this tonight I will adjust the setting to:
Wireless Gateway IP 10.0.10.10

Does anyone know of a:
How To Connect SB to WIN XP using Wireless Ad Hac Network?
If not, I would edit the help messages I have recieved and post it to this
fourm.
Also, for a wired Ad Hoc Network and the SB, is a null (wires crossed)
network cable required or do you use a regular ethernet cable?

Thanks


Derek


----Original Message Follows----
From: Ian Payton <ian_gmane (AT) bibbly (DOT) demon.co.uk>
Reply-To: Slim Devices Discussion <discuss (AT) lists (DOT) slimdevices.com>
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] WIN XP PRO SP2 Ad Hoc - No connection
Date: Mon, 07 Feb 2005 08:03:36 +0000

Hi,

Cafe Nervosa wrote:
>Here is is output of route print.
>I think I do have the line you asked for.

Yes you do. This line means that anything for 10.0.10.20 will be routed by
your windows box through the 10.0.10.10 adaptor:

> Network Destination Netmask Gateway Interface
> 10.0.10.0 255.255.255.0 10.0.10.10 10.0.10.10

However...

>Still not connected.

What about the Wireless Gateway setting on the SB? I use DHCP on a wired
network here, so I haven't had to do this myself, but the help files say
this:

> Using static IP address
>
> To configure the player using static IP addresses, choose "Enter
> everything manually". This will take you to a series of four screens,
> where you can enter the IP address of the player, your netmask, your
> router's address, and the IP address of your server. To enter the
> addresses, use the left and right buttons to select the digit to edit,
> and up/down to change that digit. Press "ok" to go the next screen
> (the 'ok' button is just below and to the right of the arrow buttons).

The equivalent of "router" here is "wireless gateway". You showed this as
being set to 0.0.0.0 earlier. Can you change that to the IP address of your
XP box?

Ian