PDA

View Full Version : album not playing



Allan Hise
2005-02-09, 13:12
On Wed, 9 Feb 2005, kdf wrote:

> Quoting Allan Hise <allan (AT) hise (DOT) org>:
>
> > Tonight I found an album that will not play on my squeezebox.
> > All tracks are mp3 files, and as far as I remember it was encoded in the
> > same way as all my other working mp3s. The tracks play fine in iTunes and
> > on my ipod, but are simply skipped when they in a playlist on the
> > slimserver.
> >
> > Any ideas how to track down this problem? Debug flags I should turn on??
>
> d_source, then play the song, check the log :)

Thanks for the quick response kdf (do you ever sleep?)

Here is what seems lrelevant from the logs...

***
2005-02-09 20:54:12.1961 00:04:20:05:77:5a: Switching to mode play from
stop
2005-02-09 20:54:12.2101 openSong on:
file:///private/Network/Servers/thoth/usr/local/mp3/Ani%20DiFranco/Little%20Plastic%20Castle/06%20Deep%20Dish.mp3
2005-02-09 20:54:12.2119 openSong: getting duration 217.6, size , endian
and offset for
file:///private/Network/Servers/thoth/usr/local/mp3/Ani%20DiFranco/Little%20Plastic%20Castle/06%20Deep%20Dish.mp3
2005-02-09 20:54:12.2120 openSong: not bothering opening file with zero
size or duration
2005-02-09 20:54:12.2149 Couldn't open song. Stopping.
2005-02-09 20:54:12.2151 opening next song...
***

Hmmmm why does it think the size is zero?

kdf
2005-02-09, 13:22
Quoting Allan Hise <allan (AT) hise (DOT) org>:

file:///private/Network/Servers/thoth/usr/local/mp3/Ani%20DiFranco/Little%20Plastic%20Castle/06%20Deep%20Dish.mp3
> 2005-02-09 20:54:12.2120 openSong: not bothering opening file with zero
> size or duration
> 2005-02-09 20:54:12.2149 Couldn't open song. Stopping.
> 2005-02-09 20:54:12.2151 opening next song...
> ***
>
> Hmmmm why does it think the size is zero?

coudl be something corrupt in the header, perhaps. Try ripping and encoding the
track again.

-kdf