PDA

View Full Version : Playing unprotected .m4a files on Linux WORKING,but not ideally.



Dave Owen
2005-02-01, 15:36
>mov mp3 * *
> [faad] -w -f 1 $FILE$ | [lame] --resample 44100 -x --silent -q
9 -b $BITRATE$
- -
>
>[faad] -w -f 2 $FILE$

Top-notch advice, and it worked, so thank you. However, there appear to
be two issues that are going to prevent me from using this (which isn't
your fault, of course, just the way things are):

1. It fills the log with "decoding" progress messages;
2. It completes the faad conversion before starting the lame conversion,
and on my machine (Pentium Pro 450) that faad can only work at about 18x
realtime -- that means quite a long wait before the stream starts. This
is the deal-breaker, I think.

Looks like I'll just manually convert the files from unprotected .m4a to
..mp3 using faad and lame at the command line en masse. :) Thanks again
for your help, though.

kdf
2005-02-01, 16:15
Quoting Dave Owen <dowen (AT) sapient (DOT) com>:

> >mov mp3 * *
> > [faad] -w -f 1 $FILE$ | [lame] --resample 44100 -x --silent -q
> 9 -b $BITRATE$
> - -
> >
> >[faad] -w -f 2 $FILE$
>
> Top-notch advice, and it worked, so thank you. However, there appear to
> be two issues that are going to prevent me from using this (which isn't
> your fault, of course, just the way things are):
>
> 1. It fills the log with "decoding" progress messages;
> 2. It completes the faad conversion before starting the lame conversion,
> and on my machine (Pentium Pro 450) that faad can only work at about 18x
> realtime -- that means quite a long wait before the stream starts. This
> is the deal-breaker, I think.
>
> Looks like I'll just manually convert the files from unprotected .m4a to
> .mp3 using faad and lame at the command line en masse. :) Thanks again
> for your help, though.
>
I suspect you may need a slight patch to your faad version. I believe it is a
case of teh release versions not supporting STDOUT properly. Unfortunately, I
no longer have the source code that I used any more.

-kdf

Triode
2005-02-02, 11:55
You need a version of faad based on the cvs rather than faad2. The current cvs has just been updated to add a quiet option. If you
are able to compile your own you may download from cvs from:
http://www.audiocoding.com/

I think there is still a problem that the faad process will continue to decode a track if you move onto the next one (as it does not
detect that slimserver is no longer reading data). [I did send them a patch for this, but doesn't look like it is included]

----- Original Message -----
From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Tuesday, February 01, 2005 11:15 PM
Subject: [slim] Playing unprotected .m4a files on Linux WORKING, but notideally.


> Quoting Dave Owen <dowen (AT) sapient (DOT) com>:
>
>> >mov mp3 * *
>> > [faad] -w -f 1 $FILE$ | [lame] --resample 44100 -x --silent -q
>> 9 -b $BITRATE$
>> - -
>> >
>> >[faad] -w -f 2 $FILE$
>>
>> Top-notch advice, and it worked, so thank you. However, there appear to
>> be two issues that are going to prevent me from using this (which isn't
>> your fault, of course, just the way things are):
>>
>> 1. It fills the log with "decoding" progress messages;
>> 2. It completes the faad conversion before starting the lame conversion,
>> and on my machine (Pentium Pro 450) that faad can only work at about 18x
>> realtime -- that means quite a long wait before the stream starts. This
>> is the deal-breaker, I think.
>>
>> Looks like I'll just manually convert the files from unprotected .m4a to
>> .mp3 using faad and lame at the command line en masse. :) Thanks again
>> for your help, though.
>>
> I suspect you may need a slight patch to your faad version. I believe it is a
> case of teh release versions not supporting STDOUT properly. Unfortunately, I
> no longer have the source code that I used any more.
>
> -kdf
>