PDA

View Full Version : SoftSqueeze and Live365



Roy Owen
2005-01-20, 08:34
I am unable to get softsqueeze to consistantly log in to my Live365
account, if it does log in it may or may not retrieve my presets and
then may or may not actually play the stream.

Using Softsqueeze 1.16, slimserver 5.4.1 nightly 1/10/2005

Roy
--
Do meddle in the affairs of Dragons,
for you are crunchy and good with Tabasco.

Roy Owen
2005-01-21, 06:44
A little more info. If I try to connect with 1.16 the SlimServer
grinds to a halt. If I go back to using ver 1.14 everything works as
it should.


On Thu, 20 Jan 2005 10:34:59 -0500, Roy Owen <yddraig (AT) gmail (DOT) com> wrote:
> I am unable to get softsqueeze to consistantly log in to my Live365
> account, if it does log in it may or may not retrieve my presets and
> then may or may not actually play the stream.
>
> Using Softsqueeze 1.16, slimserver 5.4.1 nightly 1/10/2005
>
> Roy
> --
> Do meddle in the affairs of Dragons,
> for you are crunchy and good with Tabasco.
>


--
Do meddle in the affairs of Dragons,
for you are crunchy and good with Tabasco.

Jim
2005-01-22, 14:46
Roy Owen wrote:
> I am unable to get softsqueeze to consistantly log in to my Live365
> account, if it does log in it may or may not retrieve my presets and
> then may or may not actually play the stream.
>
> Using Softsqueeze 1.16, slimserver 5.4.1 nightly 1/10/2005

Is there any particular message that is displayed is lieu of your
presets or the stream?

If you can provide the output from running with --d_plugins I might be
able to help.

I tested the plugin with Softsqueeze during development, so I know it
works in general.

J

Roy Owen
2005-01-23, 12:51
No, no error message the server just hangs. If I use SoftSqueeze 1.14
it works just fine, maybe it's something to do with the Java MP3
library.


On Sat, 22 Jan 2005 14:46:07 -0700, Jim <jim1128 (AT) comcast (DOT) net> wrote:
> Roy Owen wrote:
> > I am unable to get softsqueeze to consistantly log in to my Live365
> > account, if it does log in it may or may not retrieve my presets and
> > then may or may not actually play the stream.
> >
> > Using Softsqueeze 1.16, slimserver 5.4.1 nightly 1/10/2005
>
> Is there any particular message that is displayed is lieu of your
> presets or the stream?
>
> If you can provide the output from running with --d_plugins I might be
> able to help.
>
> I tested the plugin with Softsqueeze during development, so I know it
> works in general.
>
> J
>
>

rtitmuss
2005-01-24, 13:18
Roy,

Do you get an error shown in the Softsqueeze console? (look in the last
tab in the preferences window)

Regards,
Richard


On 23 Jan 2005, at 19:51, Roy Owen wrote:

> No, no error message the server just hangs. If I use SoftSqueeze 1.14
> it works just fine, maybe it's something to do with the Java MP3
> library.
>
>
> On Sat, 22 Jan 2005 14:46:07 -0700, Jim <jim1128 (AT) comcast (DOT) net> wrote:
>> Roy Owen wrote:
>>> I am unable to get softsqueeze to consistantly log in to my Live365
>>> account, if it does log in it may or may not retrieve my presets and
>>> then may or may not actually play the stream.
>>>
>>> Using Softsqueeze 1.16, slimserver 5.4.1 nightly 1/10/2005
>>
>> Is there any particular message that is displayed is lieu of your
>> presets or the stream?
>>
>> If you can provide the output from running with --d_plugins I might be
>> able to help.
>>
>> I tested the plugin with Softsqueeze during development, so I know it
>> works in general.
>>
>> J
>>
>>

Roy Owen
2005-01-25, 06:01
Richard,

Below is the cut and paste from the console window.

<<<<<>>>>>
0 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
170 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
220 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
2273 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
2513 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
2563 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
3264 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
4226 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
5297 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
6319 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
7240 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
8322 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
9263 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
10265 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
11266 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
12237 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
13289 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
14220 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
15252 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
16253 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
17245 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
18246 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
19027 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
19267 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
20249 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
21260 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
22222 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
23233 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
24205 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
25236 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
26238 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
27229 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
28240 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
29282 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
30223 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
31265 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
32226 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
33258 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
34239 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
35321 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
36272 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
37213 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
38215 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
39226 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
40248 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
41239 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
42251 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
43292 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
44233 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
45235 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
46176 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
47238 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
48219 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
49241 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
50222 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
51243 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
52275 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
53236 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
55490 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
55490 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
56261 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
57342 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
58254 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
59275 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
60256 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
61238 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
61869 [Thread-4] WARN search - checking now ... -7
62239 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
63531 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
64863 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
65584 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
66265 [Player Thread-1] INFO audiobuffer.verbose - audio buffer underrun
66365 [SlimTCP] ERROR slimproto - Exception processing frame
java.lang.NullPointerException
at com.slim.softsqueeze.player.JavaSoundPlayer.stopPl ayer(JavaSoundPlayer.java:276)
at com.slim.softsqueeze.player.AbstractPlayer.stop(Ab stractPlayer.java:52)
at com.slim.softsqueeze.Player.disconnect(Player.java :129)
at com.slim.softsqueeze.Player.slimprotoCmd(Player.ja va:96)
at com.slim.softsqueeze.Protocol$TcpSocket.run(Protoc ol.java:357)
69570 [SlimTCP] ERROR slimproto - Exception processing frame
java.lang.NullPointerException
at com.slim.softsqueeze.player.JavaSoundPlayer.startP layer(JavaSoundPlayer.java:264)
at com.slim.softsqueeze.player.AbstractPlayer.unpause (AbstractPlayer.java:72)
at com.slim.softsqueeze.Player.unpause(Player.java:25 7)
at com.slim.softsqueeze.Player.autostart(Player.java: 206)
at com.slim.softsqueeze.Player.slimprotoCmd(Player.ja va:90)
at com.slim.softsqueeze.Protocol$TcpSocket.run(Protoc ol.java:357)
94045 [SlimTCP] ERROR slimproto - Exception processing frame
java.lang.NullPointerException
at com.slim.softsqueeze.player.JavaSoundPlayer.stopPl ayer(JavaSoundPlayer.java:276)
at com.slim.softsqueeze.player.AbstractPlayer.pause(A bstractPlayer.java:62)
at com.slim.softsqueeze.Player.pause(Player.java:274)
at com.slim.softsqueeze.Player.slimprotoCmd(Player.ja va:94)
at com.slim.softsqueeze.Protocol$TcpSocket.run(Protoc ol.java:357)
95177 [SlimTCP] ERROR slimproto - Exception processing frame
java.lang.NullPointerException
at com.slim.softsqueeze.player.JavaSoundPlayer.stopPl ayer(JavaSoundPlayer.java:276)
at com.slim.softsqueeze.player.AbstractPlayer.stop(Ab stractPlayer.java:52)
at com.slim.softsqueeze.Player.disconnect(Player.java :129)
at com.slim.softsqueeze.Player.slimprotoCmd(Player.ja va:96)
at com.slim.softsqueeze.Protocol$TcpSocket.run(Protoc ol.java:357)

<<<<<end>>>>>


On Mon, 24 Jan 2005 20:18:02 +0000, Richard Titmuss
<richard_titmuss (AT) yahoo (DOT) co.uk> wrote:
> Roy,
>
> Do you get an error shown in the Softsqueeze console? (look in the last
> tab in the preferences window)
>
> Regards,
> Richard
>
>
> On 23 Jan 2005, at 19:51, Roy Owen wrote:
>
> > No, no error message the server just hangs. If I use SoftSqueeze 1.14
> > it works just fine, maybe it's something to do with the Java MP3
> > library.
> >
> >
> > On Sat, 22 Jan 2005 14:46:07 -0700, Jim <jim1128 (AT) comcast (DOT) net> wrote:
> >> Roy Owen wrote:
> >>> I am unable to get softsqueeze to consistantly log in to my Live365
> >>> account, if it does log in it may or may not retrieve my presets and
> >>> then may or may not actually play the stream.
> >>>
> >>> Using Softsqueeze 1.16, slimserver 5.4.1 nightly 1/10/2005
> >>
> >> Is there any particular message that is displayed is lieu of your
> >> presets or the stream?
> >>
> >> If you can provide the output from running with --d_plugins I might be
> >> able to help.
> >>
> >> I tested the plugin with Softsqueeze during development, so I know it
> >> works in general.
> >>
> >> J
> >>
> >>

rtitmuss
2005-01-25, 14:17
Roy,

Could you try using the JLayer mp3 decoder with Softsqueeze 1.16. You
can change the mp3 decoders in the Audio tab of the Softsqueeze preferences.

Thanks,
Richard


Roy Owen wrote:

>Richard,
>
>Below is the cut and paste from the console window.
>
><cut>
>
>
>On Mon, 24 Jan 2005 20:18:02 +0000, Richard Titmuss
><richard_titmuss (AT) yahoo (DOT) co.uk> wrote:
>
>
>>Roy,
>>
>>Do you get an error shown in the Softsqueeze console? (look in the last
>>tab in the preferences window)
>>
>>Regards,
>>Richard
>>
>>
>>On 23 Jan 2005, at 19:51, Roy Owen wrote:
>>
>>
>>
>>>No, no error message the server just hangs. If I use SoftSqueeze 1.14
>>>it works just fine, maybe it's something to do with the Java MP3
>>>library.
>>>
>>>
>>>
>>>

Roy Owen
2005-01-26, 06:52
Richard,
The sound is broken (many dropouts) and playing way too fast, sounds
like the Chipmunks. I still get some audio buffer underrunn errors
in the console.


On Tue, 25 Jan 2005 21:17:02 +0000, Richard Titmuss
<richard_titmuss (AT) yahoo (DOT) co.uk> wrote:
> Roy,
>
> Could you try using the JLayer mp3 decoder with Softsqueeze 1.16. You
> can change the mp3 decoders in the Audio tab of the Softsqueeze preferences.
>
> Thanks,
> Richard
>
>
> Roy Owen wrote:
>
> >Richard,
> >
> >Below is the cut and paste from the console window.
> >
> ><cut>
> >
> >
> >On Mon, 24 Jan 2005 20:18:02 +0000, Richard Titmuss
> ><richard_titmuss (AT) yahoo (DOT) co.uk> wrote:
> >
> >
> >>Roy,
> >>
> >>Do you get an error shown in the Softsqueeze console? (look in the last
> >>tab in the preferences window)
> >>
> >>Regards,
> >>Richard
> >>
> >>
> >>On 23 Jan 2005, at 19:51, Roy Owen wrote:
> >>
> >>
> >>
> >>>No, no error message the server just hangs. If I use SoftSqueeze 1.14
> >>>it works just fine, maybe it's something to do with the Java MP3
> >>>library.
> >>>
> >>>
> >>>
> >>>
>

rtitmuss
2005-01-27, 13:31
I have tried to see if I could recreate this problem tonight, but I
cannot get Live365 working - in fact it has never worked for me. At the
moment when I try to play a track I get the following error:

Can't use an undefined value as a symbol reference at
/home/richard/slimsever-svn/trunk/Plugins/Live365.pm line 850

Any clues anyone?

Regards,
Richard


On 26 Jan 2005, at 13:52, Roy Owen wrote:

> Richard,
> The sound is broken (many dropouts) and playing way too fast, sounds
> like the Chipmunks. I still get some audio buffer underrunn errors
> in the console.
>
>
> On Tue, 25 Jan 2005 21:17:02 +0000, Richard Titmuss
> <richard_titmuss (AT) yahoo (DOT) co.uk> wrote:
>> Roy,
>>
>> Could you try using the JLayer mp3 decoder with Softsqueeze 1.16. You
>> can change the mp3 decoders in the Audio tab of the Softsqueeze
>> preferences.
>>
>> Thanks,
>> Richard
>>
>>
>> Roy Owen wrote:
>>
>>> Richard,
>>>
>>> Below is the cut and paste from the console window.
>>>
>>> <cut>
>>>
>>>
>>> On Mon, 24 Jan 2005 20:18:02 +0000, Richard Titmuss
>>> <richard_titmuss (AT) yahoo (DOT) co.uk> wrote:
>>>
>>>
>>>> Roy,
>>>>
>>>> Do you get an error shown in the Softsqueeze console? (look in the
>>>> last
>>>> tab in the preferences window)
>>>>
>>>> Regards,
>>>> Richard
>>>>
>>>>
>>>> On 23 Jan 2005, at 19:51, Roy Owen wrote:
>>>>
>>>>
>>>>
>>>>> No, no error message the server just hangs. If I use SoftSqueeze
>>>>> 1.14
>>>>> it works just fine, maybe it's something to do with the Java MP3
>>>>> library.
>>>>>
>>>>>
>>>>>
>>>>>
>>

kdf
2005-01-27, 14:58
Quoting Richard Titmuss <richard_titmuss (AT) yahoo (DOT) co.uk>:

> I have tried to see if I could recreate this problem tonight, but I
> cannot get Live365 working - in fact it has never worked for me. At the
> moment when I try to play a track I get the following error:
>
> Can't use an undefined value as a symbol reference at
> /home/richard/slimsever-svn/trunk/Plugins/Live365.pm line 850
>
> Any clues anyone?

that's a new one :)
it seems to be just a link back to a label. Maybe re-download a copy of Live365
to make sure you have a good copy?

-kdf

rtitmuss
2005-01-27, 16:13
On 27 Jan 2005, at 21:58, kdf wrote:

> Quoting Richard Titmuss <richard_titmuss (AT) yahoo (DOT) co.uk>:
>
>> I have tried to see if I could recreate this problem tonight, but I
>> cannot get Live365 working - in fact it has never worked for me. At
>> the
>> moment when I try to play a track I get the following error:
>>
>> Can't use an undefined value as a symbol reference at
>> /home/richard/slimsever-svn/trunk/Plugins/Live365.pm line 850
>>
>> Any clues anyone?
>
> that's a new one :)
> it seems to be just a link back to a label. Maybe re-download a copy
> of Live365
> to make sure you have a good copy?

I meant to say I get the same error on both the 5.4.x branch and trunk
from subversion. So I don't think it's a bad copy.

Regards,
Richard

Jim
2005-01-28, 19:31
Richard Titmuss wrote:
>
> On 27 Jan 2005, at 21:58, kdf wrote:
>
>> Quoting Richard Titmuss
>> <richard_titmuss (AT) yahoo (DOT) co.uk>:
>>
>>> I have tried to see if I could recreate this problem tonight, but I
>>> cannot get Live365 working - in fact it has never worked for me. At the
>>> moment when I try to play a track I get the following error:
>>>
>>> Can't use an undefined value as a symbol reference at
>>> /home/richard/slimsever-svn/trunk/Plugins/Live365.pm line 850
>>>
>>> Any clues anyone?
>>
>>
>> that's a new one :)
>> it seems to be just a link back to a label. Maybe re-download a copy
>> of Live365
>> to make sure you have a good copy?
>
>
> I meant to say I get the same error on both the 5.4.x branch and trunk
> from subversion. So I don't think it's a bad copy.

Assuming I'm looking at the source code you're using, I'd be interested
in the value of $self->{Directory} set on line 346, and the value of
$xmlDirectory one line before.

What platform?

rtitmuss
2005-01-31, 13:57
Jim,

> Assuming I'm looking at the source code you're using, I'd be
> interested in the value of $self->{Directory} set on line 346, and the
> value of $xmlDirectory one line before.
>

I don't think we are. At the moment I am using the svn trunk build. The
error is:

Can't use an undefined value as a symbol reference at
..../Plugins/Live365.pm line 580.

And line 580 is at the top of 'sub getPlaylist':
${*$self}{live365_original_title} ||= Slim::Music::Info::title();

> What platform?

Redhat 8.0.

Regards,
Richard

Jim
2005-02-01, 18:00
Richard Titmuss wrote:

> Can't use an undefined value as a symbol reference at
> .../Plugins/Live365.pm line 580.
>
> And line 580 is at the top of 'sub getPlaylist':
> ${*$self}{live365_original_title} ||= Slim::Music::Info::title();

I read that as $self being undefined... you say that happens as soon as
you press play on a station, or some time later (initial call of the
routine, or in response to a timer)?

>> What platform?
>
> Redhat 8.0.

That'd good news. I developed on FC1, so I'm reasonably sure there's no
platform gotcha's between us.

Cheers,
Jim

rtitmuss
2005-02-02, 13:06
On 2 Feb 2005, at 01:00, Jim wrote:

> Richard Titmuss wrote:
>
>> Can't use an undefined value as a symbol reference at
>> .../Plugins/Live365.pm line 580.
>> And line 580 is at the top of 'sub getPlaylist':
>> ${*$self}{live365_original_title} ||= Slim::Music::Info::title();
>
> I read that as $self being undefined... you say that happens as soon
> as you press play on a station, or some time later (initial call of
> the routine, or in response to a timer)?

I suspect this might be in response to a timer, before the error I get
several:

Use of uninitialized value in string eq at /.../Slim/Utils/Timers.pm
line 147.

Sorry I should have mentioned that before, but I did not think it was
connected.

Regards,
Richard