PDA

View Full Version : Help with flac files



Arnon Meshoulam
2005-01-19, 07:55
I'm suddenly getting white noise (hissing) with flac files on the
SoftSqueeze and playing flac causes the Squeezebox to reboot!!

Ring a bell to anyone?

Files are fine (winamp plays them)
Running 5.4.01 with firmware 40
All log file shows is MP3 format error
Tried with both flac 1.1 and 1.1.1

Any clues on what to provide and how to proceed?

Output of --d_source attached


Arnon

Output of --d_source shows:
c7:b4:e4:f4:19:0c: Switching to mode play from stop
2005-01-15 12:51:03.0418 openSong on: file:///music/cd/Mati%20Caspi/The%20Best/%D7%A0%D7%97_05.flac
2005-01-15 12:51:03.0442 openSong: getting duration 192.586666666667, size 24064833, endian and offset 8936 for file:///music/cd/Mati%20Caspi/The%20Best/%D7%A0%D7%97_05.flac
2005-01-15 12:51:03.0466 undermax = 1, type = flc, softsqueeze = c7:b4:e4:f4:19:0c, lame = /usr/bin/lame
2005-01-15 12:51:03.0471 checking formats for: flc-aif-softsqueeze-c7:b4:e4:f4:19:0c
2005-01-15 12:51:03.0473 Checking to see if flc-aif-softsqueeze-c7:b4:e4:f4:19:0c is enabled
2005-01-15 12:51:03.0475 enabled
2005-01-15 12:51:03.0476 checking formats for: flc-aif-*-c7:b4:e4:f4:19:0c
2005-01-15 12:51:03.0478 Checking to see if flc-aif-*-c7:b4:e4:f4:19:0c is enabled
2005-01-15 12:51:03.0479 enabled
2005-01-15 12:51:03.0480 checking formats for: flc-aif-softsqueeze-*
2005-01-15 12:51:03.0482 Checking to see if flc-aif-softsqueeze-* is enabled
2005-01-15 12:51:03.0483 enabled
2005-01-15 12:51:03.0501 checking formats for: flc-aif-*-*
2005-01-15 12:51:03.0504 Checking to see if flc-aif-*-* is enabled
2005-01-15 12:51:03.0513 enabled
2005-01-15 12:51:03.0523 checking formats for: flc-wav-softsqueeze-c7:b4:e4:f4:19:0c
2005-01-15 12:51:03.0533 Checking to see if flc-wav-softsqueeze-c7:b4:e4:f4:19:0c is enabled
2005-01-15 12:51:03.0543 enabled
2005-01-15 12:51:03.0551 checking formats for: flc-wav-*-c7:b4:e4:f4:19:0c
2005-01-15 12:51:03.0553 Checking to see if flc-wav-*-c7:b4:e4:f4:19:0c is enabled
2005-01-15 12:51:03.0563 enabled
2005-01-15 12:51:03.0572 checking formats for: flc-wav-softsqueeze-*
2005-01-15 12:51:03.0581 Checking to see if flc-wav-softsqueeze-* is enabled
2005-01-15 12:51:03.0584 enabled
2005-01-15 12:51:03.0593 checking formats for: flc-wav-*-*
2005-01-15 12:51:03.0632 Checking to see if flc-wav-*-* is enabled
2005-01-15 12:51:03.0642 enabled
2005-01-15 12:51:03.0652 Found command: [flac] -dcs --force-raw-format --endian=little --sign=signed $FILE$
2005-01-15 12:51:03.0693 Matched Format: wav Type: flc Command: [flac] -dcs --force-raw-format --endian=little --sign=signed $FILE$
2005-01-15 12:51:03.0704 openSong: this is an flc file: file:///music/cd/Mati%20Caspi/The%20Best/%D7%A0%D7%97_05.flac
2005-01-15 12:51:03.0733 file type: flc format: wav inrate: 999.275699252285 maxRate: 0
2005-01-15 12:51:03.0743 command: [flac] -dcs --force-raw-format --endian=little --sign=signed $FILE$
2005-01-15 12:51:03.0783 Using command for conversion: "/usr/local/slimserver_dev/SlimServer_v5.4.0/SlimServer_v2004-12-03/Bin/i386-linux-thread-multi/flac" -dcs --force-raw-format --endian=little --sign=signed "/music/cd/Mati Caspi/The Best/πη_05.flac" & |
2005-01-15 12:51:03.1232 Streaming with format: wav
2005-01-15 12:51:03.5182 c7:b4:e4:f4:19:0c New play mode: play

kdf
2005-01-19, 11:01
Quoting Arnon Meshoulam <ameshoulam (AT) btconnect (DOT) com>:

> I'm suddenly getting white noise (hissing) with flac files on the
> SoftSqueeze and playing flac causes the Squeezebox to reboot!!
>
> Ring a bell to anyone?
>
> Files are fine (winamp plays them)
> Running 5.4.01 with firmware 40
> All log file shows is MP3 format error
> Tried with both flac 1.1 and 1.1.1
>
> Any clues on what to provide and how to proceed?
>

usually, white noise is a symptom of an endian mixup. however, I've never heard
of this causing reboots. You coudl perhaps confirm or rule out an endian
problem by changing your convert.conf to read:

flc wav * *
[flac] -dcs --force-raw-format --endian=big --sign=signed --skip=$START$
--until=$END$ $FILE$

restart the server and play. endian=little should be the right line, but this
would confirm the exact nature of the problem. The cause is another thing.
The server should automatically do the right thing as far as endian. From your
log, it looks like endian value is blank. I can't say offhand if that's
correct or not.

Dean would have a better idea, as I believe this part of the code was something
he added.

I'm also finding it odd that you are getting an MP3 error in the log. yoru
d_status log shows this file is being converted to WAV, not MP3. I guess if a
player was expecting mp3 and got WAV data, that might have strange effects.

cheers,
kdf