PDA

View Full Version : L/R channels sometimes reversed when using optical output



Ralph Edington
2005-01-17, 15:37
I managed to work around this problem by navigating to

/Ralph%20Edington/Brain/Preferences/

and selecting the "I don't care which channel is which" checkbox.

Of course, note that selecting this checkbox will automatically de-select
the "I'm an Audiophile" option...

;o) Sorry, couldn't resist.

RE

> -----Original Message-----
> From: discuss-bounces (AT) lists (DOT) slimdevices.com
> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of Mike Reeve
> Sent: Monday, January 17, 2005 2:22 PM
> To: discuss (AT) lists (DOT) slimdevices.com
> Subject: [slim] L/R channels sometimes reversed when using optical
> output
>
>
> Mike Reeve <reeve_mike@...> writes:
>
> > Yes, it is a real bug.
>
> Mitch
>
> I forgot to say ...
>
> The known-about bug only affects PCM not MP3 playback
> - if you have had the problem with an MP3 track then that's new :-O
>
> And it only happens sometimes!
>
> You can 'fix' it by soft resetting the Squeezebox
> (i.e. hold down the power button on the remote until it restarts)
> - keep doing this until the channels are the correct way round.
>
> Once the channels are correct then they will stay that way until
> an MP3 track is played (or the Squeezebox is restarted),
> after which they may or may not be the correct way round ...
>
> Mike
>
>
>
>

Mike Reeve
2005-01-17, 17:19
Phillip Kerman <lists@...> writes:

> Anyway, the solution that I have found--which seems pretty perfect is to
> just force all streams to come over as PCM.

Phillip

I don't think that your 'work around' is absolutely guaranteed to work ... :-O

As I understand it, the 'channel swap thing' on the digital out
occurs when the DSP chip switches from MP3 mode to PCM mode.
Unfortunately the chip powers up in MP3 mode so (for us PCM only users)
it always has to switch from MP3 mode to PCM mode ...
.... and then it is just a matter of chance
as to whether the channels are reversed :-(

Regards

Mike

Michael Scott
2005-01-18, 09:38
Quoting Ralph Edington <ralph (AT) edington (DOT) com>:

>
> I managed to work around this problem by navigating to
>
> /Ralph%20Edington/Brain/Preferences/
>
> and selecting the "I don't care which channel is which" checkbox.
>
> Of course, note that selecting this checkbox will automatically
> de-select
> the "I'm an Audiophile" option...
>
> ;o) Sorry, couldn't resist.

But apparently, the "I am a smart@$$" option cannot be deselected :-)

----------------------
- Mike Scott
- mscott (AT) pyewacket (DOT) org