PDA

View Full Version : AlienBBC v0.91 - fixed Windows version,and minor tweaksto Linux version



Raul da Silva
2005-01-13, 11:04
Jules, Triode, et al.-

I don't have problems with the Live streams like Bill has (yet), but Neil
seems to think it's an mplayer problem.

I do though have weird behavior with some of the "Other Streams".

When I try to play the Deutsche Welle streams, I get the following from slim
and then a full crash:

=========================================
Going to Item: 8
Going to Item: 21
Adding: Deutsche Welle (German) - live, index.html?menu=8.21.&play=8.21.0.
Adding: rtsp://193.159.249.25:554/farm/*/encoder/dwelle/dwelle-audio-de.rm,
index.html?menu=8.21.1.
Adding: AlienBBC Home, index.html
Going to Item: 8
Going to Item: 21
Going to Item: 0
Going to play:
rtsp://193.159.249.25:554/farm/*/encoder/dwelle/dwelle-audio-de.rm
Can't call method "model" on an undefined value at C:/Program
Files/SlimServer/server/Plugins/Alien/RTSP.pm line 47.
===========================================

Seems to crash here in RTSP.pm ---> my $player = $client->model();

-raul

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Jules Taplin
Sent: Thursday, January 13, 2005 9:23 AM
To: Slim Devices Discussion
Subject: [slim] AlienBBC v0.91 - fixed Windows version, and minor
tweaksto Linux version


Hmm. Ok. That's interesting.

We've seen this occasionally for basically ever. I've never managed to
reproduce it consistently, though. It seems to me to occur more often on
the 'Live' streams than the 'Listen Again' ones, but I certainly can't
make it happen on demand. To be more precise... I use AlienBBC to listen
to Radio 4 in the mornings before I head to work... and it goes wrong
for me probably once every 3 weeks or so.

If you've a way of making it work consistently, that'd be interesting.
If I had to hazard a guess, I'd say it's an mplayer issue, although I
couldn't hand-on-heart say that it wasn't there with alienstream, either.


-- Jules

Bill Burns wrote:

> Jules Taplin wrote:
>
>> It's bumped to version 0.91 so you can tell the difference, and it
>> has the '.ra' filetype added, which will help with most of the 'Other
>> Streams' menu, too. That's fixed on both Linux and Windows packages.
>> And I've updated the install docs to remind Windows users that we
>> like codecs if we're to get any sound out.
>
>
> I just installed the 1/13 6.0 nightly on WinXP (thanks, Dean, for
> putting slim.exe back into it!), copied over the Perl files,
> downloaded the mplayer codecs, and installed AlienBBC 0.91, and it's
> working.
>
> There's one odd glitch on both my 5.4 and 6.0 installations (running
> on two separate WinXP machines). About 10 minutes into the AlienBBC
> audio stream (any channel), the audio starts to stutter. It sounds
> like the stream is being chopped up several times a second and not
> necessarily re-assembled in the correct order. Re-selecting the same
> channel starts normal play again, but the glitch appears consistently
> after the same interval.
>
> I'm using the mplayer codecs from their "windows essential" link,
> copied into ..\Bin\MSWin32-x86-multi-thread\codecs (mplayer.exe is
> also in this directory).
>