PDA

View Full Version : Pi Zero: bluetooth not working anymore



Rnee
2019-03-24, 03:06
Hi all

I have been using a Zero as a portable player through the house, together with a BT speaker, for a few months now and it was fine until a few days ago.
Even after starting with a fresh image, the BT controller stays off; log says "Error powering on Bluetooth Adapter"
It has worked a few times since but after powering off/on, the BT connection did not come up automatically.

Any idea what might be wrong or what I could do/try?

TIA
R

paul-
2019-03-24, 05:10
If you started with a new image, did you remember to enable the Bluetooth.

You might run Diagnostics from the main web page. Look at the dmesg section towards the bottom. There should be messages when the Bluetooth tries to enable.

Rnee
2019-03-24, 13:05
Hi Paul, thanks for your reply.
By enabling bluetooth, you mean selecting Bluetooth audio in the Squeezelite settings tab, right?

Here is the part of the dmesg output related to BT:


[ 28.662650] Bluetooth: Core ver 2.22
[ 28.662798] NET: Registered protocol family 31
[ 28.662805] Bluetooth: HCI device and connection manager initialized
[ 28.664424] Bluetooth: HCI socket layer initialized
[ 28.664446] Bluetooth: L2CAP socket layer initialized
[ 28.664495] Bluetooth: SCO socket layer initialized
[ 28.688560] Bluetooth: HCI UART driver ver 2.3
[ 28.688575] Bluetooth: HCI UART protocol H4 registered
[ 28.688579] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 28.690562] Bluetooth: HCI UART protocol Broadcom registered
[ 28.911058] random: dbus-daemon: uninitialized urandom read (12 bytes read)
[ 28.931770] random: dbus-daemon: uninitialized urandom read (12 bytes read)
[ 29.432185] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 29.432196] Bluetooth: BNEP filters: protocol multicast
[ 29.432223] Bluetooth: BNEP socket layer initialized
[ 29.433675] random: bluetoothd: uninitialized urandom read (4 bytes read)
[ 29.522200] ------------[ cut here ]------------
[ 29.522990] WARNING: CPU: 0 PID: 10 at net/wireless/reg.c:416 restore_regulatory_settings+0xac/0x42c [cfg80211]
[ 29.523000] Unexpected user alpha2: "B
[ 29.523004] Modules linked in: bnep hci_uart serdev btbcm bluetooth ecdh_generic brcmfmac brcmutil cfg80211 rfkill snd_soc_bcm2835_i2s regmap_mmio snd_bcm2835(C) snd_soc_core snd_compress snd_pcm_dmaengine snd_pcm snd_timer snd fixed squashfs lz4 lz4_compress zram zsmalloc spidev spi_bcm2835 i2c_bcm2835 uio_pdrv_genirq uio

paul-
2019-03-24, 18:51
That looks like an error in the WiFi configuration. Is the WiFi working ok?

Rnee
2019-03-25, 16:21
WIFI does not seem to have any problem, I can control the device - remember: it only has WIFI, it's a Zero.
I did switch to another dedicated AP recently and with same ID and security all wireless devices worked immediately.
To be sure I also switched back to the AP from my router, same result.

Steps I took:
- wrote image to SD
- renamed & modified wpa_supplicant.conf according to https://www.picoreplayer.org/how_to_setup_wifi_on_pcp_without_ethernet.shtml
- resized FS
- selected BT audio output
- under 'Card Control', downloaded BT related files

Rebooted every time when needed but BT controller remained off.

Am I missing something?

paul-
2019-03-25, 19:04
Yes, on the wifi page, there is a setting to enable the BT radio.

It is off by default, and we have it on the wifi page, because that was a trick in the past to make wifi work better.

Rnee
2019-03-26, 03:16
Thanks A LOT Paul, that was the problem indeed.
Even though I did manage before to get the Zero running this way, I got so fixated on BT that I didn't check the WIFI tab again since this was OK. :o